Zählen von Merkmalen innerhalb einer Zelle

Bild

Betrifft: Zählen von Merkmalen innerhalb einer Zelle
von: Christian
Geschrieben am: 10.11.2003 19:28:13

Hallo Liebe Excel-Cracks,

ich bin auf der Suche nach einer Formel (nach Möglichkeit kein Makro), mit der folgende Situation gelöst werden kann:

Situationsbeschreibung:

Spalte A hat 500 Zeilen. Jede Zelle in Spalte A trägt einen bis mehrere Einträge die zu zählen sind. In diesem Fall sind es Namen mit einem anschliessenden Kennzeichen (z.b. "Maier (NA), Schulz (NB)"). Mit welcher Funktion kann ich EXCEL klar machen das ich nur die Anzahl von "(NA)" und "(NB") gezählt haben möchte (insgesamt gibt es 6 verschiedene Merkmale). Bisher habe ich es nur geschafft, das er immer nur 1 "(NA)" oder ("NB") findet....

Wäre für eure Hilfe dankbar..

Gruß,
Christian

Bild


Betrifft: AW: Zählen von Merkmalen innerhalb einer Zelle
von: Boris
Geschrieben am: 10.11.2003 19:35:09

Hi Christian,

in E1 steht der gesuchte Begriff - z.B. (NA).
Dann:

=SUMMENPRODUKT(LÄNGE(A1:A500)-LÄNGE(WECHSELN(A1:A500;E1;)))/LÄNGE(E1)

Grüße Boris


Bild


Betrifft: AW: soviele Wege führen nach Rom
von: FP
Geschrieben am: 10.11.2003 21:37:37

Hallo Christian,

wie gesagt, nicht alle, aber viele ;-)

Anmerkung:
in Zeile 2 und 3 ist es egal, wie "NA" geschrieben ist ( auch "na" wird gezählt )
in Zeile 4 bis 5 ist dies NICHT egal !


Excel Jeanie HTML
Formeln der Tabelle
B2 : {=SUMME(N(TEIL(A1:A10;SPALTE(4:4);2)="NA"))}
B3 : =SUMMENPRODUKT(N(TEIL(A1:A10;SPALTE(4:4);2)="NA"))
B4 : {=SUMME(N(IDENTISCH(TEIL(A1:A10;SPALTE(1:1);2);"NA")))}
B5 : =SUMMENPRODUKT(N(IDENTISCH(TEIL(A1:A10;SPALTE(1:1);2);"NA")))
B6 : =SUMMENPRODUKT((LÄNGE(A1:A10))-LÄNGE(WECHSELN(A1:A10;"NA";"")))/LÄNGE("NA")
  Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download   Servus aus dem Salzkammergut Franz

Bild

Beiträge aus den Excel-Beispielen zum Thema " Zählen von Merkmalen innerhalb einer Zelle"