Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zelle einfärben - Bedingung Quelldatei des Wertes

Zelle einfärben - Bedingung Quelldatei des Wertes
21.06.2016 10:29:48
Felicitas
Hallo, ich brauche Hilfe.
Ich habe eine Formel die per Index,Verleich aus einer externen Datei Daten ausliest; wenn in der dort vorhandenen Matrix kein Eintrag zu finden ist, sucht die Formel in einer weiteren Datei per Index,Vergleich und liefert die Rückmeldung von dort.
Konkret: Wenn in Quelle 1 keine Sonderwünsche hinterlegt sind, dann soll das Ergebnis aus dem Vorschlag angezeigt werden.
(kurz: wenn Quelle 1 (Sonderwünsche/MONTAG ORIGINAL)=leer, dann Quelle 2(Wochenplan))
Nun soll die Zelle - je nach zum Zug kommender Quelle eingefärbt werden.
De facto muss ich wissen aus welcher Quelldatei die Rückmeldung stammt.
Wie kann ich das anstellen?
Hier meine verzweifelte Formel....& herzlichen Dank für alle Bemühungen.
=WENN(+INDEX('[MONTAG ORIGINAL.xlsx]Tabelle 1'!$A$4:$DZ$100;VERGLEICH($A5; '[MONTAG ORIGINAL.xlsx]Tabelle 1'!$A$4:$A$100;0);VERGLEICH(H$4; '[MONTAG ORIGINAL.xlsx]Tabelle 1'!$A$4:$DZ$4;0))=""; +WENN(ISTFEHLER(+INDEX('Wochenplan KW24'!$B$2:$J$40;VERGLEICH($A5;'Wochenplan KW24'!$B$2:$B$40;0) ; VERGLEICH(H$2;'Wochenplan KW24'!$B$2:$I$2;0)));"";
INDEX('Wochenplan KW24'!$B$2:$J$40;VERGLEICH($A5;'Wochenplan KW24'!$B$2:$B$40;0);VERGLEICH(H$2;'Wochenplan KW24'!$B$2:$J$2;0)));
(+INDEX('[MONTAG ORIGINAL.xlsx]Tabelle 1'!$A$4:$DZ$100;VERGLEICH($A5;'[MONTAG ORIGINAL.xlsx]Tabelle 1'!$A$4:$A$100;0);VERGLEICH(H$4;'[MONTAG ORIGINAL.xlsx]Tabelle 1'!$A$4:$DZ$4;0))))

1
Beitrag zum Forumthread
Beitrag zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Zelle einfärben - Bedingung Quelldatei des Wertes
25.06.2016 08:21:26
Hajo_Zi
mache für jede Überprüfung eine Bedingte Formatierung.
Ich bin nun nicht der Formelmensch. Ich sehe den Teil nicht.

Anzeige

311 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige