wenn, dann Funktion, verküpft mit Sverweis

Bild

Betrifft: wenn, dann Funktion, verküpft mit Sverweis von: Jörn Taraba
Geschrieben am: 07.04.2005 10:39:39

Hallo,

ich habe ein Problem bei der Verschachtelung von sverweisen mit wenn,dann Funktionen.

Ich habe die zelle H33. In die Zelle wird eine Zahl zwischen 1 und 10 eingegeben.
In der Zelle J33 muss ich den Querschnitt einer Rohrleitung festlegen.
Es gibt die Möglichkeiten 15,20,25

Aus der Kombination der beiden Zahlen muss ich in L33 den Wert aus einer tabelle einlesen.

Die tabelle "test" hat folgendes Aussehen:
15 20 25
1 0,5 0,8 1,0
2 1,0 0,9 1,2

usw
10

Ich habe eine Formel eingegeben, bei der die fehlermeldung kommt, dass ich zu viele Argumente eingegeben habe.

Die Formel lautet:

=wenn(J33=15;sverweis(H33;test;2;falsch);wenn(J33=20;sverweis(H33;testl;3;falsch);wenn(J33=25;sverweis(H33;test;4;falsch;))))

Weiss jemand wie ich das Problem lösen kann?

Vielen Dank im voraus!!!

Grüße
Jörn

Bild


Betrifft: AW: wenn, dann Funktion, verküpft mit Sverweis von: Holger Levetzow
Geschrieben am: 07.04.2005 11:03:41

Hallo Jörn,

angenommen, in A1:K10 steht Deine Tabelle, dann nimm:

=INDEX(A1:K10;VERGLEICH(J33;A1:A10);VERGLEICH(H33;A1:K1))

Holger


Bild


Betrifft: AW: wenn, dann Funktion, verküpft mit Sverweis von: Jörn Taraba
Geschrieben am: 07.04.2005 12:23:28

Vielen Dank für den Tipp.

Grüße
Jörn


Bild


Betrifft: AW: wenn, dann Funktion, verküpft mit Sverweis von: heikoS
Geschrieben am: 07.04.2005 11:23:48

Hallo Jörn,

da sind mehrere Punkte:
1. hast Du test auch als Name definiert? Oder soll das das Tabellenblatt sein? Im 2. Fall mußt Du auch die Matrix benennen, z.B. A1:D100.

2. In Deiner Formel ist nach dem letzten FALSCH ein ; gesetzt, das da weg muß.

3. Würde ich einen etwas anderen sverweis() nehmen, mit dem Du gleich die Kombination aus "Zahl zw. 1 und 10" und "Querschnitt" abfragst:

=SVERWEIS(E1;A1:D4;VERGLEICH(E2;A1:D1;0);FALSCH)

In E1 steht die Zahl zw. 1 und 10 und in E2 der Querschnitt.


Gruß Heiko

PS: Rückmeldung?


Bild


Betrifft: AW: wenn, dann Funktion, verküpft mit Sverweis von: Jörn Taraba
Geschrieben am: 07.04.2005 12:25:59

hallo Heiko,

vielen Dank für die Tipps.

Ich habe das Semikolon entfernt. Jetzt funktioniert alles wunderbar.

Gruß
Jörn


Bild


Betrifft: AW: wenn, dann Funktion, verküpft mit Sverweis von: WolleKa
Geschrieben am: 07.04.2005 11:25:29

Hallo, Jörn,
m.E. ist das Semikolon hinter dem letzten "Falsch" überflüssig.

Gruß
WolleKa


 Bild

Beiträge aus den Excel-Beispielen zum Thema "wenn, dann Funktion, verküpft mit Sverweis"