Zelle mit Bereich vergleich, durchf. Arrayformel

Bild

Betrifft: Zelle mit Bereich vergleich, durchf. Arrayformel
von: Thomas
Geschrieben am: 27.10.2003 12:31:06

Hallo Forum!

Ich möchte Zelle E2 aus Tabelle Personalkosten mit dem Bereich E2:E10 in der Tabelle vergleichen. Kommt der Wert vor soll eine bestimmte Arrayformel durchgeführt werden. Ist das möglich?

Liebe Grüsse Thomas

Bild


Betrifft: AW: Zelle mit Bereich vergleich, durchf. Arrayformel
von: Thomas
Geschrieben am: 27.10.2003 13:34:13

hätte diese formel eingegeben:

=SUMME(VERGLEICH($E2;Personal!$E$2:$E$10;0)=WENN((Personal!$K$2:$K$20<=$E2)*(Personal!$L$2:$L$20>=$E2);1))

bekomm aber als ergebnis null.

wenn E2 im Bereich E2-E10 vorkommt bzw. wenn das Datum in E2 <= K2:K20 und E2>= L2:L20 soll die Summe gebildet werden.

Denke das ist gar verwirrend.


Bild


Betrifft: AW: Zelle mit Bereich vergleich, durchf. Arrayformel
von: IngoG
Geschrieben am: 27.10.2003 14:17:24

HAllo Thomas,

bin mir nicht ganz sicher in welcher Tabelle was steht...
aber im prinzip kann deine Formel so aussehen (keine arrayformel!!!)

=wenn(zählenwenn(personal!$e$2:$e$10;!$e2)>=1;summenprodukt((Personal!$K$2:$K$20<=$E2)*(Personal!$L$2:$L$20>=$E2));"")

die formel zählt alle zeilen in personal bei denen in K2:L20 von-, bis-werte für e2 stehen, wenn e2 in personal!e2:e10 vorkommt

ich hoffe, das bringt dich etwas weiter

Gruß Ingo


Bild


Betrifft: AW: Zelle mit Bereich vergleich, durchf. Arrayformel
von: Thomas
Geschrieben am: 27.10.2003 14:19:38

hallo ingo!

Was bedeutet in dem zählenwenn das ! bei ;!$e2?

gruss thomas


Bild


Betrifft: Artefakt ;-)
von: Ingo
Geschrieben am: 27.10.2003 14:22:06

hallo Thomas,
Sorry hab vergessen das ! zu löschen, da stand vorher tabelle!$e2

Gruß ingo


Bild


Betrifft: AW: Artefakt ;-)
von: Thomas
Geschrieben am: 27.10.2003 14:23:21

bekomme als Ergebnis 0 obwohl da 6 stehen sollte. *g*


Bild


Betrifft: Bsp-Datei?
von: IngoG
Geschrieben am: 27.10.2003 14:48:07

Hallo Thomas,
kannst Du vielleicht eine Testdatei hochladen?

Gruß Ingo


Bild


Betrifft: AW: Bsp-Datei?
von: Thomas
Geschrieben am: 27.10.2003 14:53:50

hab ich letztens versucht, ist aber bei mir nicht gegangen.

obwohl mein file ein xls. file war.


Bild


Betrifft: AW: Bsp-Datei?
von: ingoG
Geschrieben am: 27.10.2003 15:01:36

Hallo Thomas,
der Vorgang wird eigendlich ganz gut beschrieben:

1. durchsuchen anklicken
2. datei auswählen
3. Datei zum server anklicken
4. text unten markieren (mit maus ziehen) und ctrl-C drücken oder bearbeiten/kopieren
wählen
5. zurück anwählen und in deine Antwort den kopierten wert einfügen

fertig

sollte so funzen und erleichtert die sache ungemein
Gruß Ingo


Bild


Betrifft: AW: Bsp-Datei?
von: Thomas
Geschrieben am: 27.10.2003 15:22:48

nach datei zum server bekomm ich dieses meldung

Kein Upload möglich
Grund: Ungültiger Dateiname

Erlaubte Dateiformate: txt dat gif jpg doc xls xla xlt zip dat ppt
Bitte beachten: Der Dateiname darf keine Leerzeichen enthalten

obwohl xls und kein leerzeichen!


Bild


Betrifft: AW: Bsp-Datei?
von: IngoG
Geschrieben am: 27.10.2003 15:32:46

hallo Thomas,
HAst Du mal versucht testweise abzuspeichern unter C:thomas999.xls
und dich dann darauf zu beziehen?
uU hat muß der Dateiname nämlich eindeutig sein auf dem server

ist evt einen vresuch wert

Gruß ingo


Bild


Betrifft: AW: Bsp-Datei?
von: Thomas
Geschrieben am: 27.10.2003 15:50:27

hab folgenden pfad drinnen

S:\Persönliche Ordner\Severa\PROKOP\PLANUNG\Test.xls

und trotzdem gehts nicht. *grummel*


Bild


Betrifft: vielleicht wg "Persönliche Ordner"
von: IngoG
Geschrieben am: 27.10.2003 16:12:48

Hallo Thomas,
deshalb probier mal eine Kopie in C:\ zu speichern und diese hochzuladen

Gruß Ingo


Bild


Betrifft: AW: vielleicht wg "Persönliche Ordner"
von: thomas
Geschrieben am: 27.10.2003 16:17:16

https://www.herber.de/bbs/user/1625.xls

müsste funktioniert haben (mit C:) probiers bitte mal aus.


Bild


Betrifft: AW: Zelle mit Bereich vergleich, durchf. Arrayformel
von: IngoG
Geschrieben am: 27.10.2003 16:32:21

Hallo Thomas,

zunächst einmal, die datei ist jetzt da.

mir ist aber noch nicht ganz klar, was die formel wirklich tun soll.

als erstes ist mir aufgefallen, dass nicht in e2 sondern in d2 das referenzdatum steht und deshalb die formel zumindest an einer stelle geändert werden müsste:

=WENN(ZÄHLENWENN(Personal!$E$2:$E$10;$E2)>=1;SUMMENPRODUKT((Personal!$K$2:$K$20<=$D2)*(Personal!$L$2:$L$20>=$D2));"")

das ergebnis dieser Formel ist aber 9, da in allen Datensätzen in personal die grenzen um 01.01.2004 liegen
und der Schlüsselcode in e2 in der Tabelle vorkommt.
wenn Du nur die werte zählen möchtest, die in personal den entsprechenden Schlüsselcode haben muß die Formel lauten:

=SUMMENPRODUKT((Personal!$K$2:$K$20<=$D2)*(Personal!$L$2:$L$20>=$D2)*(Personal!$e$2:$e$20=$e2))

Probier es vielleicht einmal aus und melde dich nochmal
Gruß Ingo





Bild


Betrifft: AW: Zelle mit Bereich vergleich, durchf. Arrayformel
von: Thomas
Geschrieben am: 27.10.2003 16:36:32

Grundsätzlich soll folgendes passieren:

Im Sheet Personal stehen meine ganzen Mitarbeiter unterteilt nach Abteilungen (KSTCD).
Pro Monat möchte ich meine Mitarbeiteranzahl berechnen.

D.h. wenn die Kostenstelle gleich ist und Das Eintrittsdatum <= Monatsdatum bzw. Das Autrittsdatum >=Austrittsdatum dann soll der Mitarbeiter gezählt werden.

Klarer?


Bild


Betrifft: siehe untere Formel...
von: IngoG
Geschrieben am: 27.10.2003 16:42:16

HAllo Thomas,
genau das sollte die untere Formel auch machen.
hast Du es mal ausprobiert? einfach in die 2. Zeile eingeben

Gruß Ingo


Bild


Betrifft: AW: siehe untere Formel...
von: Thomas
Geschrieben am: 27.10.2003 17:11:58

so einen hätte ich noch.

ich würde jetzt gerne die summe pro kostenstelle (unter der bedingung kostenstelle, eintritt, austritt) berechnen.

das wärs dann aber wirklich!


Bild


Betrifft: AW: siehe untere Formel...
von: Thomas
Geschrieben am: 27.10.2003 17:14:21

ich habs schon!

=SUMMENPRODUKT((Personal!$K$2:$K$27<=$D2)*(Personal!$L$2:$L$27>=$D2)*(Personal!$E$2:$E$27=$E2)*(Personal!$H$2:$H$27))


Bild


Betrifft: AW: Zelle mit Bereich vergleich, durchf. Arrayformel
von: Thomas
Geschrieben am: 27.10.2003 16:50:36

hallo ingo!

es dürfte jetzt genau so funktionieren. vielen dank für deine hilfe. ich werd das dann noch genauer testen.

liebe grüsse
thomas


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Zelle mit Bereich vergleich, durchf. Arrayformel"