Microsoft Excel

Herbers Excel/VBA-Archiv

Ratlos wegen Formel in Verbindung mit Teilergebnis

Betrifft: Ratlos wegen Formel in Verbindung mit Teilergebnis von: Martin
Geschrieben am: 11.08.2004 15:28:46

Hallo liebe Leute,

ich habe ein für mich ungeheuer kniffliges Problem.

Und zwar habe ich eine Datei, in welcher ich auf eine Liste die Funktion Teilergebnis anwende. Danach filtere ich die Datei nach einem bestimmten Kriterium. In diesem Fall filtere ich nach Umsätzen über oder gleich 2 (T€).
Nun füge ich über jede Zeile mit den Teilergebnissen für die einzelnen Firmen eine Extrazeile ein. In dieser Zeile, welche in meiner Datei auch mit "Sonstige Artikel" zu erkennen ist, möchte ich eine Formel hinterlegen, mit der ich die Differenz ausrechne zwischen dem Ergebnis und den einzelnen Produkten, die im Filterkriterium liegen.

Zu erwähnen ist dabei, dass ich vorher alle Formeln, die den Begriff "=TEILERGEBNIS(9;" mit "=SUMME(" ersetze, so dass ich auch wirklich die richtigen Summen habe. Nur so macht die Spalte mit den sonstigen Artikeln auch wieder Sinn.

Nun habe ich allerdings das Problem, dass ich wenn beispielsweise die Produkte in den Zeilen 50 bis 100 zum Kunden 10 gehören, aber nur Zeile 60 und 70 im Teilergebnis auftauchen, da nur sie das Filterkriterium erfüllen, ich nicht genau weiß, wie ich ein Makro gestalten soll, welches diesen Vorgang automatisiert. :-(

Ich lade mal eine Beispiel-Datei auf den Server.
Vielleicht fällt einem von Euch etwas schlaues ein.

Ich danke Euch für Eure Hilfe und verbleibe

Mit freundlichen Grüssen
Martin

HIER IST DIE DATEI:
https://www.herber.de/bbs/user/9521.xls

  


Betrifft: AW: Ratlos wegen Formel in Verbindung mit Teilergebnis von: Panicman
Geschrieben am: 12.08.2004 10:34:33

Hallo Martin,

Hier mal ein Formel-Ansatz. Du mußt nur darauf achten, daß du den Autofilter "größer oder gleich 2" ZWEIMAL ausführen mußt, da die Formel erst nach dem Ereignis Autofilter berechnet wird.

C30 = =SUMME(INDIREKT(ADRESSE(ZEILE(C29);SPALTE(C29))&":"&ADRESSE(VERGLEICH($A30;$A:$A;0);SPALTE(C29))))-TEILERGEBNIS(9;INDIREKT(ADRESSE(ZEILE(C29);SPALTE(C29))&":"&ADRESSE(VERGLEICH($A30;$A:$A;0);SPALTE(C29))))


Gruß Holger


  


Betrifft: AW: Ratlos wegen Formel in Verbindung mit Teilergebnis von: Martin
Geschrieben am: 12.08.2004 11:00:04

Hallo Holger,

vielen Dank für Deine Formel. Ich werde damit mal ein wenig rumexperimentieren und schauen, ob und wie ich sie verwenden kann.

Dank Dir recht herzlich.

Gruss,
Martin


 

Beiträge aus den Excel-Beispielen zum Thema "Ratlos wegen Formel in Verbindung mit Teilergebnis"