Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
736to740
736to740
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Datum in Zahl umwandeln
25.02.2006 17:57:37
Erich
Hallo EXCEL-Freunde,
kann man ein Datum in eine "normale Zahl umwandeln"?
In der Zelle A1 wird angezeigt: 02.12.1998
in Zelle A2 soll angezeigt werden:2121998
Die 0en und die Punkte müsste man quasi entnehmen.
Besten Dank für eine Hilfe!
mfg
Erich
EXCEL-Shareware und Freeware: http://www.toolex.de
Private Tippgemeinschaft für Lotto oder KENO: http://www.kenostrategen.de

13
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Datum in Zahl umwandeln
25.02.2006 18:06:41
Heinz
Hallo Erich,
versuchs mal damit:
=TAG(A1)&MONAT(A1)&JAHR(A1)
Gruß Heinz
AW: Datum in Zahl umwandeln
25.02.2006 18:08:31
Peter
Hallo Erich,
=A1 in B1, wenn das Datum in A1 steht und deine Zahl in B1 stehen soll. B1 als Zahl ohne Nachkommastellen formatieren.
Viele Grüße Peter
Eine kurze Nachricht, ob es läuft, wäre nett - danke.
AW: Datum in Zahl umwandeln
25.02.2006 18:34:34
HermannZ
Hallo Erich;
du kannst daraus auch wieder eine zahl mit der man auch rechnen kann machen;
Wenn du schreibst =TEXT(A1;"TTMMJJJJ")*1 erhälst du wie gesagt eine zahl ohne führende 0 mit der man auch noch rechnen kann.
Gruß hermann
Anzeige
AW: Datum in Zahl umwandeln
25.02.2006 18:48:38
Erich
Hallo Hermann,
danke; aber beim Monat kommt leider die Null; allerdings funktioniert die Lösung von heinz, also gelöst.
mfg
Erich
EXCEL-Shareware und Freeware: http://www.toolex.de
Private Tippgemeinschaft für Lotto oder KENO: http://www.kenostrategen.de
AW: Datum in Zahl umwandeln
25.02.2006 18:52:42
HermannZ
Hallo Erich;
das ist kein hinderungsgrund denn dann brauchst du nur in der Textformel bei der Format angabe aus "TTMMJJJJ" "TTMJJJJ" zu machen und dann ist die 0 des Monats weg.
gruß hermann
AW: Datum in Zahl umwandeln
25.02.2006 19:55:35
Erich
Hallo Hermann,
aber wenn es um die Monate 10 - 12 geht habe ich ein Problem? Könnte das evtl. mit
einer wenn-Abfrage klären.
mfg
Erich
EXCEL-Shareware und Freeware: http://www.toolex.de
Private Tippgemeinschaft für Lotto oder KENO: http://www.kenostrategen.de
Anzeige
AW: Datum in Zahl umwandeln
26.02.2006 10:07:18
HermannZ
Hallo Erich;
du schreibst;
" aber wenn es um die Monate 10 - 12 geht habe ich ein Problem? "
wie soll ich das verstehen, du wolltest das die führende 0 bei dem Tag und Monat nicht in der Zahl berücksichtigt wird oder ?
Beispiel;
 
 GH
138  
13901.08.2006182006
14010.09.20061092006
14111.11.200611112006
14210.12.200610122006
143  
Formeln der Tabelle
H139 : =TEXT(G139;"TTMJJJJ")*1
H140 : =TEXT(G140;"TTMJJJJ")*1
H141 : =TEXT(G141;"TTMJJJJ")*1
H142 : =TEXT(G142;"TTMJJJJ")*1
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
gruß hermann
Anzeige
AW: Datum in Zahl umwandeln
26.02.2006 11:58:36
Sigi
Hallo Hermann, hallo Erich,
die Lösungen von Heinz und Hermann sind im Ergebnis nicht mehr eindeutig!
z.Bsp. "21.01.2006" und "02.11.2006" ergeben jeweils "21122006". Wollt Ihr das so?
Gruß
Sigi
AW: Datum in Zahl umwandeln
26.02.2006 12:03:36
Sigi
Ich meinte natürlich "2112006". Hatte leider eine Ziffer zuviel eingetippt.
Sigi
AW: Datum in Zahl umwandeln
26.02.2006 11:45:11
rlenz
Hallo Erich,
ich weiss nicht wozu das nützlich sein soll, aber, des Menschen Wille ist sein Himmelreich.
Ein Datum in Excel ist eine Zahl, die bei Eingabe als Datum formatiert, das heißt angezeigt wird. Hinter dem Datum 26.02.2006 steckt die (serielle) Zahl 38774
 
 ABCDEF
1Datumim Format TMJJJJim Format TMMJJJJFormel, Format StandardFormel, Format Standardserielle Zahl, damit rechnet Excel, Format Standard
202.01.19982119982011998211998201199835797
330.12.19983012199830121998301219983012199836159
402.12.1998212199821219982121998212199836131
Formeln der Tabelle
B2 : =A2
C2 : =A2
D2 : =TEXT(A2;"TMJJJ")*1
E2 : =TEXT(A2;"TMMJJJ")*1
F2 : =A2
B3 : =A3
C3 : =A3
D3 : =TEXT(A3;"TMJJJ")*1
E3 : =TEXT(A3;"TMMJJJ")*1
F3 : =A3
B4 : =A4
C4 : =A4
D4 : =TEXT(A4;"TMJJJ")*1
E4 : =TEXT(A4;"TMMJJJ")*1
F4 : =A4
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Mfg
Rüdiger Lenz
Anzeige
AW: Datum in Zahl umwandeln
26.02.2006 12:53:03
Erich
Hallo Rüdiger,
besten Dank für die Übersicht, werde ich noch näher betrachten. Hintergrund ist,
dass ich für einen Vergleich ein Datum in drei Spalten habe (Tag, Monat, Jahr)
und das muss ich jetzt vergleichen mit einem Datum in einer Zelle.
Da habe ich mir gedacth, wenn ich einfach TTMMJJJJ als "normale Zahl" in einer
Zelle habe, dann kann ich das vergleichen.
Mit der ersten Lösung in diesem Beitrag klappt das auch.
mfg
Erich
EXCEL-Shareware und Freeware: http://www.toolex.de
Private Tippgemeinschaft für Lotto oder KENO: http://www.kenostrategen.de
Anzeige
AW: Datum in Zahl umwandeln
27.02.2006 09:33:25
rlenz
Hallo Erich,
viele Wege führen nach Rom:
Zu vergleichendes Datum in Zelle A2
Tag in Zeile B2
Monat in Zeile C2
Jahr in Zeile D2
Zeile E2: Datum aus Zahlen in Zeilen B2, C2, D2 =DATUM(D2;C2;B2)
Jetzt kannst du schon die Zeile A2 mit Zeile E2 vergleichen.
 
 ABCDEFGHIJK
1DatumTagMonatJahrist Datumgleich oder ungleich     
215.03.2006153200615.03.2006gleich     
316.03.2006153200615.03.2006nicht gleich     
4      ist gleichist nicht gleich   
515.03.2006153200615.03.2006gleichgleich    
615.03.2006153200615.03.2006 gleich Eingaben richtig?
704.02.190335132  gleich Tag falsch?Monat falsch?Jahr falsch?
815.03.200635132   nicht gleichTag falsch?Monat falsch?Jahr falsch?
9        Eingaben können so gewollt sein!
Formeln der Tabelle
E2 : =DATUM(D2;C2;B2)
F2 : =WENN(A2=E2;"gleich";"nicht gleich")
E3 : =DATUM(D3;C3;B3)
F3 : =WENN(A3=E3;"gleich";"nicht gleich")
E5 : =WENN(UND(ISTZAHL(B5);ISTZAHL(C5);ISTZAHL(D5));DATUM(D5;C5;B5);"")
F5 : =WENN(UND(ISTZAHL(A5);ISTZAHL(B5);ISTZAHL(C5);ISTZAHL(D5));WENN(A5=E5;"gleich";"nicht gleich");"")
G5 : =WENN(UND(ISTZAHL(A5);ISTZAHL(B5);ISTZAHL(C5);ISTZAHL(D5));WENN(A5=E5;"gleich";"");"")
H5 : =WENN(UND(ISTZAHL(A5);ISTZAHL(B5);ISTZAHL(C5);ISTZAHL(D5));WENN(A5=E5;"";"nicht gleich");"")
E6 : =WENN(UND(ISTZAHL(B6);ISTZAHL(C6);ISTZAHL(D6));DATUM(D6;C6;B6);"")
G6 : =WENN(UND(ISTZAHL(A6);ISTZAHL(B6);ISTZAHL(C6);ISTZAHL(D6));WENN(A6=DATUM(D6;C6;B6);"gleich";"");"")
H6 : =WENN(UND(ISTZAHL(A6);ISTZAHL(B6);ISTZAHL(C6);ISTZAHL(D6));WENN(A6=DATUM(D6;C6;B6);"";"nicht gleich");"")
G7 : =WENN(UND(ISTZAHL(A7);ISTZAHL(B7);ISTZAHL(C7);ISTZAHL(D7));WENN(A7=DATUM(D7;C7;B7);"gleich";"");"")
H7 : =WENN(UND(ISTZAHL(A7);ISTZAHL(B7);ISTZAHL(C7);ISTZAHL(D7));WENN(A7=DATUM(D7;C7;B7);"";"nicht gleich");"")
I7 : =WENN(DATUM(D7;C7;B7)>DATUM(D7;C7+1;0);"Tag falsch?";DATUM(D7;C7;B7))
J7 : =WENN(UND(C7>0;C7<13);"";"Monat falsch?")
K7 : =WENN(D7<1900;"Jahr falsch?";"")
G8 : =WENN(UND(ISTZAHL(A8);ISTZAHL(B8);ISTZAHL(C8);ISTZAHL(D8));WENN(A8=DATUM(D8;C8;B8);"gleich";"");"")
H8 : =WENN(UND(ISTZAHL(A8);ISTZAHL(B8);ISTZAHL(C8);ISTZAHL(D8));WENN(A8=DATUM(D8;C8;B8);"";"nicht gleich");"")
I8 : =WENN(DATUM(D8;C8;B8)>DATUM(D8;C8+1;0);"Tag falsch?";DATUM(D8;C8;B8))
J8 : =WENN(UND(C8>0;C8<13);"";"Monat falsch?")
K8 : =WENN(D8<1900;"Jahr falsch?";"")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
MfG
Rüdiger Lenz
Anzeige

300 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige