Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Text in Uhrzeit umwandeln
Nina
Hallo habe ein Problem, habe aus einem HTML Dokument Zeiten und Daten herauskopiert, diese nun in Excel mit Hilfe von Tabs eingespeist. Laut Formatangabe steht das nun in einer Textform dort.
Also Bsp: 260.45 (hhh:mm) nun will ich aber damit weiterrechnen, also andere zeiten davon subtrahieren oder addieren. Wie verwandel ich das Textdokument jetzt in ein Format hhh:mm?
Vielen Dank für die Hilfe
AW: Text in Uhrzeit umwandeln
24.01.2011 16:33:26
Nina
Habe mich übrigens schon durch einige Foren durchgelesen, bisher hat aber nichts funktioniert. hatte es auch schon mal von . auf , umformatiert, dann kann man damit rechnen er macht aber so mist dinger wie 60,78 :-(
Danke für eine Antwort.
AW: Text in Uhrzeit umwandeln
24.01.2011 17:32:52
Josef

Hallo Nina,
das geht z. B. so.
Test

 ABC
19   
20264.45264:45 
21123.17123:17 
2213.1213:12 
23   
24 401:14 
25   

Formeln der Tabelle
ZelleFormel
B20=LINKS(A20;FINDEN(".";A20)-1)/24+TEIL(A20;FINDEN(".";A20)+1;2)/1440
B21=LINKS(A21;FINDEN(".";A21)-1)/24+TEIL(A21;FINDEN(".";A21)+1;2)/1440
B22=LINKS(A22;FINDEN(".";A22)-1)/24+TEIL(A22;FINDEN(".";A22)+1;2)/1440
B24=SUMME(B20:B22)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Sepp

Anzeige
AW: Text in Uhrzeit umwandeln
25.01.2011 09:27:18
Nina
Hi...
habe ich versucht. Er gibt mir aber leider folgendes aus...
161.07 und wenn ich dann Deine Formel in die Spalte b eingeben, gibt er mit 17:07 aus :-(
Habe auch schon einige andere Formeln hier versucht und bin mit meinem Latein echt mal am Ende :-(
AW: Text in Uhrzeit umwandeln
25.01.2011 10:22:05
Josef

Hallo Nina,
du musst die Ausgabezelle im Format [hh]:mm formatieren, dann stimmt aich die Anzeige.

Gruß Sepp

Anzeige
AW: Text in Uhrzeit umwandeln
25.01.2011 10:37:09
Nina
Hi...noch eine kurze Frage...bei minus Stunden geht es leider nicht :-( noch eine Idee was man da machen könnte?!
Danke schon mal vorab!
AW: Text in Uhrzeit umwandeln
25.01.2011 10:56:35
Nina
Hi...
danke für den Link, aber ich will eigentlich nicht damit rechnen, sondern das Textformat in eine negative Uhrzeit darstellen... Rechnen habe ich hinbekommen, leider liest er mir mit deiner sensationellen formel den text nicht in eine negative zeit um :-(
Anzeige
AW: Text in Uhrzeit umwandeln
25.01.2011 10:57:46
Nina
Äh...hat sich erledigt...mit den 1904 datumswerten bin ich damit durch gekommen..habe jetzt die negativzeiten! Nochmal, vielen, vielen Dank für die Hilfe!
Grüßle Sabrina
AW: Text in Uhrzeit umwandeln
25.01.2011 11:05:54
Nina
hm...oder auch nicht...mist...jetzt rechnet er einfach die zahl von 00:00 ab... :-(
AW: Text in Uhrzeit umwandeln
25.01.2011 11:15:51
Josef

Hallo Nina,
nicht verzweifeln;-))
Tabelle2

 AB
20-161.07-161:07
2125.1425:14
22247.03247:03

Formeln der Tabelle
ZelleFormel
B20=WENN(LINKS(A20;1)="-";"-";"")&TEXT(ABS(LINKS(A20;FINDEN(".";A20)-1))/24+TEIL(A20;FINDEN(".";A20)+1;2)/1440;"[hh]:mm")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Sepp

Anzeige
AW: Text in Uhrzeit umwandeln
25.01.2011 11:34:45
Nina
Du Genie...danke...mit dem Wenn habe ich jetzt auch schon angefangen...aber das mit dem Text und ABS war für mein kleines Laienhirn einfach zu viel!!
Danke...der Tag ist gerettet
Grüße Sabrina

290 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige