Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

text in Bereich umwandeln

text in Bereich umwandeln
Aton
Hallo
=Summe(A2:D4)
Kann man D4 so ersetzen:
Text "D" + Zahl aus A1
D4 soll die Zahl 4 Aus A1 ausgelesen werden.
Gruß Aton

8
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: mit indirekt
20.11.2011 06:24:01
hary
Hallo Aton
Tabelle1
 ABCD
146   
22     
3       
4    31
5      1

verwendete Formeln
Zelle Formel Bereich
B1 =SUMME(INDIREKT("A2:D"&A1)) 

Tabellendarstellung in Foren Version 5.30


gruss hary
Anzeige
AW: mit indirekt - Vielen Dank
20.11.2011 07:44:49
Aton
Hallo
Vielen Dank, das ist besser als über Bereich Verschieben.
Gruß Aton
oder mit INDEX
20.11.2011 08:27:51
Erich
Hi A(n?)ton,
BEREICH.VERSCHIEBEN und INDIREKT sind volatile Funktionen - sie verursachen (mit gutem Grund)
eine Neuberechnung der jeweiligen Formel bei jeder Tabellenänderung.
INDEX hat diesen Nachteil nicht.
Welche Fkt. bei dir am besten passt, hängt vor allem auch hiervon ab:
Die drei Formeln haben jetzt das selbe Ergebnis, unterscheiden sich aber in ihrem Verhalten,
wenn z. B. vor/über/in dem angesprochenen Bereich Zeilen oder Spalten eingefügt oder gelöscht werden:
 ABCD
14123412341234
21000    
3   xxx
4200 304
5 5000  5000

Formeln der Tabelle
ZelleFormel
B1=SUMME(INDIREKT("A2:D"&A1))
C1=SUMME(A2:INDEX(D:D;A1))
D1=SUMME(BEREICH.VERSCHIEBEN(A2:D2;;;A1-1))

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
AW: oder mit INDEX
20.11.2011 09:20:54
Aton
Hallo
Ja das stimmt.
Aber Coppieren lassen sie sich bei mir ganz schlecht. woran liegt das.
Gruß BWE
unklar
20.11.2011 09:34:28
Erich
Hi BWE (hast du auch einen 'normalen' Vornamen?),
was meinst du mit "Aber Coppieren lassen sie sich bei mir ganz schlecht" ?
Was willst du kopieren?
Was ist dann schlecht, was passiert?
Wie sollte das besser sein?
Wenn ich das weiß, kann ich vielleicht sagen, woran das liegt. :-)
Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
AW: unklar
20.11.2011 09:46:03
Aton
Hallo
Wenn ich Formeln mit Indirekt Coppiere dauert das pro Celle ca. 0,5 Sek.
Beim einfügen der Selben etwar 40 mal 1,5 Sek.
bei 4 Cellen sind das 4*1,5=6*40 = 240 Sek zum Coppieren und einfügen.
bei 10 Cellen 10*1,5=15*40=600 Sek eher noch länger.
Das berechnen ist wie immer schnell.
Guß Aton
Anzeige
weiterhin unklar
20.11.2011 10:33:23
Erich
Hi Vorname?,
sorry, aber ich verstehe nicht, was du meinst.
Was dauert da sdo lange? Ist es das Eintippen der Formeln, musst du sie nicht nur kopieren,
sondern auch manuell an die jeweilige Zeile/Spalte anpassen?
Oder braucht Excel so lange, wenn de die Eingabe mit Return beendest (das wäre dann die Berechnung)?
Schreibst du mal bitte auch ganz genau die Formel hin, die du kopieren (nicht: Coppieren) willst?
Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
AW: weiterhin unklar
20.11.2011 10:48:23
Aton
Hallo
Wenn ich die tabelle auf rund 200 cellen verkleinere hat sie immer noch 9000 kByte.
normal wären ca 20 KByte.
das Coppieren dauert so lange und das einfügen ca 40 mal länger.
in anderen Arbeitsmappen ist alles OK
Auch wenn ich eine ganz neue erstelle ist es das gleiche Problem.
datei zu groß im verhältnis und copieren einfügen total langsam.
werde mal excel neu installieren.
Gruß Aton
Anzeige

300 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige