Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenns mit Datum

Betrifft: Zählenwenns mit Datum von: Tim
Geschrieben am: 05.10.2020 17:56:45

Hallo zusammen,


ich möchte gern die Zählenwenns Funktion nutzen und die Anzahl ermitteln, wenn im Suchbereich das Datum in einen bestimmten Monat fällt, leider scheitere ich daran.


In Spalte B sind fortlaufen Einträge mit Datumswerten z.B. 11.04.2020, diese sollen gezählt werden wenn diese Datum auf den Monat April fallen.


Meine Variante scheitert, könnt ihr mir bitte behilflich sein!?

=ZÄHLENWENNS(April!$C:$C;'Übersicht'!$A7;April!B:B;MONAT(April!B:B)=4)

Betrifft: AW: Zählenwenns mit Datum
von: Hajo_Zi
Geschrieben am: 05.10.2020 17:59:44


Tabelle1
 C
118

verwendete Formeln
Zelle Formel Bereich N/A
C11=SUMMENPRODUKT((MONAT(B11:B25)=4)*1)  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.21 einschl. 64 Bit



GrußformelHomepage

Betrifft: AW: Zäh... günstiger als mit SUMMENPRODUKT(), ...
von: neopa C
Geschrieben am: 05.10.2020 19:43:29

Hallo Tim,

... weil da die Formel über den gesamten Zeilenbereich definiert schneller auswertet. Allerdings ist für mich "Auswertung eines bestimmten Monats" auch immer mit einem konkreten Jahr verbunden. Die SUMMENPRODUKT()-Formel, wie sie Hajo definiert hat, würde auch die Daten aus dem April anderer Jahre mit auswerten.

Deshalb für April z.B. des Jahres 2020 so:

=ZÄHLENWENNS(April!C:C;Übersicht!A7;April!B:B;">="&"4.20"+0;April!B:B;"<="&"5.20"-1)

Gruß Werner
.. , - ...

Betrifft: AW: Zäh... günstiger als mit SUMMENPRODUKT(), ...
von: Tim
Geschrieben am: 06.10.2020 13:14:02

Hallo zusammen,

vielen Dank für die beiden Varianten. Ich habe mich für =ZÄHLENWENNS(April!C:C;Übersicht!A7;April!B:B;">="&"4.20"+0;April!B:B;"<="&"5.20"-1) entschieden, diese macht genau das was ich damit erreichen wollte!

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 06.10.2020 14:29:35

Gruß Werner
.. , - ...