Summewenn in Verbindung mit Heute()

Bild

Betrifft: Summewenn in Verbindung mit Heute()
von: Zohdy
Geschrieben am: 24.11.2003 01:24:01

Hallo zusammen
ist zwar schon recht spät aber ich wollte mein Begehr wenigstens noch los werden.
Habe mal wieder ein kleines Problem, dass ich mich mit meinen Kenntnissen nicht lösen kann. Vieleicht sehe ich aber auch den Wakd vor lauter Bäumen nicht.
Wie schon im Topic beschrieben möchte ich die Funktion " Summewenn " in Verbindung mit der Bedingung "Heute()" nutzen.
Habe dafür folgende Formel erstellt.
=SUMMEWENN(Rollout!$M$5:$M$749;"<37924";Rollout!$BV$5:$BV$749)-SUMMEWENN(Rollout!A5:A749;"8*";Rollout!BV5:Rollout!BV749)

Da es bei mir nur funktioniert wenn ich den Wert des heutigen Tages eingebe ist in der Formel eben dieser Wert, naja nicht ganz aktuell.
Habe folgendes bereits ausprobiert:
1. Statt des Wertes einen Verweis auf ein Feld mit der Variablen Heute()
2. Einen Verweis auf ein Feld mit der Formel Wert(Feld,xy), wobei in dem Feld wiederum die Variable " Heute() " steht.
Das Ergebnis ist entweder ein falscher Wert (Verwendung von "), oder die Formel wird nicht akzeptiert.
Vielen Dank für eure Hilfe
Gruß
Zohdy

Bild


Betrifft: AW: Summewenn in Verbindung mit Heute()
von: oos
Geschrieben am: 24.11.2003 08:30:01

Hallo,

schau dir mal das folgende Beispiel an, es funktioniert mit der Funktion Heute() problemlos.

G.a.BY
Niko

 
 ABC
124.11.200390 
224.11.2003100 
324.11.2003110 
425.11.2003120 
526.11.2003130 
627.11.2003140 
728.11.2003150300
Formeln der Tabelle
A1 : =HEUTE()
A2 : =HEUTE()
A3 : =HEUTE()
C7 : =SUMMEWENN(A1:A7;HEUTE();B1:B7)
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Bild


Betrifft: AW: Summewenn in Verbindung mit Heute()
von: Zohdy
Geschrieben am: 24.11.2003 10:56:35

Hallo Niko
sieht gut aus aber ich möchte alle Werte < Heute () addieren und das funktioniert bei mir nicht.
Übrigens was bedeutet G.a.BY
Gruß
Zohdy


Bild


Betrifft: Grüße aus Bayern ;-)
von: oos
Geschrieben am: 24.11.2003 11:58:28

Hi


Bild


Betrifft: AW: Summewenn in Verbindung mit Heute()
von: Mac4
Geschrieben am: 24.11.2003 09:15:54

Hi,

und wenn Du variabel bleiben willst, muß die Syntax folgendermaßen aussehen:


=SUMMEWENN(Rollout!$M$5:$M$749;"<"&heute()";Rollout!$BV$5:$BV$749)-SUMMEWENN(Rollout!A5:A749;"8*";Rollout!BV5:Rollout!BV749)

Marc


Bild


Betrifft: AW: Summewenn in Verbindung mit Heute()
von: Zohdy
Geschrieben am: 24.11.2003 10:59:35

Hi Marc
hast Du das geprüft?
Erstens fehlt glaube ich ein " vor heute oder es ist eins zuviel. ;"<"&heute()";
Allerdings funktionieren beide Varianten nicht. Es kommt immer 0 als Ergebnis.
Viele Grüße
Zohdy


Bild


Betrifft: AW: Summewenn in Verbindung mit Heute()
von: Mac4
Geschrieben am: 24.11.2003 11:03:08

Hi,

stimmt, sorry. Das "" hinter Heute() ist zuviel. Aber sonst müsste es klappen, aber es bei mir mit Beispielsdaten getestet!

Marc


Bild


Betrifft: AW: Summewenn in Verbindung mit Heute()
von: Zohdy
Geschrieben am: 24.11.2003 11:10:05

Jo Marc
die Variante hatte ich nicht ausprobiert. Jetzt klappts.
Vielen Dank ist ne Super Erleichterung, da sich der Wert jetzt selbst aktualisiert.
Übrigens weißt Du auch eine Antwort auf meine zweite Frage.
Gruß
Zohdy


Bild

Beiträge aus den Excel-Beispielen zum Thema " Summewenn in Verbindung mit Heute()"