Verweis oder Summewenn oder ?

Bild

Betrifft: Verweis oder Summewenn oder ? von: Jörg
Geschrieben am: 05.02.2005 00:27:09

Hallo zusammen,

kann mir jemand bei der formel helfen?

ich habe in spalte a und b zahlenbereiche eingegeben (von ... bis ...) hinter denen in spalte c jeweils ein text steht.

in spalte e stehen sortiert zahlen von 1 bis x.

durch eine formel soll nun in spalte f die beschriftung aus spalte c eingefügt werden, sofern die zahl aus spalte e im zahlenbereich der spalten a und b ist.

danke schon mal im voraus. ich hoffe die beschreibung des problems ist nicht zu kompliziert.

Bild


Betrifft: WENN von: Beate Schmitz
Geschrieben am: 05.02.2005 01:03:48

Hallo Jörg,

nachstehende Lösung geht davon aus, dass es egal ist, ob in A oder B der niedrigere bzw. höhere Wert steht, Hauptsache, die Zahl in E liegt zwischen beiden oder ist gleich groß wie eine der beiden:
 
 ABCDEF
106Text1 4Text1
219Text2 3Text2
342Text3 10 
411Text4 5 
558Text5 11 
669Text6 3Text6
740Text7 11 
Formeln der Tabelle
F1 : =WENN(UND(E1>=A1;E1<=B1);C1;WENN(UND(E1>1;E1<=A1);C1;""))
F2 : =WENN(UND(E2>=A2;E2<=B2);C2;WENN(UND(E2>1;E2<=A2);C2;""))
F3 : =WENN(UND(E3>=A3;E3<=B3);C3;WENN(UND(E3>1;E3<=A3);C3;""))
F4 : =WENN(UND(E4>=A4;E4<=B4);C4;WENN(UND(E4>1;E4<=A4);C4;""))
F5 : =WENN(UND(E5>=A5;E5<=B5);C5;WENN(UND(E5>1;E5<=A5);C5;""))
F6 : =WENN(UND(E6>=A6;E6<=B6);C6;WENN(UND(E6>1;E6<=A6);C6;""))
F7 : =WENN(UND(E7>=A7;E7<=B7);C7;WENN(UND(E7>1;E7<=A7);C7;""))
 


Steht die niedrigere Zahl immer in Spalte A, reicht diese Formel:
 
 ABCDEF
106Text1 4Text1
219Text2 3Text2
335Text3 10 
447Text4 5Text4
558Text5 11 
669Text6 3 
738Text7 11 
Formeln der Tabelle
F1 : =WENN(UND(E1>=A1;E1<=B1);C1;"")
F2 : =WENN(UND(E2>=A2;E2<=B2);C2;"")
F3 : =WENN(UND(E3>=A3;E3<=B3);C3;"")
F4 : =WENN(UND(E4>=A4;E4<=B4);C4;"")
F5 : =WENN(UND(E5>=A5;E5<=B5);C5;"")
F6 : =WENN(UND(E6>=A6;E6<=B6);C6;"")
F7 : =WENN(UND(E7>=A7;E7<=B7);C7;"")
 


Gruß,
Beate


Bild


Betrifft: AW: WENN von: Jörg
Geschrieben am: 05.02.2005 09:22:35

hallo beate,

deine lösung ist dann ok, wenn der wert aus e1 zwischen den werten aus a1 und b1 ermittelt wird. in meiner tabelle ist das nicht der fall. d.h. hier muss in den spalten a und b erst nach den zahlen gesucht werden, in deren bereich die zahl aus e reinfällt.

ohje, ich glaube es ist sehr verwirrend. eigentlich wollte ich ein beispiel hochladen, geht aber irgendwie nicht.

wäre trotzdem super, wenn du einen vorschlag hast. danke.


Bild


Betrifft: AW: Verweis oder Summewenn oder ? von: FP
Geschrieben am: 05.02.2005 10:05:24

Hi Jörg,

meinst Du das so?

Werte müssen nach Spalte A sortiert sein!

Tabelle1
 ABCDEF
1110Text 35 1Text 35
21120Text 93 24Text 25
32144Text 25 93Text 31
44560Text 94 76Text 36
56164Text 59   
66568Text 98   
76973Text 97   
87480Text 36   
98184Text 47   
108590Text 83   
119191Text 27   
129298Text 31   
1399100Text 83   
14101108Text 5   
15109114Text 91   
Formeln der Tabelle
F1 : =SVERWEIS(E1;A$1:C$15;3;1)
F2 : =SVERWEIS(E2;A$1:C$15;3;1)
F3 : =SVERWEIS(E3;A$1:C$15;3;1)
F4 : =SVERWEIS(E4;A$1:C$15;3;1)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Bild


Betrifft: AW: Verweis oder Summewenn oder ? von: Jörg
Geschrieben am: 05.02.2005 11:30:23

das ist genau die Lösung!

... und so einfach :-)

Super, vielen Dank. LG


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Verweis oder Summewenn oder ?"