Microsoft Excel

Herbers Excel/VBA-Archiv

wie Summewenn, nur flexibler

Betrifft: wie Summewenn, nur flexibler von: Markus
Geschrieben am: 28.07.2014 15:53:30

Hallo Excel Freunde,

folgendes Anliegen:

In einer Liste wird die Summe von Kosten ermittelt. Das habe ich auch mittels VBA recht gut hinbekommen. Zuletzt wird noch die Summe der Kosten pro Vorgang benötigt.
Wenn dies statisch wäre, wäre die Formel SUMMEWENN(A:A;17;K:K) eine gute Lösung.

Allerdings ändert sich die Liste dauernd (neue Berechnungen für andere Bauteile).
Das heißt, der abzufragende Wert in Spalte A ändert sich. Es kann eine andere Zahl sein und der Wert kann 1x oder 20x vorhanden sein. Das Ergebnis pro Vorgang soll in Spalte L immer in die gleiche Zeile der letzten noch vorhandenen Vorgangsnummer stehen.

Hier die Tabelle:
https://www.herber.de/bbs/user/91757.xlsm

Wer hat Ideen? Und wenn es nur ein Anstupser wäre.
Der Makrorekorder gibt mir ActiveCell.FormulaR1C1 = "=SUMIF(C1,17,C[-3])" raus.
Dies schreibt mir dann eine Formel in die gerade aktive Zelle. Vielleicht kann man ja darauf aufbauen?

Gruß
Markus

  

Betrifft: AW: wie Summewenn, nur flexibler von: selli
Geschrieben am: 28.07.2014 15:58:43

hallo markus,

nimm eine pivottable.

gruß
selli


  

Betrifft: AW: wie Summewenn, nur flexibler von: ChrisL
Geschrieben am: 28.07.2014 15:59:51

Hi Markus

Formel für M5:
=WENN(A5<>A6;SUMMEWENN(A:A;A5;K:K);"")

danach runterziehen...

cu
Chris


  

Betrifft: AW: wie Summewenn, nur flexibler von: Daniel
Geschrieben am: 28.07.2014 16:05:19

Hi

füge in Spalte M als Hilfsspalte folgende Formel ein (Formel für M5):
=WENN($A5=$A4;M4+$K5;$K5)

füge in Spalte L als Ergebnisspalte folgende Formel ein (Formel für L5)
=WENN($A5=$A6;"";M5)

beide Formel ziehst du dann bis ans Datenende.

gruß Daniel


  

Betrifft: AW: wie Summewenn, nur flexibler von: Markus
Geschrieben am: 29.07.2014 07:32:22

An alle Helfer!

Danke für die Tipps.
Funktioniert gut.

Gruß
Markus