Microsoft Excel

Herbers Excel/VBA-Archiv

Summe mit mehreren Bedingungen; Summe über Zahlen die x davor stehen haben

Betrifft: Summe mit mehreren Bedingungen; Summe über Zahlen die x davor stehen haben von: Matthias
Geschrieben am: 11.02.2020 15:07:31

Hallo,


bin schon seit längerem daran ein Problem zu lösen und habe bisher noch keine zufriedenstellende Lösung gefunden.


In meiner Tabelle gibt es eine Spalte mit Jahreszahlen (18,19,20) und eine Spalte mit unterschiedlichen Zahlen (3,4,x3,x4 usw.)


Die Summe der Zahlen ohne x davor lässt sich mit Bedingungen relativ leicht ausrechnen. Jedoch nicht wenn ich die Summer der Zahlen mit x davor ausrechnen soll. Ich habe zwar schon eine Formel um die Summe zu bekommen, schaffe es aber nicht die 2. Bedingung, das die Summer nur für die einzelnen Jahre berechnet wird, hinzubekommen.


für die komplette Summe habe ich das hier: (Matrixformel)


SUMME(WENN(LINKS(Gesamtliste!AX10:AX600;1)="x";RECHTS(Gesamtliste!AX10:AX600;LÄNGE(Gesamtliste!AX10:AX600)-1)*1))


wie kann ich hier die zweite Bedingung einbauen?

Betrifft: AW: so nicht eindeutig ...
von: neopa C
Geschrieben am: 11.02.2020 15:34:55

Hallo Matthias,

... (D)eine kleine Beispieldatei könnte da Aufklärung über IST und Ziel bringen.

Gruß Werner
.. , - ...

Betrifft: AW: Summe mit mehreren Bedingungen; Summe über Zahlen die x davor stehen haben
von: Matthias
Geschrieben am: 12.02.2020 07:25:06

Guten Morgen,

ich habe ein Beispiel-Datei hochgeladen. Leider darf ich die original Datei nicht nehmen. Es sollte aber ersichtlich sein was mein Problem ist.

Ein paar Erklärungen stehen mit in der Excel-File

https://www.herber.de/bbs/user/135139.xlsx

Vielen Dank schonmal

Betrifft: AW: jetzt eindeutig; dann reicht eine Formel ...
von: neopa C
Geschrieben am: 12.02.2020 16:33:52

Hallo Matthias,

... mit folgender klassischen Matrixformel in E1:

{=SUMME(WECHSELN("0"&E$11:E$25;"x";"")*($C$11:$C$25=WENN($D1="";$C$11:$C$25;$D1))
*WENN(LINKS($A1;3)="erl";ISTTEXT(E$11:E$25);ISTZAHL(E$11:E$25)))}


und diese nach unten und rechts ziehend kopiert, werden die gewünschten Ergebnisse ermittelt.

Gruß Werner
.. , - ...

Betrifft: AW: jetzt eindeutig; dann reicht eine Formel ...
von: Matthias
Geschrieben am: 13.02.2020 07:47:44

Hallo Werner,

vielen Dank für die Formel. Nach ein paar kleinen Anpassungen hab ich eine für mich passende Lösung gefunden.

Würde es auch eine Lösung als wirklich klassische Formel geben? Also keine Matrix-Formel.

Was meinst Du?

Betrifft: AW: nachgefragt ...
von: neopa C
Geschrieben am: 13.02.2020 09:11:16

Hallo Matthias,

... denn Deinen Wunsch kann ich momentan nicht wirklich nachvollziehen. Du hattest doch ursprünglich schon mehrere klassische Matrixformeln im Einsatz und hast damit nur einen Teil der jetzigen einen Formel gelöst. Was spricht also gegen meinen bisherigen Formelvorschlag? Eine äquivalente Formel ohne {} würde hier mit zusätzlichen Aufwand verbunden sein und die Formel wahrscheinlich viel länger werden. Warum also dies?

Gruß Werner
.. , - ...

Betrifft: AW: nachgefragt ...
von: Matthias
Geschrieben am: 13.02.2020 11:51:06

Hallo Werner,



der Hintergrund ist die riesige Menge (ca. 50000 Zeilen) an Daten die in der Originaltabelle steht und eine Matrixformel doch relativ lange braucht gerade wenn es nicht die einzige ist.



Die Beispiel-Datei ist extrem abgespeckt worden um ein Beispiel zu kreieren.

Betrifft: AW: bei einer derartigen auszuwertenden Datenmnge
von: neopa C
Geschrieben am: 13.02.2020 13:20:12

Hallo Matthias,

... hilft Dir auch eine {}-freie Formellösung nicht wirklich. Dann käme als Formellösung nur eine Hilfsspaltenlösung in Frage und zwar für jede Schulung eine. Und dies deshalb, weil Deine Kennzeichnung der erledigten Tage mit dem vorangestellten "x" ungünstig gewählt ist.

Als Alternative bliebe noch hier eine Auswertung über PowerQuery.

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Summe mit mehreren Bedingungen; Summe über Zahlen die x davo"