ZÄHLENWENN mit mehreren Bedingungen

Bild

Betrifft: ZÄHLENWENN mit mehreren Bedingungen
von: Horst Helfen
Geschrieben am: 20.04.2005 08:27:43
Ich habe bereits mehrere Beiträge zu diesem Thema studiert und ausprobiert. Dabei bin ich auf ein Problem gestoßen:
Ich habe in Spalte A Monatszahlen und in einer E die Namen von Personen, jeweils in den Zeilen 3 bis 194.
Wenn ich jetzt feststellen will, welche Personen im aktuellen Monat wie oft eingetragen sind, geht das mit der Formel
=SUMMENPRODUKT(($A3:$A194=MONAT(HEUTE()))*($E3:$E194="Name"))
So weit so gut. Jetzt werden aber in den Spalten ständig neue Daten eingetragen und ich kann in der Formel keinen festen Bereich angeben. Ich wollte diese daher folgendermaßen abwandeln:
=SUMMENPRODUKT(($A:$A=MONAT(HEUTE()))*($E:$E=P25))
was aber zu einer Fehlermeldung (#ZAHL!) führt. Wenn ich in der obigen Formel statt der Zeilenangabe 194 z. B. jeweils 1000 eingebe (um zukünftige Eingaben abzudecken), funktioniert es. Das erscheint mir aber nicht sonderlich elegant.

Bild

Betrifft: AW: ZÄHLENWENN mit mehreren Bedingungen
von: Harald Kapp
Geschrieben am: 20.04.2005 08:58:32
Hallo Horst,
probier mal statt $A:$A einfach A:A. Bei Zählenwenn geht das, vielleicht aiuch beim Summenprodukt?
Gruß Harald
Bild

Betrifft: AW: ZÄHLENWENN mit mehreren Bedingungen
von: heikoS
Geschrieben am: 20.04.2005 09:42:06
Hallo Horst,
summenprodukt() kann ganze Spalten nicht verarbeiten, nimm daher statt A:A besser A3:A65535.
Wenn Du die Überschriften in den Zeilen 1 und 2 mit reinnehmen möchtest (warum?), solltest Du die Funktion etwas anders aufbauen: summenprodukt(--(a1:a65535=monat(heute())),--(e1:e65535=p25))
Dann liefert die Formel das gewünschte Ergebnis.

Gruß Heiko
 Bild

Beiträge aus den Excel-Beispielen zum Thema "ZÄHLENWENN mit mehreren Bedingungen"