HERBERS Excel-Forum - das Archiv

Thema: Wenn mit mehreren Bedingungen

Wenn mit mehreren Bedingungen
Werner Denner
Hallo Excel Freunde

Habe wieder mal eine Frage.
Ich möchte in Zelle F12 folgendes Ergebnis haben:

1. Bedingung
Wenn in Zelle Q12 als Ergebnis eine Null steht und Zelle P12 leer ist, soll in Zelle F12 nichts stehen.

2. Bedingung
Wenn in Zelle Q12 als Ergebnis eine Zahl höher als Null steht und Zelle P12 leer ist, soll als Ergebnis C12 - B12 stehen.

3. Bedingung
Wenn in Zelle P12 ein g steht, soll als Text Erledigt stehen.

Beispiel:

P12 Q12 F12
leer 0 leer
leer 5 Berechnung C12-B12
g leer Erledigt

Hoffe, Ihr könnt mir dazu die Nötige Formel nennen.

Danke
Werner
AW: Wenn mit mehreren Bedingungen
SF
Hola,
ungetestet:
=wenn(und(Q12=0;P12="");"";wenn(und(Q12>0;P12=22);C12-B12;wenn(P12="g";"erledigt";"")))

Gruß,
steve1da
AW: Wenn mit mehreren Bedingungen
Onur
=WENN(P12="g";"erledigt";WENN(Q12=0;"";C12-B12))
AW: Wenn mit mehreren Bedingungen
daniel
HI

teste mal:

=Wenn(P12="g";"Erledigt";Wenn(P12<>"";"???";Wenn(Q12=0;"";Wenn(Q12<0;"???";C12-B12))))

??? heißt, dass du für diesen Fall noch keinen Ergebniswunsch geäußert hast.

Gruß Daniel

AW: Wenn mit mehreren Bedingungen
Oppawinni
Hm,
Es gibt da so einige ähm... Definitionslücken.
Für mich sieht das unter dem Strich dann so aus:

=WENN(P12<>"";"Erledigt";WENN(Q12<=0;"";C12-B12))

Wenn in P12 z.B. irgendwas ist ausser "" steht, dann kommt halt "Erledigt" raus, etwas anderes ist für den Fall ja nicht definiert.
ob da jetzt "g" was weiß ich stehen kann ? k.A. aber ein anderer Fall wäre ja in deiner Definition nicht abgedeckt.
AW: Wenn mit mehreren Bedingungen
Werner Denner
Danke Onur

Problem gelöst
Danke
Werner
Gerne !
Onur
AW: Wenn mit mehreren Bedingungen
BoskoBiati2
Hi,

so wirklich befriedigend scheinen beide Formeln nicht zu sein. Zudem ist nicht festgelegt, was passiert, wenn in P12 was anderes als g steht:

Userbild


Gruß

Edgar
Dialog-Beispiele