Microsoft Excel

Herbers Excel/VBA-Archiv

Abgleich mit mehreren Bedingungen

Betrifft: Abgleich mit mehreren Bedingungen
von: Erich
Geschrieben am: 14.04.2003 - 10:54:58

Hallo EXCEL-Freunde,

gibt es eine Formel mit der in dem folgenden Beispiel die Spalte das vorgegebene Ergebnis (Fehler oder richtig) ausweist.

Fehler = wenn Name in Spalte A gleich ist, in Spalte C aber unterschiedliche Zahlen zugeordnet sind

richtig = wenn Name in Spalte A gleich ist und in Spalte C gleiche Zahlen zugeordnet sind oder wenn unterschiedliche Zahlen zugeordnet sind und dann in Spalte C die zu a zugeordnete Zahl nicht 1 ist

Das Beispiel soll die Anforderung verdeutlichen:


MS Excel von Erich
 ABCD
1Müllera1Fehler
2Müllerb1Fehler
3Müllerc2Fehler
4Hubera1richtig
5Huberb1richtig
6Mayera3richtig
7Mayerb2richtig
8Mayerc2richtig
9Schmida1Fehler
10Schmidb2Fehler
11Hausera1richtig
12Hauserb1richtig


Vielen Dank für eine Rückmeldung!

mfg
Erich



  

Re: Abgleich mit mehreren Bedingungen
von: Boris
Geschrieben am: 14.04.2003 - 13:12:16

Hi Erich,


MS Excel von Boris an Erich
 ABCDE
1Müllera1FehlerFALSCH
2Müllerb1FehlerFALSCH
3Müllerc2FehlerFALSCH
4Hubera1richtigWAHR
5Huberb1richtigWAHR
6Mayera3richtigWAHR
7Mayerb2richtigWAHR
8Mayerc2richtigWAHR
9Schmida1FehlerFALSCH
10Schmidb2FehlerFALSCH
11Hausera1richtigWAHR
12Hauserb1richtigWAHR


Die Spalten A bis D sind von dir übernommen.
Formel in E1 und runterkopiert:

=((SUMMENPRODUKT(($A$1:$A$12&$C$1:$C$12=A1&C1)*1)=ZÄHLENWENN($A$1:$A$12;A1))+(SUMMENPRODUKT(($A$1:$A$12=A1)*($B$1:$B$12&$C$1:$C$12="a1"))=0)>0)

Ich hoffe, dass ich alles berücksichtigt habe.

Gruß Boris


  

Re: Abgleich mit mehreren Bedingungen
von: Erich
Geschrieben am: 14.04.2003 - 20:32:44

Hallo Boris,

W A H N S I N N !!
Da wär ich nie drauf gekommen - besten Dank!!
Die Formel mit Summenprodukt fasziniert mich immer wieder, aber irgendwie kann ich sie selber nicht umsetzen.

mfg
Erich

 

Beiträge aus den Excel-Beispielen zum Thema "Abgleich mit mehreren Bedingungen"