Microsoft Excel

Herbers Excel/VBA-Archiv

Arbeitszeiten mit mehreren Bedingungen

Betrifft: Arbeitszeiten mit mehreren Bedingungen von: Kurt Schneider
Geschrieben am: 06.08.2006 16:19:19

Hallo,

ich habe folgende Tabelle

von bis Pause Arbeitszeit
8:00 20:00 1:00

Die komplette Arbeitszeit ist von 8:00 bis 20:00
Das Problem
von 8:00 bis 14:01 gibt es keine Zuschläge
von 14:01 bis 16:00 gibt es 20 %
und von 16:01 bis 20:00 gibt es 25 %

Ich habe schon mehrere wenn(und - Verknüpfungen probiert, doch immer wenn ich glaubte es geschafft zu haben erschien #WERT.

Vielleicht kann mir ja jemand helfen.
Vielen Dank im Voraus

  


Betrifft: AW: Arbeitszeiten mit mehreren Bedingungen von: Josef Ehrensberger
Geschrieben am: 06.08.2006 16:59:04

Hallo Kurt!

Ein Ansatz.

Tabelle1
 ABCDEFGHI
1BeginnEndePauseArbeitszeitdavon + 20%davon + 25%BruttoStundensatz:=     22,00 €
207:0016:1501:0008:1502:0000:15     191,68 €   
306:4521:1501:3013:0002:0005:15     323,68 €   
408:0015:3000:4506:4501:3000:00     155,10 €   
Formeln der Tabelle
D2 : =B2-A2-C2
E2 : =SUMMENPRODUKT((ZEILE($1:$1439)<B2*1440)*(ZEILE($1:$1439)>=ZEITWERT("14:00")*1440)*(ZEILE($1:$1439)<=ZEITWERT("15:59")*1440))/1440
F2 : =SUMMENPRODUKT((ZEILE($1:$1439)<B2*1440)*(ZEILE($1:$1439)>=ZEITWERT("16:00")*1440))/1440
G2 : =((D2*24)*$I$1)+((E2*24)*($I$1*0,2))+((F2*24)*($I$1*0,25))
D3 : =B3-A3-C3
E3 : =SUMMENPRODUKT((ZEILE($1:$1439)<B3*1440)*(ZEILE($1:$1439)>=ZEITWERT("14:00")*1440)*(ZEILE($1:$1439)<=ZEITWERT("15:59")*1440))/1440
F3 : =SUMMENPRODUKT((ZEILE($1:$1439)<B3*1440)*(ZEILE($1:$1439)>=ZEITWERT("16:00")*1440))/1440
G3 : =((D3*24)*$I$1)+((E3*24)*($I$1*0,2))+((F3*24)*($I$1*0,25))
D4 : =B4-A4-C4
E4 : =SUMMENPRODUKT((ZEILE($1:$1439)<B4*1440)*(ZEILE($1:$1439)>=ZEITWERT("14:00")*1440)*(ZEILE($1:$1439)<=ZEITWERT("15:59")*1440))/1440
F4 : =SUMMENPRODUKT((ZEILE($1:$1439)<B4*1440)*(ZEILE($1:$1439)>=ZEITWERT("16:00")*1440))/1440
G4 : =((D4*24)*$I$1)+((E4*24)*($I$1*0,2))+((F4*24)*($I$1*0,25))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  




Gruß Sepp


  


Betrifft: AW: Arbeitszeiten mit mehreren Bedingungen von: Luschi
Geschrieben am: 06.08.2006 17:06:33

Hallo Josef,

wenn der Arbeiter in dem 2. Beispiel die Pause aber von 16:01 bis 17:31 macht, wie muß dann die Formel lauten

fragt sich Luschi
aus klein-Paris?


  


Betrifft: AW: Arbeitszeiten mit mehreren Bedingungen von: Kurt Schneider
Geschrieben am: 06.08.2006 17:55:50

Hallo Sepp,

vielen Dank für deine schnelle Hilfe. Leider funktionieren die Formeln nur , wenn die Anfangszeit vor 14:00 ist. In meinem Fall kann die Anfangszeit aber auch nach 14:00 bzw. sogar nach 16:00 sein.

Kurt


  


Betrifft: AW: Arbeitszeiten mit mehreren Bedingungen von: Josef Ehrensberger
Geschrieben am: 06.08.2006 18:53:11

Hallo Kurt!

Dann kann man das ganze mit dieser Formel realisieren.

http://www.excelformeln.de/formeln.html?welcher=9


Gruß Sepp


  


Betrifft: AW: Arbeitszeiten mit mehreren Bedingungen von: Josef B
Geschrieben am: 06.08.2006 21:23:51

Hallo Sepp u.Kurt

Im Beispiel von Sepp in E2:

=MAX(0;MIN(B2;2/3)-MAX(A2;7/12))

In F2
=MAX(0;B2-MAX(A2;2/3))
und die Formeln nach unten Kopieren.

Gruss Josef


  


Betrifft: Meinst Du wirklich ;-) von: FP
Geschrieben am: 06.08.2006 23:06:09

Hallo Sepp,

Ganz so einfach ist es denn doch nicht ;-)

Ich habe hier 2 Lösungen gebastelt:

1) mit Berücksichtigung der Pause bei den Zuschlägen

1 Stunde soferne die Arbeitszeit mehr als 4,5 Stunden beträgt und die nach einer Zeit von 3,5 Stunden angetreten wird

2) ohne Berücksichtigung der Pause bei den Zuschlägen

Tabelle2
 ABCDEFGHIJK
114:0016:0018:0003:3001:00<- Pause nach 3,5 Stunden   ohne Pause
2BegEnd1Beg2EndPauAZ20%25% 20%25%
304:0007:3008:3014:0001:0009:0000:0000:00 00:0000:00
410:0014:0014:0014:0000:0004:0000:0000:00 00:0000:00
508:0011:3012:3015:4501:0006:4501:4500:00 01:4500:00
614:3018:0019:0023:0001:0007:3001:3002:00 01:3002:00
714:3015:5915:5915:5900:0001:2901:2900:00 01:2900:00
812:0015:3016:3022:0001:0009:0001:3001:30 02:0002:00
912:0015:3016:3017:3001:0004:3001:3001:00 02:0001:30
1016:3020:0021:0002:0001:0008:3000:0001:30 00:0001:30
1115:0018:3019:3001:0001:0009:0001:0002:00 01:0002:00
1218:0021:3022:3003:0001:0008:0000:0000:00 00:0000:00
1322:0001:3002:3008:0001:0009:0000:0000:00 00:0000:00
1407:0010:3011:3019:0001:0011:0002:0002:00 02:0002:00
Formeln der Tabelle
B3 : =REST(C3-(C3<D3+(A3>D3))*E$1;1)
C3 : =REST(MIN(A3+D$1+E$1;D3+(A3>D3));1)
E3 : =C3-B3
F3 : =D3+(A3>D3)-A3-E3
G3 : =MAX(;MIN(B$1;B3+(A3>B3))-MAX(A$1;A3))+MAX(;MIN(B$1;B3+0)-A$1)*(A3>B3)+MAX(;MIN(B$1;D3+(C3>D3))-MAX(A$1;C3))+MAX(;MIN(B$1;D3+0)-A$1)*(C3>D3)
H3 : =MAX(;MIN(C$1;B3+(A3>B3))-MAX(B$1;A3))+MAX(;MIN(C$1;B3+0)-B$1)*(A3>B3)+MAX(;MIN(C$1;D3+(C3>D3))-MAX(B$1;C3))+MAX(;MIN(C$1;D3+0)-B$1)*(C3>D3)
J3 : =MAX(;MIN(B$1;D3+(A3>D3))-MAX(A$1;A3))+MAX(;MIN(B$1;D3+0)-A$1)*(A3>B3)
K3 : =MAX(;MIN(C$1;D3+(A3>D3))-MAX(B$1;A3))+MAX(;MIN(C$1;D3+0)-B$1)*(A3>D3)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Servus aus dem Salzkammergut
Franz


  


Betrifft: AW: Arbeitszeiten mit mehreren Bedingungen von: ingUR
Geschrieben am: 06.08.2006 22:04:48

Hallo, Kurt,

aufbauend auf Sepps Vorarbeit habe ich folgenden Vorschlag mit Zellenformel, wobei jedoch die Arbeitszeitpausen moch nicht in dem Formeln berücksichtigt wurden, da aus den Angaben nicht zu erkennen ist, zu welcher Zuschlagsgruppe sie zu zählen sind!
 
 ABCDEFGH
1    14:0016:0020:00Stundensatz
2BeginnEndePauseArbeitszeit100%120%125%22
307:0016:1501:0008:1507:0002:0000:15213,68
417:3021:1501:3002:1500:0000:0002:3068,75
515:1515:3000:1500:0000:0000:1500:006,60
6    ohne Pausen! 
Formeln der Tabelle
D3 : =B3-A3-C3
E3 : =WENN(B3<=$E$1;B3-A3;WENN($E$1-A3<=0;0;$E$1-A3))
F3 : =WENN(B3<=$F$1;WENN(B3-A3-E3<=0;0;B3-A3-E3);WENN($F$1-A3<=0;0;$F$1-A3-E3))
G3 : =WENN(B3<=$G$1;WENN(B3-A3-(E3+F3)<=0;0;B3-A3-(E3+F3));WENN($G$1-A3<=0;0;$G$1-A3-(E3+F3)))
H3 : =$H$2*SUMMENPRODUKT($E$2:$G$2;E3:G3)*24
D4 : =B4-A4-C4
E4 : =WENN(B4<=$E$1;B4-A4;WENN($E$1-A4<=0;0;$E$1-A4))
F4 : =WENN(B4<=$F$1;WENN(B4-A4-E4<=0;0;B4-A4-E4);WENN($F$1-A4<=0;0;$F$1-A4-E4))
G4 : =WENN(B4<=$G$1;WENN(B4-A4-(E4+F4)<=0;0;B4-A4-(E4+F4));WENN($G$1-A4<=0;0;$G$1-A4-(E4+F4)))
H4 : =$H$2*SUMMENPRODUKT($E$2:$G$2;E4:G4)*24
D5 : =B5-A5-C5
E5 : =WENN(B5<=$E$1;B5-A5;WENN($E$1-A5<=0;0;$E$1-A5))
F5 : =WENN(B5<=$F$1;WENN(B5-A5-E5<=0;0;B5-A5-E5);WENN($F$1-A5<=0;0;$F$1-A5-E5))
G5 : =WENN(B5<=$G$1;WENN(B5-A5-(E5+F5)<=0;0;B5-A5-(E5+F5));WENN($G$1-A5<=0;0;$G$1-A5-(E5+F5)))
H5 : =$H$2*SUMMENPRODUKT($E$2:$G$2;E5:G5)*24
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß,
Uwe


 

Beiträge aus den Excel-Beispielen zum Thema "Arbeitszeiten mit mehreren Bedingungen"