Herbers Excel-Forum - das Archiv

Ziffern in Zahlen mit Bedingungen zählen

Bild

Betrifft: Ziffern in Zahlen mit Bedingungen zählen
von: Rene
Geschrieben am: 01.10.2003 13:05:51
Hallo,

ich habe folgende Formel (aus dem Forum) um aus einer Liste (in Spalte A) von 3-Stelligen Zahlen die Anzahl der Zahlen (in Spalte B) mit der Ziffer "2" an erster Stelle abzufragen. Das funktioniert auch prima!

=SUMMENPRODUKT(N(TEIL($A$2:$A$200;1;1)="2");$B$2:$B$200)

Nun möchte ich aber auch wissen, wie viele Zahlen in der Liste an erster Stelle die Ziffer "2" haben und an 3. Stelle die Ziffer "1"?

Eine Verknüpfung der Formel mit "und" liefert immer "#WERT!" in der Ergebniszelle (siehe unten).

=SUMMENPRODUKT(UND(N(TEIL($A$2:$A$200;1;1)="2");N(TEIL($A$2:$A$200;3;1)="1"));$B$2:$B$200)

Bitte um Hilfe!!!

Vielen Dank Rene

Bild

Betrifft: AW: Ziffern in Zahlen mit Bedingungen zählen
von: th.heinrich
Geschrieben am: 01.10.2003 13:43:18
hallo Rene,

die FORMEL scheint von Boris zu sein, dass kannst Du ruhig erwaehnen.

zu dem UND prob folgender vorschlag, nicht ausgetestet.

=SUMMENPRODUKT(N(TEIL($A$2:$A$200;1;1)="2"))*N(TEIL($A$2:$A$200;3;1)="1")

gruss thomas

ps. was dies soll $B$2:$B$200 kann ich nicht nachvollziehen. aber Boris et.al war sicher wieder viel schneller ;-))
Bild

Betrifft: AW: Ziffern in Zahlen mit Bedingungen zählen
von: Rene
Geschrieben am: 01.10.2003 13:53:22
Hallo Thomas,

die Formel ist von einem Marc (mac4). Leider funktioniert die *-Verknüpfung nicht.

Die Erweiterung um $B$2:$B$200 bewirkt, dass die Häufigkeit (befindet sich in Spalte B) der 3-stelligen Zahl mit einer Ziffer "2" an Stelle 1 addiert wird.

Vielen Dank.

Rene
Bild

Betrifft: AW: Ziffern in Zahlen mit Bedingungen zählen
von: th.heinrich
Geschrieben am: 01.10.2003 14:19:33
hallo Rene,

was spricht diesem entgegen.

=SUMMENPRODUKT(N(TEIL($A$2:$A$200;1;1)="2"))*N(TEIL($A$2:$A$200;3;1)="1")+B2

hast Du schon getestet ob auf B2:B200 nicht nicht verzichtet werden kann ?

gruss thomas
Bild

Betrifft: AW: Ziffern in Zahlen mit Bedingungen zählen
von: Rene
Geschrieben am: 01.10.2003 14:34:45
Hi Thomas,

es kann m.E. nicht auf den zusatz b2:b200 verzichtet werden.

Schaust mal den Link unten, in der Datei sind die Versuche dokumentiert.

https://www.herber.de/bbs/user/1229.xls


Gruss Rene
Bild

Betrifft: AW: Ziffern in Zahlen mit Bedingungen zählen
von: th.heinrich
Geschrieben am: 01.10.2003 15:29:48
hallo Rene,

reload ;-)

https://www.herber.de/bbs/user/1230.xls

gruss thomas
Bild

Betrifft: AW: Ziffern in Zahlen mit Bedingungen zählen
von: rene
Geschrieben am: 01.10.2003 15:45:04
hi thomas und boris,

die lösung von boris funktioniert.

vielen, vielen Dank für Eure Hilfe, dass erleichtert uns erheblich die Auswertbarkeit dieser Statistik.

Ihr seid super!

Rene
Bild

Betrifft: danke fuer die rueckmeldung ot.
von: th.heinrich
Geschrieben am: 01.10.2003 16:06:34
.
Bild

Betrifft: Verwechslung im Thread ??? :-((
von: Ramses
Geschrieben am: 01.10.2003 17:32:13
Hallo Andreas,

wenn ich auf deine Antwort klicke erhalte / sehe ich die Antwort von th. Heinrich auf eine andere Frage.
Irgendwas geht hier wieder mal schief.

Gruss Rainer
Bild

Betrifft: Oje,... nun ist das auch am falschen Platz :-(
von: Ramses
Geschrieben am: 01.10.2003 17:33:25
...
Bild

Betrifft: AW: Ziffern in Zahlen mit Bedingungen zählen
von: Boris
Geschrieben am: 01.10.2003 15:28:11
Hi René,

ohne Deine Beispielmappe angeschaut zu haben:

=SUMMENPRODUKT((LINKS(A1:A100)="2")*(RECHTS(A1:A100)="1"))

=Azahl der Zahlen, die mit 2 beginnend UND mit 1 enden.

Grüße Boris
 Bild
Excel-Beispiele zum Thema " Ziffern in Zahlen mit Bedingungen zählen"
Autofilter auch mit Ziffern von Zahlen Im Textfeld nur Eingabe von 2 Ziffern zulassen, dann zum nächsten
Zeichenfolge in Ziffern und Buchstaben aufteilen Eingabebegrenzung und keine Zifferneingabe
Ausziffern von Werten Vorkommen von Zahlenreihen in Spalten
Zeichenfolgen in Zahlen nach Textimport Zahlenformatierung mit Punkt nach der 1. Ziffer
Namen von TextBoxes hochzählen Zählen formatierter Zellen