Summenprodukt mit Summewenn (?)

Bild

Betrifft: Summenprodukt mit Summewenn (?)
von: Andreas
Geschrieben am: 07.10.2015 14:18:33

Liebe Excel-Profis,
vielleicht kann mir jemand von Euch helfen:
In der nachstehenden Muster-Datei soll für jeden Mitarbeiter die Anzahl der Monate ermittelt werden, in denen die Summe seiner Stellenanteile über alle Kostenstellen Null ist.
Mit meiner zusammengebastelten Formel bekomme ich zwar die richtigen Ergebnisse, bräuchte aber eine kompaktere Lösung, da das Ganze nur der Extrakt einer noch umfangreicheren Aufgabe ist.
Für Eure Anregungen schon mal besten Dank im Voraus!
Andreas
Tabelle1

 ABCDEFGHIJKLMNO
1NameKoStJanFebMrzAprMaiJunJulAugSepOktNovDezAuswertung
2Mitarbeiter 1413150,250,250,250,250,250,250,000,250,250,250,250,251
3Mitarbeiter 2474101,001,001,001,001,001,001,001,001,001,001,001,000
4Mitarbeiter 3442000,000,000,000,380,380,380,380,380,380,380,380,383
5Mitarbeiter 3442200,000,000,000,630,630,630,630,630,630,630,630,633
6Mitarbeiter 4430070,630,000,000,000,000,000,000,000,000,000,000,000
7Mitarbeiter 4432000,250,250,370,500,500,500,500,500,500,500,500,500
8Mitarbeiter 5140001,001,001,001,001,001,001,001,001,001,001,001,000
9Mitarbeiter 6454150,050,050,050,050,050,050,050,050,000,000,000,002
10Mitarbeiter 6200000,500,500,500,500,500,500,500,500,500,500,000,002
11Mitarbeiter 6463100,000,000,000,000,000,000,000,000,000,000,000,002
12Mitarbeiter 6473500,100,100,100,100,100,100,100,100,100,100,000,002
13Mitarbeiter 6474130,350,350,350,350,350,350,350,350,400,400,000,002
14Mitarbeiter 7171000,100,100,100,100,100,100,100,100,100,100,100,100
15Mitarbeiter 7170100,900,900,900,900,900,900,900,900,900,900,900,900
16Mitarbeiter 8457201,001,001,001,001,001,001,001,001,001,001,001,000

Formeln der Tabelle
ZelleFormel
O2=SUMMENPRODUKT((SUMMEWENN(A:A;A2;C:C)=0)+(SUMMEWENN(A:A;A2;D:D)=0)+(SUMMEWENN(A:A;A2;E:E)=0)+(SUMMEWENN(A:A;A2;F:F)=0)+(SUMMEWENN(A:A;A2;G:G)=0)+(SUMMEWENN(A:A;A2;H:H)=0)+(SUMMEWENN(A:A;A2;I:I)=0)+(SUMMEWENN(A:A;A2;J:J)=0)+(SUMMEWENN(A:A;A2;K:K)=0)+(SUMMEWENN(A:A;A2;L:L)=0)+(SUMMEWENN(A:A;A2;M:M)=0)+(SUMMEWENN(A:A;A2;N:N)=0))
O3=SUMMENPRODUKT((SUMMEWENN(A:A;A3;C:C)=0)+(SUMMEWENN(A:A;A3;D:D)=0)+(SUMMEWENN(A:A;A3;E:E)=0)+(SUMMEWENN(A:A;A3;F:F)=0)+(SUMMEWENN(A:A;A3;G:G)=0)+(SUMMEWENN(A:A;A3;H:H)=0)+(SUMMEWENN(A:A;A3;I:I)=0)+(SUMMEWENN(A:A;A3;J:J)=0)+(SUMMEWENN(A:A;A3;K:K)=0)+(SUMMEWENN(A:A;A3;L:L)=0)+(SUMMEWENN(A:A;A3;M:M)=0)+(SUMMEWENN(A:A;A3;N:N)=0))
O4=SUMMENPRODUKT((SUMMEWENN(A:A;A4;C:C)=0)+(SUMMEWENN(A:A;A4;D:D)=0)+(SUMMEWENN(A:A;A4;E:E)=0)+(SUMMEWENN(A:A;A4;F:F)=0)+(SUMMEWENN(A:A;A4;G:G)=0)+(SUMMEWENN(A:A;A4;H:H)=0)+(SUMMEWENN(A:A;A4;I:I)=0)+(SUMMEWENN(A:A;A4;J:J)=0)+(SUMMEWENN(A:A;A4;K:K)=0)+(SUMMEWENN(A:A;A4;L:L)=0)+(SUMMEWENN(A:A;A4;M:M)=0)+(SUMMEWENN(A:A;A4;N:N)=0))
O5=SUMMENPRODUKT((SUMMEWENN(A:A;A5;C:C)=0)+(SUMMEWENN(A:A;A5;D:D)=0)+(SUMMEWENN(A:A;A5;E:E)=0)+(SUMMEWENN(A:A;A5;F:F)=0)+(SUMMEWENN(A:A;A5;G:G)=0)+(SUMMEWENN(A:A;A5;H:H)=0)+(SUMMEWENN(A:A;A5;I:I)=0)+(SUMMEWENN(A:A;A5;J:J)=0)+(SUMMEWENN(A:A;A5;K:K)=0)+(SUMMEWENN(A:A;A5;L:L)=0)+(SUMMEWENN(A:A;A5;M:M)=0)+(SUMMEWENN(A:A;A5;N:N)=0))
O6=SUMMENPRODUKT((SUMMEWENN(A:A;A6;C:C)=0)+(SUMMEWENN(A:A;A6;D:D)=0)+(SUMMEWENN(A:A;A6;E:E)=0)+(SUMMEWENN(A:A;A6;F:F)=0)+(SUMMEWENN(A:A;A6;G:G)=0)+(SUMMEWENN(A:A;A6;H:H)=0)+(SUMMEWENN(A:A;A6;I:I)=0)+(SUMMEWENN(A:A;A6;J:J)=0)+(SUMMEWENN(A:A;A6;K:K)=0)+(SUMMEWENN(A:A;A6;L:L)=0)+(SUMMEWENN(A:A;A6;M:M)=0)+(SUMMEWENN(A:A;A6;N:N)=0))
O7=SUMMENPRODUKT((SUMMEWENN(A:A;A7;C:C)=0)+(SUMMEWENN(A:A;A7;D:D)=0)+(SUMMEWENN(A:A;A7;E:E)=0)+(SUMMEWENN(A:A;A7;F:F)=0)+(SUMMEWENN(A:A;A7;G:G)=0)+(SUMMEWENN(A:A;A7;H:H)=0)+(SUMMEWENN(A:A;A7;I:I)=0)+(SUMMEWENN(A:A;A7;J:J)=0)+(SUMMEWENN(A:A;A7;K:K)=0)+(SUMMEWENN(A:A;A7;L:L)=0)+(SUMMEWENN(A:A;A7;M:M)=0)+(SUMMEWENN(A:A;A7;N:N)=0))
O8=SUMMENPRODUKT((SUMMEWENN(A:A;A8;C:C)=0)+(SUMMEWENN(A:A;A8;D:D)=0)+(SUMMEWENN(A:A;A8;E:E)=0)+(SUMMEWENN(A:A;A8;F:F)=0)+(SUMMEWENN(A:A;A8;G:G)=0)+(SUMMEWENN(A:A;A8;H:H)=0)+(SUMMEWENN(A:A;A8;I:I)=0)+(SUMMEWENN(A:A;A8;J:J)=0)+(SUMMEWENN(A:A;A8;K:K)=0)+(SUMMEWENN(A:A;A8;L:L)=0)+(SUMMEWENN(A:A;A8;M:M)=0)+(SUMMEWENN(A:A;A8;N:N)=0))
O9=SUMMENPRODUKT((SUMMEWENN(A:A;A9;C:C)=0)+(SUMMEWENN(A:A;A9;D:D)=0)+(SUMMEWENN(A:A;A9;E:E)=0)+(SUMMEWENN(A:A;A9;F:F)=0)+(SUMMEWENN(A:A;A9;G:G)=0)+(SUMMEWENN(A:A;A9;H:H)=0)+(SUMMEWENN(A:A;A9;I:I)=0)+(SUMMEWENN(A:A;A9;J:J)=0)+(SUMMEWENN(A:A;A9;K:K)=0)+(SUMMEWENN(A:A;A9;L:L)=0)+(SUMMEWENN(A:A;A9;M:M)=0)+(SUMMEWENN(A:A;A9;N:N)=0))
O10=SUMMENPRODUKT((SUMMEWENN(A:A;A10;C:C)=0)+(SUMMEWENN(A:A;A10;D:D)=0)+(SUMMEWENN(A:A;A10;E:E)=0)+(SUMMEWENN(A:A;A10;F:F)=0)+(SUMMEWENN(A:A;A10;G:G)=0)+(SUMMEWENN(A:A;A10;H:H)=0)+(SUMMEWENN(A:A;A10;I:I)=0)+(SUMMEWENN(A:A;A10;J:J)=0)+(SUMMEWENN(A:A;A10;K:K)=0)+(SUMMEWENN(A:A;A10;L:L)=0)+(SUMMEWENN(A:A;A10;M:M)=0)+(SUMMEWENN(A:A;A10;N:N)=0))
O11=SUMMENPRODUKT((SUMMEWENN(A:A;A11;C:C)=0)+(SUMMEWENN(A:A;A11;D:D)=0)+(SUMMEWENN(A:A;A11;E:E)=0)+(SUMMEWENN(A:A;A11;F:F)=0)+(SUMMEWENN(A:A;A11;G:G)=0)+(SUMMEWENN(A:A;A11;H:H)=0)+(SUMMEWENN(A:A;A11;I:I)=0)+(SUMMEWENN(A:A;A11;J:J)=0)+(SUMMEWENN(A:A;A11;K:K)=0)+(SUMMEWENN(A:A;A11;L:L)=0)+(SUMMEWENN(A:A;A11;M:M)=0)+(SUMMEWENN(A:A;A11;N:N)=0))
O12=SUMMENPRODUKT((SUMMEWENN(A:A;A12;C:C)=0)+(SUMMEWENN(A:A;A12;D:D)=0)+(SUMMEWENN(A:A;A12;E:E)=0)+(SUMMEWENN(A:A;A12;F:F)=0)+(SUMMEWENN(A:A;A12;G:G)=0)+(SUMMEWENN(A:A;A12;H:H)=0)+(SUMMEWENN(A:A;A12;I:I)=0)+(SUMMEWENN(A:A;A12;J:J)=0)+(SUMMEWENN(A:A;A12;K:K)=0)+(SUMMEWENN(A:A;A12;L:L)=0)+(SUMMEWENN(A:A;A12;M:M)=0)+(SUMMEWENN(A:A;A12;N:N)=0))
O13=SUMMENPRODUKT((SUMMEWENN(A:A;A13;C:C)=0)+(SUMMEWENN(A:A;A13;D:D)=0)+(SUMMEWENN(A:A;A13;E:E)=0)+(SUMMEWENN(A:A;A13;F:F)=0)+(SUMMEWENN(A:A;A13;G:G)=0)+(SUMMEWENN(A:A;A13;H:H)=0)+(SUMMEWENN(A:A;A13;I:I)=0)+(SUMMEWENN(A:A;A13;J:J)=0)+(SUMMEWENN(A:A;A13;K:K)=0)+(SUMMEWENN(A:A;A13;L:L)=0)+(SUMMEWENN(A:A;A13;M:M)=0)+(SUMMEWENN(A:A;A13;N:N)=0))
O14=SUMMENPRODUKT((SUMMEWENN(A:A;A14;C:C)=0)+(SUMMEWENN(A:A;A14;D:D)=0)+(SUMMEWENN(A:A;A14;E:E)=0)+(SUMMEWENN(A:A;A14;F:F)=0)+(SUMMEWENN(A:A;A14;G:G)=0)+(SUMMEWENN(A:A;A14;H:H)=0)+(SUMMEWENN(A:A;A14;I:I)=0)+(SUMMEWENN(A:A;A14;J:J)=0)+(SUMMEWENN(A:A;A14;K:K)=0)+(SUMMEWENN(A:A;A14;L:L)=0)+(SUMMEWENN(A:A;A14;M:M)=0)+(SUMMEWENN(A:A;A14;N:N)=0))
O15=SUMMENPRODUKT((SUMMEWENN(A:A;A15;C:C)=0)+(SUMMEWENN(A:A;A15;D:D)=0)+(SUMMEWENN(A:A;A15;E:E)=0)+(SUMMEWENN(A:A;A15;F:F)=0)+(SUMMEWENN(A:A;A15;G:G)=0)+(SUMMEWENN(A:A;A15;H:H)=0)+(SUMMEWENN(A:A;A15;I:I)=0)+(SUMMEWENN(A:A;A15;J:J)=0)+(SUMMEWENN(A:A;A15;K:K)=0)+(SUMMEWENN(A:A;A15;L:L)=0)+(SUMMEWENN(A:A;A15;M:M)=0)+(SUMMEWENN(A:A;A15;N:N)=0))
O16=SUMMENPRODUKT((SUMMEWENN(A:A;A16;C:C)=0)+(SUMMEWENN(A:A;A16;D:D)=0)+(SUMMEWENN(A:A;A16;E:E)=0)+(SUMMEWENN(A:A;A16;F:F)=0)+(SUMMEWENN(A:A;A16;G:G)=0)+(SUMMEWENN(A:A;A16;H:H)=0)+(SUMMEWENN(A:A;A16;I:I)=0)+(SUMMEWENN(A:A;A16;J:J)=0)+(SUMMEWENN(A:A;A16;K:K)=0)+(SUMMEWENN(A:A;A16;L:L)=0)+(SUMMEWENN(A:A;A16;M:M)=0)+(SUMMEWENN(A:A;A16;N:N)=0))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Bild

Betrifft: AW: Summenprodukt mit Summewenn (?)
von: KlausF
Geschrieben am: 07.10.2015 14:30:47
Hallo Andreas,
wenn ich Dich richtig verstanden habe, in O2:
=ZÄHLENWENN(C2:N2;"=0")
und Formel nach unten ziehen
Gruß
Klaus

Bild

Betrifft: AW: Summenprodukt mit Summewenn (?)
von: Andreas
Geschrieben am: 07.10.2015 14:38:28
Hallo Klaus,
Danke für Deinen Lösungsansatz, aber das war nicht gemeint:
Der Mitarbeiter 6 wird z. B. auf 5 Kostenstellen geführt, und die Summe seiner Stellenanteile über diese Kostenstellen ist in 2 Monaten (nämlich Nov. und Dez.) Null.
2 ist also das gewünschte Ergebnis, und das habe ich ja auch ermittelt, nur mein Weg dorthin erscheint mir etwas umständlich!
Beste Grüße
Andreas

Bild

Betrifft: AW: Summenprodukt mit Summewenn (?)
von: MAG
Geschrieben am: 08.10.2015 07:49:42
Hallo,
Summenprodukt weglassen, weil ohne Funktion!
Gruß, MAG

Bild

Betrifft: AW: Summenprodukt mit Summewenn (?)
von: Andreas
Geschrieben am: 08.10.2015 08:27:47
Hallo MAG,
Danke auch Dir für den Tipp, aber ohne Summenprodukt bekomme ich leider nicht das gewünschte Ergebnis.
Ich habe Summenprodukt gerade deshalb gewählt, weil gezählt werden soll, wie oft die Summe der Stellenanteile eines Mitarbeiters in den Monaten Jan.-Dez. Null ergibt.
Zur Vereinfachung meines Formelentwurfs hatte ich eher an Matritzen gedacht, habe aber leider zu wenig Ahnung davon.
Gruß, Andreas.

Bild

Betrifft: AW: mit SUMME(), MMULT(), INDEX(), VERWEIS()...
von: ... neopa C
Geschrieben am: 11.10.2015 14:19:37
Hallo Andreas,
... außerdem noch ZÄHLENWENN(), SPALTE() und ZEILE(). Damit ergibt sich eine kompaktere Formel.
Doch das diese dann auch schneller auswertet, bezweifele ich.
Auf jeden Fall setze ich nachfolgend voraus, dass die Datentabelle nach Spalte A sortiert ist.
In O2:

=WENN(A2="";"";SUMME(--(0=MMULT(SPALTE(A2:INDEX(2:2;ZÄHLENWENN(A:A;A2)))^0;INDEX(C:C;VERGLEICH(A2; A:A;)):INDEX(N:N;VERWEIS(9;1/(A$1:A12=A2);ZEILE(A:A))))))) 
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summenprodukt mit Summewenn (?)"