SummeWenn - mehrere Kriterien gleichzeitig

Bild

Betrifft: SummeWenn - mehrere Kriterien gleichzeitig
von: Holger
Geschrieben am: 12.06.2007 18:35:33

Hallo,
ich habe ein Problem und kann auf die schnelle nichts im Forum finden. Ich versuche aus einer Tabelle Werte zu summieren, wenn mehrere Kriterien erfüllt sind. Hier ein Beispiel:
=SUMIF(D:D;B62;U:U)+SUMIF(D:D;C65;U:U)+SUMIF(D:D;C66;U:U)+SUMIF(D:D;C67;U:U)
Der Bereich und der Bereich der summiert werdne soll sind also die gleiche, allerdings sind die Kriterien andere. Kann ich das nicht anders hinbekommen? Ich dachte an
=SUMIF(D:D;B62&C65:C67;U:U)
oder ähnlich. Allerdings scheint das nicht zu funktionieren. Da es nur eine vereinfachte Darstellung ist und mehrere Kriterien erfüllt sein müssen, wäre das Hilfreich wenn es da einfacher ginge...
Anmerkung: In Spalte U ist nicht immer ein Wert.
Danke im Voraus,
-Holger

Bild

Betrifft: AW: SummeWenn - mehrere Kriterien gleichzeitig
von: HermannZ
Geschrieben am: 12.06.2007 19:04:27
Hallo Holger;
versuche einmal folgende Formel;
=SUMIF(D:D;INDIREKT({"B62"."C65"."C66"."C67"});U:U)
Gruss HermannZ

Bild

Betrifft: AW: SummeWenn - mehrere Kriterien gleichzeitig
von: Holger
Geschrieben am: 13.06.2007 09:31:44
Hallo,
leider hat auch diese Formel nicht zum Erfolg geführt.
Ich habe eine Tabelle vereinfacht dargestellt angehangen.
Sobald ich 2 Kriterien eingefügt habe, kommt nurnoch 0 raus...
https://www.herber.de/bbs/user/43201.xls

Bild

Betrifft: AW: SummeWenn - mehrere Kriterien gleichzeitig
von: Holger
Geschrieben am: 13.06.2007 09:48:29
So, jetzt habe ich noch diese Variante versucht, die auch nicht so recht will...
=SUMPRODUCT((D:D=B62)*(U:U))
Wäre um jeden Tipp dankbar.
Mfg
-Holger

Bild

Betrifft: SUMMENPRODUKT akzeptiert keine
von: WF
Geschrieben am: 13.06.2007 11:03:56
ganzen Spalten D:D und U:U
also: D1:D65535 und U1:U65535
Salut WF

Bild

Betrifft: AW: SUMMENPRODUKT akzeptiert keine
von: Hajo_Zi
Geschrieben am: 13.06.2007 11:12:16
Hallo Walter,
war es nicht so das Summenprodukt nicht für die ganze Spalte ging?


Bild

Betrifft: genau das hab ich doch geschrieben
von: WF
Geschrieben am: 13.06.2007 11:29:10
Hi Hajo,
darum ja auch 65535 und nicht 65536

Bild

Betrifft: AW: SUMMENPRODUKT akzeptiert keine
von: Holger
Geschrieben am: 13.06.2007 11:30:58
hmmmm........ :-(
auch das hat nicht geholfen.
Gibt es nicht ganz einfach die Möglichkeit zu sagen:
=SUMIF(E:E;A2,B3;F:F) ?? Also im Prinzip will ich ja nicht mehr :-)
verzweifle bald...
Danke
-Holger

Bild

Betrifft: SUMMENPRODUKT mit +
von: WF
Geschrieben am: 13.06.2007 11:44:09
=SUMMENPRODUKT(((E1:E99=A2)+(E1:E99=B3))*F1:F99)
WF

Bild

Betrifft: AW: SUMMENPRODUKT mit +
von: Holger
Geschrieben am: 13.06.2007 12:13:49
Yiiiiiiiiiiiihaaaaaaaaaaaaaa,
jetzt funktioniert es. Und kürzer geht es nicht? Ich verweise immer auf andere Tabellen, wodurch die Formel sehr schnell sehr lang wird...
Wenn es da keine Möglichkeit gibt, werde ich mich aber auch mit der jetzigen Lösung zufrieden...
VIELEN DANK!!
Super forum
-Holger

 Bild

Beiträge aus den Excel-Beispielen zum Thema "SummeWenn - mehrere Kriterien gleichzeitig"