flexible Spalten und Zeilen - Indirekt?

Bild

Betrifft: flexible Spalten und Zeilen - Indirekt?
von: Bonduca
Geschrieben am: 09.08.2015 17:47:38

Hallo,
ich möchte gerne einen Wverweis über einen flexiblen Bereich machen.
In F3 bzw. G3 befindet sich die letzte Spalte bzw. letzte Zeile des zu betrachtenden Bereichs.
Folgende Formel soll umgeändert werden.
=WVERWEIS(C5;Tabelle1!$A$5:$Z$63;2;FALSCH)
Statt Z63 soll Excel die Spaltenanzahl & die Zeilenanzahl aus F3 und G3 nehmen.
Kann mir hier jemand helfen?
Danke!

Bild

Betrifft: AW: flexible Spalten und Zeilen - Indirekt?
von: Sepp
Geschrieben am: 09.08.2015 18:23:02
Hallo Bonduc,
voraugesetzt in F3 steht die Spalte als Buchstabe, in G3 die Zeile als Zahl und das der Bereich nicht über Spalte Z hinausgeht, dann z.B. so.

=WVERWEIS(C5;Tabelle1!$A$5:INDEX(Tabelle1!$A$1:$Z$63;G3;CODE(GROSS(F3))-64);2;FALSCH)
Gruß Sepp


Bild

Betrifft: AW: flexible Spalten und Zeilen - Indirekt?
von: Herbert Grom
Geschrieben am: 09.08.2015 18:31:38
Hallo,
bei mir hat es damit geklappt:


=WVERWEIS(C5;INDIREKT("$A$5:$"&ZEICHEN($F$3+64)&"$"&$G$3);2;FALSCH)
Servus

Bild

Betrifft: AW: flexible Spalten und Zeilen - Indirekt?
von: Bonduca
Geschrieben am: 10.08.2015 07:21:53
Es hat geklappt.
Da ich mehr als Spalte Z hatte und die Spaltenanzahl als Zahl vorliegen hatte, hab ich statt Zeichen... WECHSELN(ADRESSE(1;F3;4);1;) eingegeben.
Vielen Dank!

 Bild

Beiträge aus den Excel-Beispielen zum Thema "flexible Spalten und Zeilen - Indirekt?"