Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Spalte mit mehrfachem Text, 1. und letzte Zeile

Spalte mit mehrfachem Text, 1. und letzte Zeile
28.12.2012 14:02:13
Franc
Hab schon im Forum gesucht aber nicht das richtige gefunden. (nur mit Zahlen aber bin zu doof das auf Text umzubauen)
Ich habe Text in einer Spalte (siehe unten)
Die Spalte ist sortiert.
Die erste Zeile bekomme ich mit
=VERGLEICH("a";A:A;0)
Wie bekomme ich die letzte Zeile wo "a" drinsteht?
a
a
a
a
b
b
b

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Spalte mit mehrfachem Text, 1. und letzte Zeile
28.12.2012 14:14:27
Hajo_Zi
Tabelle1
 ABC
1a1Erster
2a4Letzter
3a   
4a   
5b   
6b   
7b   

verwendete Formeln
Zelle Formel Bereich
B1 =VERGLEICH("a";A:A;0) 
B2 =VERGLEICH("a";A:A;0)+ZÄHLENWENN(A:A;"a")-1 

Tabellendarstellung in Foren Version 5.50



Anzeige
AW: Spalte mit mehrfachem Text, 1. und letzte Zeile
28.12.2012 14:41:04
Franc
Danke, jetzt wo ich es sehe hätt ich auch selbst drauf kommen können. ;-)
Die einfachsten Lösungen sind halt doch die besten.

=VERWEIS(2;1/(A2:A999="a");ZEILE(2:999)) _oT
28.12.2012 14:18:49
NoNet
Hallo Franc,
mit dieser Funktion erhältst Du die letzte Zeilennummer mit dem Inhalt "a" :
=VERWEIS(2;1/(A2:A999="a");ZEILE(2:999))
Einziger Wehrmutstropfen : Den Bereich (also z.B. bis Zeile 999) mnusst Du hier angeben, eine komplette Spalte kann nich überprüft werden !
Gruß, NoNet

Blödsinn : Komplette Spalte ist doch möglich !
28.12.2012 14:22:41
NoNet
Hallo Franc,
mein Satz war falsch :
...eine komplette Spalte kann nich überprüft werden !
Zumindest unter Excel 2010 kann man doch komplette Spalten durchsuchen - bei früheren Versionen bin ich mir nicht sicher :
=VERWEIS(2;1/(A:A="a");ZEILE(A:A))
Gruß, NoNet
Anzeige

322 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige