Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen mit verschiedenen Bedingungen

Betrifft: Zählen mit verschiedenen Bedingungen von: Frank
Geschrieben am: 13.11.2014 10:10:30

Hallo zusammen,

ich möchte gerne ein VBA-Makro konstruieren, welches mir ermöglicht verschiedene Bedingungen zu berücksichtigen.
In Spalte A befinden sich Städtenamen, in Spalte B Kennziffern, in Spalte C Bewertungen.
Meine Originalliste umfasst ca. 15000 Datensätze. Ich möchte nun zählen lassen, wenn ein Städtename in Spalte A 5x oder öfter vorkommt und gleichzeitig in einer der dazugehörigen Zeilen in Spalte B die Kennziffer mit einer "1" beginnt. Außerdem muss in Spalte C in einer der dazugehörigen Zeilen ein "a" stehen.

https://www.herber.de/bbs/user/93731.xlsx

Wie könnte ich das realisieren?

Viele Grüße und Danke vorab für die Hilfe
Frank

  

Betrifft: AW: Zählen mit verschiedenen Bedingungen von: Frank
Geschrieben am: 13.11.2014 10:23:34

...ich habe noch eine Bedingung vergessen, die es noch komplizierter machen dürfte.
In Spalte D müssen mindestens 5 eindeutige Werte (also unterschiedliche) stehen.
In meiner Beispieldatei dürfte dann nur Nürnberg und München gezählt werden, da die beiden alle Bedingungen erfüllen.

https://www.herber.de/bbs/user/93735.xlsx

Gruß
Frank


  

Betrifft: AW: Zählen mit verschiedenen Bedingungen von: Frank
Geschrieben am: 13.11.2014 10:24:55

Nürnberg und Berlin natürlich.....


  

Betrifft: wieso Nürnberg ? ... von: neopa C (paneo)
Geschrieben am: 13.11.2014 10:52:19

Hallo Frank,

... nach Deinen Vorgaben käme Nürnberg nicht in Frage (in Spalte C) nur "b") dafür aber doch Hamburg. oder?

Sollen die Städte nur gezählt werden oder gelistet?

Ich werde mich aber wieder ausklinken, da ich mich aus VBA raushalte.

Gruß Werner
.. , - ...


  

Betrifft: AW: wieso Nürnberg ? ... von: Frank
Geschrieben am: 13.11.2014 11:07:48

...ja stimmt, eigentlich ist es nur noch Berlin.
Ich bin vor lauter Zahlen schon etwas durch den Wind....

Gruß


  

Betrifft: ich sehe da noch Hamburg ...und von: neopa C (paneo)
Geschrieben am: 13.11.2014 11:31:36

Hallo Frank,

... ich könnte Dir auch eine relativ einfache Formellösung bieten sowohl für die Anzahl als auch für das Listing bieten, wenn Deine sonst verbal def. Bedingungen auch stimmen.

Reicht Dir das?


Gruß Werner
.. , - ...


  

Betrifft: AW: ich sehe da noch Hamburg ...und von: Frank
Geschrieben am: 13.11.2014 11:35:59

Hallo Werner,
ich würde es auch mit einer Formel versuchen, wenn es keine VBA-Lösung geben sollte.

Gruß


  

Betrifft: nun (m) eine Formellösung ... von: neopa C (paneo)
Geschrieben am: 13.11.2014 11:53:03

Hallo Frank,

... natürlich gibt es auch eine VBA-Lösung, aber ich bevorzuge eben für mich Formellösungen ;-)

Mit einer Hilfsspalte (hier Spalte H)
Formel H2 bis zum Ende und die Formel in I2 soweit wie notwendig nach unten kopieren.

Wenn es nur um das Ergebnis in G1 ginge, könnte ich auch über eine hilfsspaltenfreie Lösung nachdenken, wenn es die Zeit erlaubt.

 ABCDEFGHI
1StädteKennzifferBewertungEindeutig  2 Städte
2Hamburg100a1    Hamburg
3Hamburg110a2    Berlin
4Hamburg220a3     
5Hamburg200a4     
6Hamburg300a5     
7Hamburg4000a5   7 
8Köln110a1     
9Köln220a1     
10Köln300a1     
11Köln300a1     
12München200a1     
13München200a1     
14München220a1     
15München230a1     
16München234a1     
17Frankfurt100a1     
18Frankfurt100a2     
19Berlin199a1     
20Berlin300a2     
21Berlin400a3     
22Berlin500a4     
23Berlin900a5   23 
24Nürnbrg100b1     
25Nürnbrg110b2     
26Nürnbrg200b3     
27Nürnbrg300b4     
28Nürnbrg400b5     
29Nürnbrg400b6     

Formeln der Tabelle
ZelleFormel
G1=ANZAHL(H:H)
H2=WENN(A3=A2;"";WENN(SUMME(N(HÄUFIGKEIT(INDEX(D:D;VERGLEICH(A2;A:A;)):D2;INDEX(D:D;VERGLEICH(A2;A:A;)):D2)>0))>4;ZEILE(); ""))
I2=WENN(ZEILE(A1)>G$1;"";INDEX(A:A;KKLEINSTE(H:H;ZEILE(A1))))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



Gruß Werner
.. , - ...


  

Betrifft: ergänzende Hinweise ... von: neopa C (paneo)
Geschrieben am: 13.11.2014 13:00:32

Hallo Frank,

... bei meiner Formellösung ging ich davon aus, dass Deine Daten nach Städten sortiert oder wenigenstens zusammengestellt sind und das in Spalte D wie in Deinem Beispiel auch wirklich Zahlenwerte stehen, wie in Deinem Beispiel.

Gruß Werner
.. , - ...


  

Betrifft: AW: ergänzende Hinweise ... von: Frank
Geschrieben am: 17.11.2014 14:15:18

Hallo Werner,

herzlichen Dank für Deinen Einblick in die Formellösung.

Viele Grüße
Frank


 

Beiträge aus den Excel-Beispielen zum Thema "Zählen mit verschiedenen Bedingungen"