Microsoft Excel

Herbers Excel/VBA-Archiv

0 statt minuswert anzeigen | Herbers Excel-Forum


Betrifft: 0 statt minuswert anzeigen von: Andreas F.
Geschrieben am: 03.12.2009 10:30:08

Hallo Excel Freunde

Habe da ein kleines problem

Möchte statt minusergebniss einfach eine 0 da stehen haben.

Beispiel :

A1 : 10
B1 : Leer
C1 : =Summe(B1-A1)

Ergebnis =-10 soll aber sobald es ins Minus geht "0" da stehen.

In Zelle A1 ist immer ein Wert wobei die Zelle B1 ab und an mal leer sein kann.
finde leider keine lösung

Hoffe ihr könnt mir mit nem kleinen Tipp helfen.

MFG Andreas F.

  

Betrifft: AW: 0 statt minuswert anzeigen von: Jörg
Geschrieben am: 03.12.2009 10:37:58

Hallo Andreas,

versuch mal folgendes in C1:

=WENN(SUMME(B1-A1)<0;"";SUMME(B1-A1))

Ciao Jörg


  

Betrifft: AW: 0 statt minuswert anzeigen von: Andreas F.
Geschrieben am: 03.12.2009 10:48:38

Hallo Jörg

Vielen Dank für deine sehr schnelle Hilfe es klappt wunderbar.


  

Betrifft: =Max(B1-A1;0) owT von: Rudi Maintaire
Geschrieben am: 03.12.2009 11:00:47




  

Betrifft: AW: 0 statt minuswert anzeigen von: JogyB
Geschrieben am: 03.12.2009 11:51:24

Hi.

Soll das nur die Anzeige oder den tatsächlichen Wert in der Zelle betreffen?

Gruss, Jogy


  

Betrifft: AW: 0 statt minuswert anzeigen von: Andreas F.
Geschrieben am: 03.12.2009 12:35:53

Hallo Jogy

Es geht darum das ich monatlich die Km stände vom Auto aufschreibe,
und ich am anfang des Monats noch nicht weiß was ich am ende raus habe.
A1 = Km stand Anfang vom Monat
B1 = Km Stand Ende vom Monat
C1 = gefahrene Km vom Monat.

Damit es nicht so blöd aussieht mit dem Minus wollte ich ganz gerne einfach ne 0 da stehen haben sobald ich ins Minus komme was ja dann passiert wenn in spalte B1 nichts drinne steht.

Die Formel von Jörg paßt da halt Wunderbar.

MFG Andreas F.


  

Betrifft: AW: 0 statt minuswert anzeigen von: JogyB
Geschrieben am: 03.12.2009 12:57:07

Hi.

Wenn es nur um die Anzeigegeschichte geht, dann kannst Du auch einfach die Zellen voneinander abziehen und folgendes als benutzerdefiniertes Zahlenformat verwenden:

Standard;"0"

Gruss, Jogy


Beiträge aus den Excel-Beispielen zum Thema "0 statt minuswert anzeigen"