Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

SVERWEIS in anderer Tabelle nur gültige Werte

SVERWEIS in anderer Tabelle nur gültige Werte
Christoph
Liebe Leute,
bitte um Unterstützung bei folgender Fragestellung:
Aus einer Tabelle mit Stamdaten (60 Spalten, ca. 500 Zeilen) wird mittels SVERWEIS
=SVERWEIS("Argument Spalte A";Stammdaten!$A2:$BH2;Suchspalte;FALSCH)
nach unterschiedlichen Argumenten in der Spalte A gesucht und in unterschiedliche Zieldateien verwiesen.
In einer Zieldatei bekomme ich Treffer für alle Zeilen der Stammdatentabelle, für die gilt: Argument Spalte A ist wahr.
In den restlichen Zeilen wird der Wert #NV angezeigt.
So weit so gut.
Gibt es eine Möglichkeit, in der Zieldatei nur jene Zeilen anzeigen zu lassen, wo "sinnvolle" Einträge sind und jene Zeilen, die als Ergebnis #NV liefern automatisch nicht anzeigen zu lassen?
Mir wäre mit einer Antwort sehr geholfen .
Vielen Dank im Voraus!
Christoph
AW: SVERWEIS in anderer Tabelle nur gültige Werte
13.01.2012 11:41:23
jojo
wenn (istnv(Sverweis();0;Sverweis())
AW: SVERWEIS in anderer Tabelle nur gültige Werte
13.01.2012 11:51:32
Christoph
hm,
wenn ich nach deinern Anleitung die Formel baue
=WENN(ISTNV(SVERWEIS("Tagestraining";[TNdaten_laufend_Urban.xls]Stammdaten!$A12:$BH12;14;FALSCH);0; (SVERWEIS("Tagestraining";[TNdaten_laufend_Urban.xls]Stammdaten!$A12:$BH12;14;FALSCH))
dann lautet die Rückmeldung "Sie haben zu viele Argumente für diese Formel eingegeben"
?
Danke
Christoph
AW: SVERWEIS in anderer Tabelle nur gültige Werte
13.01.2012 12:17:09
Rudi
Hallo,
da sitzt ne Klammmer falsch.
=WENN(ISTNV(SVERWEIS("Tagestraining";[TNdaten_laufend_Urban.xls]Stammdaten!$A12:$BH12;14;FALSCH));0; SVERWEIS("Tagestraining";[TNdaten_laufend_Urban.xls]Stammdaten!$A12:$BH12;14;FALSCH))
In 2010 kannst du auch mit =Wennfehler(Sverweis(....);0) arbeiten.
Gruß
Rudi
Anzeige
AW: SVERWEIS in anderer Tabelle nur gültige Werte
13.01.2012 12:39:04
Christoph
danke erstmal,
aber vielleicht habe ich mein Anliegen nicht genau genug beschrieben.
Mit
=WENNFEHLER(SVERWEIS("Tagestraining";[TNdaten_laufend_Urban.xls]Stammdaten!$A5:$BH5;7;FALSCH);0)
erhalte ich 0 als Ergebnis, d.h. die Zeile scheint in der Zieltabelle mit lauter 0-Einträgen auf und ist somit anber immer noch vorhanden.
Natürlich könnte ich dann alle Zeilen mit 0 Einträgen ausblenden.
Aber bei 500 Zeilen und fünf verschiedenen Zieltabellen ist das händisch ein bisschen mühsam.
Daher nochmal die Frage:
Gibt es eine Möglichkeit, in der Zieltabelle ausschließlich jene Zeilen anzeigen zu lassen, die in der Ursprungstabelle "positiv" selektioniert wurden.
Danke
Christoph
Anzeige
AW: SVERWEIS in anderer Tabelle nur gültige Werte
13.01.2012 13:05:53
Rudi
Hallo,
Natürlich könnte ich dann alle Zeilen mit 0 Einträgen ausblenden.
Aber bei 500 Zeilen und fünf verschiedenen Zieltabellen ist das händisch ein bisschen mühsam.

Per Filter geht das ratzfatz.
Gruß
Rudi
AW: SVERWEIS in anderer Tabelle nur gültige Werte
13.01.2012 13:11:08
Christoph
ok, jetzt hab ich´s kapiert!
Vielen Dank
Christoph

329 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige