Microsoft Excel

Herbers Excel/VBA-Archiv

Kundendaten auslesen auf div. Tabellenblätter

Betrifft: Kundendaten auslesen auf div. Tabellenblätter von: Federchen
Geschrieben am: 28.06.2013 12:40:19

Hallo Ihr Lieben!

Leider bin ich an die Grenzen des mir möglichen gestoßen.
Es geht darum, eine Kundenliste (Tabelle1) auszulesen für jeden Kunden, der ein eigenes Tabellenblatt besitzt.
Bezug kann über die Kundennummer genommen werden, die bei Tabelle1 in Spalte A und beim Kunden in B3 steht.

So schaut das mit den von mir verwendeten Formeln jetzt aus:

http://i39.tinypic.com/mwe9u0.png

http://i40.tinypic.com/k9v2xf.png

Nun ist es über diese einfache Variante nicht möglich, mal eben alle Kunden auszulesen, da unschöne Lücken entstehen. Ausgabe der Daten soll ab A12 sein in der angegebenen Reihenfolge.

Desweiteren soll die Spalte beim Kunden, in der die Preise stehen (D), berechnet werden anhand der in Spalte E angegebenen Vorwahlnummern, da für Mobilfunk, Festnetz und Sonderrufnummern unterschiedliche Preise gelten.

Das funktioniert bisher über diese Formel:
=WENN(E12=""; ""; WENN(E12="0";"0,000"; WENN(E12="9999"; "0,000"; WENN(E12="0800"; "0,000"; WENN(E12<="0151"; "Manuell!"; WENN(E12<="0163";B12*24*60*8,4; WENN(E12<="0169"; "Manuell!"; WENN(E12<="0179"; B12*24*60*8,4; "Manuell!"))))))))

Aber wie gesagt, das funktioniert auf Kunde NR. 10001, beim nächsten müsste ich schon wieder alle Formeln ändern und Leerzeilen raus löschen. Das ist bei ein paar Hundert Fällen zu viel Arbeit.

Habt Ihr ein paar Infos für mich?

  

Betrifft: AW: Kundendaten auslesen auf div. Tabellenblätter von: Matze Matthias
Geschrieben am: 29.06.2013 23:37:07

Hallo ???

wer bist du denn ???

Mal eine bescheidene Frage: Würdest du mit Bildern arbeiten wollen???
Mach dir wenigsten die Mühe, falls die Originaldatei zu groß ist eine Musterdatei dessen hier einzustellen und bestücke die mit Beispieldaten.
Ich könnte wetten, das dir dann eventuell wer Antwortet.

Gruß Matze


 

Beiträge aus den Excel-Beispielen zum Thema "Kundendaten auslesen auf div. Tabellenblätter"