Microsoft Excel

Herbers Excel/VBA-Archiv

Angabe der Zeile eines sverweises aus mehreren Tab

Betrifft: Angabe der Zeile eines sverweises aus mehreren Tab von: ToS2
Geschrieben am: 24.10.2014 18:10:30

Hallo,

habe diese Formel um die Bezeichnung eines Artikels mithilfe der Artikelnummer aus mehreren Tabellenblättern zu finden.

=WENN(A2="";"";SVERWEIS(A2;INDIREKT("'"&INDEX({"Niro geschliffen";"Niro ungeschliffen";"Stahl";"Alu"; "Bleche"};VERGLEICH(1;(ZÄHLENWENN(INDIREKT("'"&{"Niro geschliffen";"Niro ungeschliffen";"Stahl"; "Alu";"Bleche"}&"'!b:b");A2)>0)+0;0))&"'!b:h");2;0))

Nun möchte ich, dass wenn sich die eingegebene Artikelnummer in einem bestimmten Bereich (z.B. Zeile 2 - Zeile 20) befindet "die 3. Spalte dieser Zeile zurückgegeben wird, ansonsten "1"

Hat jemand die Lösung für mein Problem???

Danke im voraus und sg
ToS2

  

Betrifft: AW: Angabe der Zeile eines sverweises aus mehreren Tab von: Hajo_Zi
Geschrieben am: 24.10.2014 18:13:25

lese mal FAQ

Zu Crossposting lese diese Seite Hajo-Excel.de
Durch Crosspostuing werden mehrere Gruppen von Leuten mit dem gleichen Thema befasst, ohne dass sie voneinander wissen.
Naturgemäß laufen dann die Antworten, die im einen Forum "zu spät" gegeben wurden, ins Leere und bleiben ohne Resonanz.
Es reicht also, zunächst in einem Forum zu posten - wenn die Antworten dann unbefriedigend sein sollten, steht es einem anschließend immer noch offen, ein anderes Forum zu Rate zu ziehen.

GrußformelHomepage


  

Betrifft: AW: Angabe der Zeile eines sverweises aus mehreren Tab von: ToS2
Geschrieben am: 24.10.2014 18:27:56

Sorry

kommt nicht wieder vor!


 

Beiträge aus den Excel-Beispielen zum Thema "Angabe der Zeile eines sverweises aus mehreren Tab"