Microsoft Excel

Herbers Excel/VBA-Archiv

Zwei Fragen: Zusammenzählen und Auswertung | Herbers Excel-Forum


Betrifft: Zwei Fragen: Zusammenzählen und Auswertung von: Sebastian.J
Geschrieben am: 11.01.2010 14:02:53

Hallo Leute,

ich arbeite gerade an einer Provisionstabelle, diese findet ihr im Anhang, damit ihr direkt ein Bild davon habt. Hier sind schon einige Makros aus euren Hilfen ;).

Nun habe ich ein Zählproblem und Auswertungsproblem.

Wie ihr in Spalte H seht steht dort "Gewertet" in Spalte L "IP" Er soll nun in Spalte L alle "Ja" suchen und diese dann für den für den IP in Spalte L zusammenzählen. Im Notfall mit Hilfstabellen.

Daraus errechnet sich dann eine Prämie.

Das zweite Problem ist die Auswertung für jeden IP. Wie kann ich eine Suchanforderung erstellen sodas ich alle gewerteten Aufnahmen von Muster IP A in einer Übersicht habe.

Ich wähle Muster IP A aus und er spuckt mir alle Vornamen und NAmen aus die Gewertet worden sind.

Hoffe ich habe mich verständlich ausgedrückt.

Hier die Datei bisher: https://www.herber.de/bbs/user/67130.xls

  

Betrifft: AW: Zwei Fragen: Zusammenzählen und Auswertung von: fcs
Geschrieben am: 11.01.2010 16:29:10

Hallo Sebastian,

beide Auswertungen kannst du als Pivottabellenberichte auf Basis der Daten Tabelle "NAs" erstellen.

Hier deine Tabelle mit den Auswertungen. Für mehr datenzeilen muss du ggf. den Datenbereich der Quelldaten für die Pivot-Berichte vergrößern.

Gruß
Franz
https://www.herber.de/bbs/user/67137.xls


  

Betrifft: AW: Zwei Fragen: Zusammenzählen und Auswertung von: Sebastian.J
Geschrieben am: 12.01.2010 09:13:12

Erszmal Danke für das Beispiel,

wie aktualisiere ich jetzt aber die Pivot-Tabelle? Wenn ich nun weitere Zeilen mit Ja kennzeichnet wird dies noch nicht mit in die Pivot übernommen.

Und wo genau kann ich den Zellenbereich vergrößern? Habe mit Pivot tabellen noch nicht direkt geabreitet. Vielleicht hier als kurze Erklärung dann habe ich wieder was dazu gelernt :d.


  

Betrifft: AW: Zwei Fragen: Zusammenzählen und Auswertung von: Sebastian.J
Geschrieben am: 12.01.2010 09:17:42

OK. Aktualisierung habe ich schon selber gefunden. Einfach mal auf das "Ausrufezeichen" klicken :).

Nur den Zellenbereich vergrößern das ist die Frage. Und ich habe in deiner Tabelle eine weitere Tabelle gefunden, Tabelle 1, für was ist diese dadacht?


  

Betrifft: AW: Zwei Fragen: Zusammenzählen und Auswertung von: Sebastian.J
Geschrieben am: 12.01.2010 12:05:14

Habe die Frage nochmal geöffnet, Gerade bei meiner Antwort vergessen.


  

Betrifft: AW: Zwei Fragen: Zusammenzählen und Auswertung von: Sebastian.J
Geschrieben am: 12.01.2010 13:14:52

Muss leider noch was schreiben. Arbeite gerade an der Geschichte weiter. Wie kann ich es hinbekommen, das er mit in der Tabelle IP gewerten die mit Ja gekennzeichnet sind wuartalsweise rausschmeißt. Also im Datum sehen kann ob es im ersten quartal, zweiten u.s.w. gewesen ist.

sorry viele Fragen aber wenn man etwas für seine Übersicht braucht ist Excel noch am besten geeignet. Allerdings habe ich bis dato noch nicht so etwas kolplexes gestaltet. diesmal soll es aber vernüftig sein.


  

Betrifft: AW: Zwei Fragen: Zusammenzählen und Auswertung von: Sebastian.J
Geschrieben am: 12.01.2010 15:07:06

Ich habe die Tabelle nun noch ein wenig angepaßt:

https://www.herber.de/bbs/user/67175.xls

Nun müßten einige Werte zusamengezählt bzw. mutlipliziert werden.

Und zwaqr in der Tabelle NAs.

Hier soll nun in der Spalte Prämien für den jeweiligen IP folgendes zusammengerechnet werden.

Grundprämie: 30€ Zeile O2
mehr als 5 gewertete im Quartal dann 65€ also plus 15€ O3
mehr als 16 gewertete im Quartal dann 80€ also nochmal plus 15€ O4

dann immer für alle rückwirkend im Quartal.

Hoffe ich habe mich verständlich ausgedrückt.


  

Betrifft: AW: Zwei Fragen: Zusammenzählen und Auswertung von: fcs
Geschrieben am: 13.01.2010 00:11:29

Hallo Sebastian,

ich hab in deiner Datei ein Blatt "Info" eingefügt mit ein paar Erläuterungen zu den Formeln in den Blättern und zur Anpassung des Datenbereichs für Pivot-Tabellen.

Ich hoffe ich hab die gewünschte Auswertung für Prämien und NAs im Quartal korrekt verstanden und umgesetzt.

Gruß
Franz
https://www.herber.de/bbs/user/67179.xls


  

Betrifft: AW: Zwei Fragen: Zusammenzählen und Auswertung von: Sebastian.J
Geschrieben am: 13.01.2010 08:51:16

Erstmal Danke für die Hilfe und Erklärungen. So lerne ich auch immer etwas dazu und kann es nachvollziehen. Für mich nur eine Verständnisfrage, da ich mir den Umgang mit Excel selber beigebracht habe und deshalb vielleicht das ein oder andere noch umständlich löse.

Was bedeuten in den Wenn-Formeln die "*" normal hatte ich dort ja immer ein ";" gesetzt. Welche Funktion hat das "*" und was bewirkt es.

Ich werde jetzt mal Aufgrund deiner Hilfe versuchen selber eine Arbeitgeber-Auswertung zu erstelln. Falls dort etwas nicht hinhauen sollte würde ich nochmal deine Hilfe in Anspruch nehmen.

Danke schon mal für die bis dato Super Hilfen.


  

Betrifft: AW: Zwei Fragen: Zusammenzählen und Auswertung von: fcs
Geschrieben am: 13.01.2010 11:59:54

Hallo Sebastian,

Das "*" wird hier in Verbindung Prüfausdrucken verwendet. Da funktioniert dann die Summenprodukt-Rechnung so.

=WENN(G9="Ja";(SUMMENPRODUKT(($G$8:$G$300="Ja")*($K$8:$K$300=K9)*($N$8:$N$300=N9))>=1)*$O$2;0)

Das "*" hat hier die gleiche Bedeutung wie das logische UND.
Wenn der Ausdruck in den Klammern WAHR ist, wird dieser in der Rechnung als 1 interpretiert. In diesem Fall wird so für jede Zeile in der die 3 Klammern WAHR sind als Produkt 1 berechnet und zur Summe für den Bereich addiert.
In ähnlicher Weise kann man für logische ODER ein "+" verwenden.

=WENN(UND(A1=2;ODER(B1=3;C1=D1)));1;0)
ist identisch mit
=WENN((A1=2)*((B1=3)+(C1=D1));1;0)
oder noch kürzer:
=(A1=2)*((B1=3)+(C1=D1))*1

Gruß
Franz


  

Betrifft: AW: Zwei Fragen: Zusammenzählen und Auswertung von: Sebastian.J
Geschrieben am: 15.01.2010 09:02:00

Ersmal Danke für die guten Hilfen.

Ich habe es nun auch alleine geschafft eine weitere Auswertungstabelle über Pivot für die AG zu erstellen. Nachdem ich das System "durschschaut" hatte.

So sieht die Tabelle nun aus: https://www.herber.de/bbs/user/67236.zip
(Als zip, da über 300kb)

Jetzt habe ich eine weitere Frage. Ist es möglich das er bei bestimmten IPs die in der Tabelle IP angezeigt werden die getätigte NA die in Tabelle NAs eingetragen wird nicht mit 1 wertet sondern mit 0,7?

Als Beispiel:
Muster IP A hat die Wertung 0,7
Empfehlung hat die Wertung 1,0

u.s.w.

Kann man dies realisieren? Wenn es nicht für einzelne IPs die in der Tabelle IP eingetragen möglich ist, dann wäre es schon wenn wenigstens bei dem IP Empfehlungen mit 1,0 gewertete wird bei allen anderen mit 0,7.

Ich habe es im Moment in der Tabelle IP so gelöst, das nur Empfehlungen mit 1,0 gewertet werden. Siehe Tabelle IP, Spalte D.

Schön wäre es aber wenn es für jeden eingetragenen einzeln einstellbar wäre.


  

Betrifft: AW: Zwei Fragen: Zusammenzählen und Auswertung von: fcs
Geschrieben am: 16.01.2010 10:15:38

Hallo Sebastian,

dazu benötigts du eine zusätzlich Spalte im Blatt IP, um den Faktor einzutragen. Per SVERWEIS kann man dann über den IP-Namen den Faktor in die Formeln im Blatt "NAs" einbauen. Voraussetzung ist, dass es keine Namensgleichen IP's gibt.

Gruß
Franz

NAs

 LMNOP
7IPPrämieEmpfehlungQuartalNAs im Quartal
8Muster IP AA50 €01. Quartal 20100,75

Formeln der Tabelle
ZelleFormel
M8=WENN(L8="Empfehlung";0;WENN(H8="Ja";(SUMMENPRODUKT(($H$8:$H$300="Ja")*($L$8:$L$300=L8)*($O$8:$O$300=O8))>=1)*$P$2+(SUMMENPRODUKT(($H$8:$H$300="Ja")*($L$8:$L$300=L8)*($O$8:$O$300=O8))>=6)*$P$3+(SUMMENPRODUKT(($H$8:$H$300="Ja")*($L$8:$L$300=L8)*($O$8:$O$300=O8))>=16)*$P$4;0))
N8=WENN(UND(L8="Empfehlung";H8="Ja"); $P$5;0)
O8=MONAT(10*MONAT(G8))&". Quartal " & JAHR(G8)
P8=WENN(H8="Ja";SVERWEIS(L8;IP!$B$4:$E$54;4;FALSCH)*SUMMENPRODUKT(($H$8:$H$300="Ja")*($L$8:$L$300=L8)*($O$8:$O$300=O8)); 0)

IP

 BCDE
4IP/VPPIDIP-FaktorGesamt NA-IP
5  0,70
6aa 0,70
7ad 0,70
8ad 0,70
9Empfehlung 11
10Muster IP AA000000040,750,75
11Muster IP AB000000050,70
12Muster IP B000000020,80,8

Formeln der Tabelle
ZelleFormel
E5=SUMME(F5:I5)*D5


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Beiträge aus den Excel-Beispielen zum Thema "Zwei Fragen: Zusammenzählen und Auswertung"