Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwert (einfach) | Herbers Excel-Forum


Betrifft: Mittelwert (einfach) von: Andreas Berg
Geschrieben am: 11.01.2010 14:14:22

Hallo
sollte eigentlich ganz einfach sein, komm aber nicht von selbst drauf:

ich habe folgende Tabelle (als Beispiel)
A|B
---
x|8
x|12
y|1
x|9
y|14
y|2

Ich möchte jetzt gerne den Durchschnitt aller Zahlen in der Spalte B haben, vorausgesetzt in der dazu gehörigen Spalte A steht ein "x"
Das Ergebnis wäre dann (8+12+9)/3 =9,66

Welche Funktion brauche ich ?

  

Betrifft: AW: Mittelwert (einfach) von: hary
Geschrieben am: 11.01.2010 14:20:12

Hallo
eine Moeglichkeit.

Tabellenblattname: Tabelle1

 

A

B

C

D

1

x

8

 

 

2

x

12

 

9,66666667

3

y

1

 

 

4

x

9

 

 

5

y

14

 

 

6

y

2

 

 


Benutzte Formeln:
D2: =SUMMEWENN(A1:B6;"x";B1:B6)/ZÄHLENWENN(A1:A6;"x")
gruss hary


  

Betrifft: =MITTELWERT(WENN(A2:A7="x";B2:B7)) von: NoNet
Geschrieben am: 11.01.2010 14:20:25

Hallo Andreas,

so geht's :

ABCDE
1
2
3
4
5
6
7

MATRIX-Funktionen (mit Strg+Shift+ENTER bestätigen)
ZelleFormel
E1   {=MITTELWERT(WENN(A2:A7="x";B2:B7)

Tabelle eingefügt mit Syntaxhighlighter 4.15

Funktion in E1 ohne die Klammern { } eingeben, dafür jedoch mit Strg+Shift+ENTER bestätigen (MATRIX-Funktion !)

Gruß, NoNet


  

Betrifft: AW:eleganter ;-) owT von: hary
Geschrieben am: 11.01.2010 14:22:00

.


  

Betrifft: Off Topic von: Worti
Geschrieben am: 11.01.2010 14:24:10

Hi NoNet,
wünsch dir ein gutes Jahr 2010.
Hast du eventuell irgendwann mal Zeit, exceltreffen.de zu aktualisieren?

Gruß Worti


  

Betrifft: OT@Worti : Ebenfalls 2010 - WAS aktualisieren ? von: NoNet
Geschrieben am: 11.01.2010 14:47:52

Moin Worti,

nochmals ganz speziell für Dich (obwohl ich das bereits allgemein formuliert hatte :
Siehe https://www.herber.de/forum/archiv/1124to1128/t1126599.htm

Prosit 2010 und alles Gute für die nächsten 12 Monate ;-))

Das mit der Aktualisierung unserer Seite http://www.exceltreffen.de ist so eine Sache : WAS sollte ich denn aktuelles darauf platzieren ? - Die Fotos sind bereits "püntklich" seit Weihnachten (mit knapp 3 Monaten Verspätung ;-) Online und etwas Neueres gibt's nicht. Oder wolltest Du da etwas ganz bestimmtes ergänzen ?

Gruß, NoNet


  

Betrifft: ...ev.dein Excelei.de ??? Gruß von: robert
Geschrieben am: 11.01.2010 17:19:34

;-)


  

Betrifft: AW: OT@Worti : Ebenfalls 2010 - WAS aktualisieren ? von: Worti
Geschrieben am: 11.01.2010 19:40:29

Hi NoNet,
ich bin ein wenig blind. Ich hab zuerst auf exceltreffen/home geschaut, nix Neues.
Unter Navigatoreintrag Treffen 2009 - nix Neues.
Unter Navigatoreintrag Treffen Archiv - Kein Eintrag für 2009.
Und dann hab ich aufgegeben-wohl zu früh. Unter Bildergalerie wäre ich wohl fündig geworden.

Gruß Wort


  

Betrifft: OT@Worti : Habe es etwas angepasst ! _oT von: NoNet
Geschrieben am: 12.01.2010 13:50:19

_oT


  

Betrifft: SUMMEWENN/ZÄHLENWENN von: Worti
Geschrieben am: 11.01.2010 14:20:47

Hallo Andreas,
so gehts: =SUMMEWENN(A1:A6;"x";B1:B6)/ZÄHLENWENN(A1:A6;"x")

Gruß Worti


  

Betrifft: AW: Mittelwert (einfach) von: Hajo_Zi
Geschrieben am: 11.01.2010 14:22:25

Hallo Andreas,


Tabelle1

 ABC
33x89,66666667
34x12 
35y1 
36x9 
37y14 
38y2 

verwendete Formeln
Zelle Formel
C33 {=MITTELWERT(WENN(A33:A38="X";B33:B38))}
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 5.3



GrußformelHomepage


  

Betrifft: AW: Mittelwert (einfach) von: Andreas Berg
Geschrieben am: 11.01.2010 14:36:19

Vielen Dank
das ging ja fix, funktioniert einwandfrei


Beiträge aus den Excel-Beispielen zum Thema "Mittelwert (einfach)"