Drop-Down und Gültigkeitsprüfung

Bild

Betrifft: Drop-Down und Gültigkeitsprüfung
von: Felixxx
Geschrieben am: 09.10.2003 15:56:44

Kann man eine Gültigkeitsprüfung mit den Tabellennamen verbinden?
Ich habe eine Zelle, wo ich ein Drop-Down erzeuge. Gleichzeitig lade ich in eine Tabelle Daten aus dem Internet herunter, die stehen dann in einer Tabelle und ich will mit dem Drop-Down auf Spalte B zugreifen. Es sind ca. 100 Internetseiten wo dann in der Tabelle untereinander stehen und ich habe für jede Internetseite einen Namen generiert und bei "Daten/Gültigkeit..." bei "zulassen" Liste und bei Quelle die Namen der Internetseite. So wie ich sie vergeben habe. Aber mein Problem ist jetzt, die Länge der Seiten verändert sich und dann passt das nicht mehr weil sich die Namen nicht selber verschieben sondern nur ich das ändern kann. Darum hab ich versucht jede Internetseite in eine eigene Tabelle zu packen und versucht darauf zuzugreifen. Aber das klappt nicht. Ich greife mit =INDIREKT($B$2) drauf zu und habe versucht =INDIREKT($B$2)!B2:B20. Das geht aber nicht. Nur wie soll ich das sonst machen? Kein VBA! Läuft alles normal über Excel. Bitte helft mir! Ich bin verzweifelt weil ich mir so eine Arbeit gemacht habe!

Bild


Betrifft: AW: Drop-Down und Gültigkeitsprüfung
von: Felixxx
Geschrieben am: 09.10.2003 16:40:44

Ok, ich glaube das geht nicht. Aber kann man dann den Sverweis mit einem Tabellennamen verbinden? Wenn der Tabellennamen in einer Zelle steht. Und ich mit Sverweis sagen kann z.b. nimm die daten von b2:b20 von der tabelle wo in b2 steht.

=SVERWEIS(D2;'B2'!B2:C20;2;FALSCH)

? Kann man da was machen? WEil so nimmt ers net, mit dem 'B2'


 Bild

Beiträge aus den Excel-Beispielen zum Thema " TXT per Button Speichern " , Problem (WICHTIG!!!)"