Microsoft Excel

Herbers Excel/VBA-Archiv

Summewenns/Summenprodukt

Betrifft: Summewenns/Summenprodukt von: Kelem
Geschrieben am: 05.08.2014 22:12:03

Hallo,

ich habe ein Problem, das ich leider nicht lösen kann. Meiner Meinung nach lässt sich das Problem mit Summewenn(s) oder Summenprodukt lösen (oder auch nicht). Ich habe eine Tabelle mit 21 Zeilen und 21 Spalten, d.h. eine 20x20 Matrix die komplett ausgefüllt ist, wobei die erste Zeile bzw. die erste Spalte ein gewisses Kriterium darstellen. Als Grundlage zu diesen Kriterien werden Zahlen genommen. Nun zum Problem: ich möchte alle Zahlen in dieser Matrix zusammenaddieren, deren Kriterien (Zeile und Spalte) in Summe größer als z.B 1,5 sind. Ist die Summe der Kriterien kleiner als z.B. 1,5 so wid die Zahl nicht addiert. Ich hoffe, dass ich mein Problem gut nachvollziehbar erklären konnte. Im Anhang befindet sich eine Excel-Datei mit dem Beispiel und Kommentaren https://www.herber.de/bbs/user/91920.xlsx. Dies ist mein erster Beitrag und ich hoffe, dass ich gegen die festgelegten Regeln nicht verstoßen habe.

Vielen Dank für Eure Hilfe!!!

  

Betrifft: =SUMMENPRODUKT((A2:A22+B1:V1>1,5)*(B2:V22)) von: Christian
Geschrieben am: 05.08.2014 22:50:42




  

Betrifft: AW: =SUMMENPRODUKT((A2:A22+B1:V1>1,5)*(B2:V22)) von: Kelem
Geschrieben am: 05.08.2014 22:59:03

Vielen Dank!!! :)