Microsoft Excel

Herbers Excel/VBA-Archiv

Datum - Abstände

Betrifft: Datum - Abstände von: Oliver Scheinert
Geschrieben am: 10.08.2008 18:32:34

Hallo,

habe folgendes Problem, vielleicht kann mir jemand helfen:

- in Spalte A habe ich Monatsultimo (31.01.,28.02., ...) abgetragen und in B Zinssätze.
- in Spalte C steht eine "=Wenn(...)"-Formel, welche mir Hochpunkte (mit "+1") und Tiefpunkte (mit "-1")
ausgibt (also ein Hoch ist: vorheriger Datenpunkt und der kommende Datenpunkt kleiner als der aktuelle)

Nun möchte ich folgendes wissen: Ich benötige die Anzahl der Tage von einem Hoch zum nächsten Tief et vice versa ... manchmal ist es nur ein Monat, manchmal 3 oder mehr ... konnte ich mich verständlich machen?

Habe schon an VBA (for i= to ... oder sowas) gedacht, aber erstens habe ich davon null Ahnung und zweitens hoffe ich eigentlich auf eine einfachere Lösung evt. direkt über eine Formel (mit Laufindex oder so)

VIELEN DANK

  

Betrifft: AW: Datum - Abstände von: David
Geschrieben am: 11.08.2008 09:35:23

meinst du so?

https://www.herber.de/bbs/user/54504.xls

Rückmeldung wäre nett.

Gruß

David


  

Betrifft: AW: Datum - Abstände von: Oliver Scheinert
Geschrieben am: 12.08.2008 10:14:08

Hallo David,

ja, so wie du es gemacht hast, habe ich es gemeint. Habe es aber auch noch umsetzen koennen danke der Hilfe eines Bekannten.

Ich habe über

=WENN(D2<>"";ZEILE(D2);E1)

die Zeilen, wo Hochs und Tiefs erscheinen ausgeben lassen und dann in der nächsten Spalte

WENN(D2="";"";INDEX($A$1:$E$56;E2;1)-INDEX($A$1:$E$56;E1;1))

... das hat mir auch die gewünschte Lösung gebracht.

Aber ich habe ein weiteres Problem:

Ich möchte nun per Solver die Rendite maximieren, als Variable bzw. für die NB gelten die Hochs (ich Kaufe also zum Hoch) und Tiefs (ich verkaufe zum Tief), die der Solver nun frei bestimmen soll. Alles funktioniert einwandfrei, aber er gibt mir mehrere Hochs (gekennzeichnet durch "1") und Tiefs (gekennzeichnet durch "-1") in Folge aus. Damit aber alle Berechnung weiterhin sinnvoll innerhalb der Mappe durchgeführt werden können, müsste der Solver nur abwechselnd mit -1 und +1 auf die Rendite hin optimieren!

Könnt Ihr mir dabei weiterhelfen???

Vielen Dank


Oliver


  

Betrifft: AW: Datum - Abstände von: David
Geschrieben am: 12.08.2008 10:17:14

Da wäre es wohl sinnvoll, wenn du die Mappe, auf die sich dein Text bezieht, auch mal hochladen würdest.

Gruß

David


  

Betrifft: AW: Datum - Abstände von: Oliver Scheinert
Geschrieben am: 12.08.2008 11:26:10

genau, ich werde heute oder morgen mal ein Beispiel anfertigen und uploaden, original geht aus vertraulichkeitsgründen nicht,


danke und bis dahin