Microsoft Excel

Herbers Excel/VBA-Archiv

Sortierreihenfolge

Betrifft: Sortierreihenfolge von: Rolf K.
Geschrieben am: 10.08.2008 17:37:17

Hallo
Ich habe ein Problem mit einer Sortierreihenfolge:

9712345
0212741
0114578
0058987
0012347

In diesen Zahlen verbergen sich in den ersten beiden Ziffern die Jahreszahl (02=2002, 97=1997), der Rest ist eine Inventarnummer.
Gerade nach der Jahreszahl soll sortiert werden
Von alt nach neu (von Hand) oder umgekehrt.

9712345
0012347
0058987
0114578
0212741

Wie geht das?
Makro?

Gruss Rolf K.

  

Betrifft: AW: Sortierreihenfolge von: Daniel
Geschrieben am: 10.08.2008 17:55:45

Hi
im prinzip nur so, daß du in einer Hilfsspalte mit einer Formel die Jahreszahl extrahierst und zur 4stelligen Jahreszahl ergänzt. dann kannst du nach dieser Hilfsspalte sortieren:

= Wenn (Links (A1;2) < "50" ; "20" ; "19" ) & Links(A1)

Gruß, Daniel


  

Betrifft: AW: Sortierreihenfolge von: Tino
Geschrieben am: 10.08.2008 18:02:38

Hallo,
mach dir eine Hilfsspalte mit dieser Formel, nach dieser kannst du dann Sortieren.
Sollte das Jahr kleiner wie 1951 sein, passe es in der Formel an.

 AB
197123451997
202127412002
301145782001
400589872000
500123472000

Formeln der Tabelle
ZelleFormel
B1=WENN(UND(--LINKS(A1;2)>50;--LINKS(A1;2)<=99); 1900+--LINKS(A1;2); 2000+--LINKS(A1;2))
B2=WENN(UND(--LINKS(A2;2)>50;--LINKS(A2;2)<=99); 1900+--LINKS(A2;2); 2000+--LINKS(A2;2))
B3=WENN(UND(--LINKS(A3;2)>50;--LINKS(A3;2)<=99); 1900+--LINKS(A3;2); 2000+--LINKS(A3;2))
B4=WENN(UND(--LINKS(A4;2)>50;--LINKS(A4;2)<=99); 1900+--LINKS(A4;2); 2000+--LINKS(A4;2))
B5=WENN(UND(--LINKS(A5;2)>50;--LINKS(A5;2)<=99); 1900+--LINKS(A5;2); 2000+--LINKS(A5;2))




Gruß Tino

www.VBA-Excel.de




  

Betrifft: AW: Sortierreihenfolge von: Rolf K.
Geschrieben am: 10.08.2008 20:22:41

Hallo
Nach einigen Modifizierungen hat es geklappt.

058987 2005 58987=RECHTS(B3;5)
0212741 2002 12741
0123473 2001 23473
0114578 2001 14578
9712345 1997 12345

Da ihr alle die gleicheIdee hattet, bedanke ich mich bei allen drei.

Gruss Rolf K.


  

Betrifft: AW: Sortierreihenfolge von: Rolf K.
Geschrieben am: 10.08.2008 20:22:41

Hallo
Nach einigen Modifizierungen hat es geklappt.

058987 2005 58987=RECHTS(B3;5)
0212741 2002 12741
0123473 2001 23473
0114578 2001 14578
9712345 1997 12345

Da ihr alle die gleicheIdee hattet, bedanke ich mich bei allen drei.

Gruss Rolf K.


  

Betrifft: AW: Sortierreihenfolge von: Erich G.
Geschrieben am: 10.08.2008 18:15:25

Hallo Rolf,
wenn du in eine Hilffspalte B die Formel wie im Beispiel schreibst und dann nach Spalte B und Spalte A sortierst,
sollte es klappen:

 AB
19712345FALSCH
20012347WAHR
30058987WAHR
40114578WAHR
50212741WAHR

Formeln der Tabelle
ZelleFormel
B1=LINKS(A1;1)<"5"
B2=LINKS(A2;1)<"5"

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort