Microsoft Excel

Herbers Excel/VBA-Archiv

Auftragspositionen >5 anzeigen

Betrifft: Auftragspositionen >5 anzeigen von: Einkäufer
Geschrieben am: 21.08.2008 13:53:24

Hallo,

ich habe folgendes Problem:

Aus einer Kundenliste mit Auftragspositionen möchte ich mir alle Kunden anzeigen lassen, die mehr als 5 Aufträge platziert haben.

Name Bezeichnung
Müller Auftrag 1
Müller Auftrag 2
Müller Auftrag 3
Müller Auftrag 4
Müller Auftrag 5
Müller Auftrag 6
Maier Auftrag 1
Maier Auftrag 2
….. ….


etc.

Kann mit jemand weiterhelfen?

Danke im Voraus.

Andreas

  

Betrifft: AW: Auftragspositionen >5 anzeigen von: Ramses
Geschrieben am: 21.08.2008 14:10:50

Hallo

Auf die Schnelle

Daten - Filter - SPezialfilter
NUR Kundenamenbereich markieren
An andere Stelle kopieren = Zelle markieren wo du die Liste haben willst
Option: Ohne Duplikate

Tabelle1
 ABCDEF
1KundeAuftrag  KundeAnzahl Aufträge
2maier1  maier4
3Huber1  Huber3
4Müller1  Müller2
5Meier1  Meier1
6Maier1  Geier2
7Huber1  Adler1
8Müller1    
9Geier1    
10Adler1    
11Huber1    
12Maier1    
13Maier1    
14Geier1    
15      
Formeln der Tabelle
F2 : =SUMMEWENN($A$2:$A$14;E2;$B$2:$B$14)
F3 : =SUMMEWENN($A$2:$A$14;E3;$B$2:$B$14)
F4 : =SUMMEWENN($A$2:$A$14;E4;$B$2:$B$14)
F5 : =SUMMEWENN($A$2:$A$14;E5;$B$2:$B$14)
F6 : =SUMMEWENN($A$2:$A$14;E6;$B$2:$B$14)
F7 : =SUMMEWENN($A$2:$A$14;E7;$B$2:$B$14)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Dann die Formel wie gezeigt einfügen.

Danach kannst du deine Ergebnisspalte mit der Formeln über den Autofilter mit "Top Ten" eingrenzen auf die besten 5

Gruss Rainer


  

Betrifft: AW: Auftragspositionen >5 anzeigen von: mpb
Geschrieben am: 21.08.2008 15:09:38

Hallo Andreas,

in Ergänzung zu Rainers Vorschlag: Wenn die Aufträge nicht mit einer Anzahl, sondern mit einer Bezeichnung angegeben sind und jeder Auftrag genau einmal vorkommt, musst Du in F2 statt mit SUMMEWENN mit ZÄHLENWENN arbeiten:

=ZÄHLENWENN($A$2:$A$14;"="&F2)

Gruß
Martin


 

Beiträge aus den Excel-Beispielen zum Thema "Auftragspositionen >5 anzeigen"