Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis und Finden

Betrifft: Sverweis und Finden von: Nico
Geschrieben am: 19.08.2008 14:10:13

Hallo Ihr,

mal wieder hoffe ich auf eure Hilfe.

Ich habe XLS vor mir mit 2 Tabellenblättern.

Tabellenblatt A enthält ca. 500 Familienunternehmen. Jedoch in der Art, dass der jeweilige Firmename irgendwo immer in der Spalte A enthalten ist. Zusätzlich in gleicher Zelle Standort oder andere Infos.

Tabellenblatt B enthält enthält in Spalte A ca. 300 Unternehmen. Hier allerdings ordentlich pur nur den Firmenamen.

Ich würde jetzt gern ein Formel haben, die es mir ermöglicht in Tabellenblatt A den Firmenamen Tabellenblatt B innerhalb der wüssten Information in den Zellen zu finden. Wird dieser in einer Zelle gefunden, dann soll irgendwas ausgeworfen werden (1 oder ja oder irgendwas).

Ich hoffe, ich habe mich verständlich ausgedrückt.

Bin euch jetzt schon allein fürs überlegen dankbar.

Liebe Grüße

Nico

  

Betrifft: sverweis() mit Platzhalter von: heikoS
Geschrieben am: 19.08.2008 14:47:13

Hallo Nico,

das geht z.B. so:

sverweis() mit Platzhalter

 ABCD
1Rohdaten Datenvorhanden?
2Straße Maier GmbH Ort Schultze1
3Ort Schröder oHG Name Maier1
4Name Schultze AG Meyer0
5Müller KG Name Ort   

Formeln der Tabelle
ZelleFormel
D2=--ISTTEXT(SVERWEIS("*"&C2&"*";$A$2:$A$5;1;))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Klappt´s?


Gruß Heiko


  

Betrifft: AW: Sverweis und Finden von: Daniel
Geschrieben am: 19.08.2008 14:52:11

Hi

so ganz verstanden habe ich es nicht, was du da willst, aber auch innerhalb der ZÄHLENWENN oder SVWERWEIS-Funktion kannst du beim Suchbegriff mit den Joker-Zeichen * (beliebig viele Zeichen) und ? (genau 1 Zeichen) arbeiten, dh. die Formel:
=ZählenWenn(A:A; "*AAA*)
hätte in dieser Auflistung:

xxxxxxx
xxxxxxx
xxxxxxx
xxAAAxx
xxxxxxx
xxxxxxx


einen Treffer.


vielleicht hilft dir das ja weiter.

wenn du den Suchbegriff aus über einen Zellbezug holst, dann kann man die Jokerzeichen so ergänzen:
=ZählenWenn(A:A;"*"&B1&"*")

Gruß, Daniel


  

Betrifft: AW: Sverweis und Finden von: Nico
Geschrieben am: 19.08.2008 14:59:34

Hallo Ihr 2,

vielen Dank für eure schnelle Hilfe! Beide Varianten haben funktioniert! Ist es eigentlich peinlich, wenn ich die Jokerfunktion nicht kannte?

Grüße


  

Betrifft: Bitte, danke für Deine Rückmeldung! mT von: heikoS
Geschrieben am: 19.08.2008 17:12:09

Hallo Nico,

nein, das ist nicht peinlich, sondern völlig normal. Wichtig ist, daß Du sie jetzt kennst.


Gruß Heiko


  

Betrifft: AW: Sverweis und Finden von: Rudi Maintaire
Geschrieben am: 19.08.2008 14:55:55

die Zeilennummer mit Matrixformel:

{=VERGLEICH(WAHR;ISTZAHL(FINDEN(A2;Tabelle1!$A$2:$A$10));)}

Gruß
Rudi


 

Beiträge aus den Excel-Beispielen zum Thema "Sverweis und Finden"