SVERWEIS mit 2 Suchkriterien

Bild

Betrifft: SVERWEIS mit 2 Suchkriterien
von: Anton
Geschrieben am: 13.04.2005 12:28:52
Hallo Leute,
ich habe 2 Tabellen und soll die Einträge der alten Liste auf die neue Liste übertragen.
Ich habe ein Schlüsselfeld angelegt, mit dem ich per SVERWEIS die Datensätze identifizieren kann.
Das Schlüsselfeld hat Spalte R
Nun zum Problem: wenn Schlüssel in Spalte R gefunden wird, suche (in der selben Zeile) ob in Spalte Q ein Wert steht. Wenn Ja, = x; Wenn Nein =-leer-

Wer von Euch kann mir hier weiterhelfen?
Mein Dank ist Euch gewiss.
Servus,
Anton

Bild

Betrifft: AW: SVERWEIS mit 2 Suchkriterien
von: Uduuh
Geschrieben am: 13.04.2005 12:38:08
Hallo,
siehe hier:
http://www.excelformeln.de/formeln.html?welcher=30
Gruß aus'm Pott
Udo

Bild

Betrifft: AW: SVERWEIS mit 2 Suchkriterien
von: Anton
Geschrieben am: 13.04.2005 12:50:52
Hallo Udo,
herzlichen Dank!
Eine bärenstarke Sammlung!!
-Da muß ich nachmittag noch etwas stöbern gehen.
Servus,
Anton
Bild

Betrifft: AW: SVERWEIS mit 2 Suchkriterien
von: UweN
Geschrieben am: 13.04.2005 12:45:11
Hallo Anton,
ungetestet:
=WENN(ISTFEHLER(SVERWEIS(B3;G:G;1;FALSCH));"Schlüssel nicht gefunden";WENN(H3="";"-leer-";"JA"))
Das macht noch etwas mehr: Damit wird die Meldung ausgegeben, wenn der Schlüssel nicht gefunden wurde.
Viele Grüße
Uwe
Bild

Betrifft: AW: SVERWEIS mit 2 Suchkriterien
von: Anton
Geschrieben am: 13.04.2005 12:53:52
Hallo Uwe,
auch Dir herzlichen Dank.
Werd's nachmittag gleich testen.
Servus,
Anton
Bild

Betrifft: AW: SVERWEIS mit 2 Suchkriterien
von: Anton
Geschrieben am: 13.04.2005 13:35:46
Hallo Uwe,
Deine Formel habe ich gerade getestet:
Das klappt nur wenn beide Listen gleich sind....
ist sie aber leider bei mir nicht.
Die alte hat 31' Zeilen und die neue hat 33' Zeilen. Außerdem fehlen ein paar Einträge in der neuen Liste.
Nochmals die Frage: wird nur die aktuelle Zeile durchsucht, wenn ich statt der "H3" ein SVERWEIS nach "x" (einzig möglicher Inhalt der Zellen in Spalte Q) in der Spalte Q einsetze?
Nochmals Dank für Deine Arbeit.
Servus,
Anton
Bild

Betrifft: AW: SVERWEIS mit 2 Suchkriterien
von: Anton
Geschrieben am: 13.04.2005 13:35:56
Hallo Uwe,
Deine Formel habe ich gerade getestet:
Das klappt nur wenn beide Listen gleich sind....
ist sie aber leider bei mir nicht.
Die alte hat 31' Zeilen und die neue hat 33' Zeilen. Außerdem fehlen ein paar Einträge in der neuen Liste.
Nochmals die Frage: wird nur die aktuelle Zeile durchsucht, wenn ich statt der "H3" ein SVERWEIS nach "x" (einzig möglicher Inhalt der Zellen in Spalte Q) in der Spalte Q einsetze?
Nochmals Dank für Deine Arbeit.
Servus,
Anton
Bild

Betrifft: AW: SVERWEIS mit 2 Suchkriterien
von: UweN
Geschrieben am: 13.04.2005 14:00:20
Hallo Anton,
Du hast recht, das kann so nicht funktionieren.
Wenn ich es richtig verstanden habe, mußt Du an der Stelle H3="";"-leer-";"JA"
einen weiteren SVERWEIS einbauen, der bei Vorhandensein des Schlüssels auch noch prüft, ob in Spalte H (oder bei Dir war es glaube ich Q?) ein x steht.
z.B. so:
=WENN(ISTFEHLER(SVERWEIS(B3;G:G;1;FALSCH));"Schlüssel nicht gefunden";WENN(SVERWEIS(B3;G:H;2;FALSCH)="";"-leer-";"JA"))

Viele Grüße
Uwe
Bild

Betrifft: AW: SVERWEIS mit 2 Suchkriterien
von: Anton
Geschrieben am: 13.04.2005 15:30:24
Hallo Uwe,
hab's gerade getestet: Geht wunderbar.
Was aber auch nicht von der Hand zu weisen ist:
=INDEX([Piping010205a.xls]Piping010205!$Q:$Q;VERGLEICH(R3;[Piping010205a.xls]Piping010205!$R:$R;0)).
INDEX kann auch links von SVERWEIS suchen.... und das ist hier das schlagende Argument.
Nochmal Dank Dir.
Servus,
Anton
 Bild

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS mit 2 Suchkriterien"