Suche mit 2 Parametern (keine Kreuztabelle)

Bild

Betrifft: Suche mit 2 Parametern (keine Kreuztabelle)
von: k
Geschrieben am: 18.06.2015 16:57:34

Hi, ich möchte in excel einen Wert ausgeben, der von 2 Parametern abhänging ist.
Ich finde nur lösungen mit Kreuztabellen, aber meine 2 Werte stehen in der selben Spalte.
V X Q
10 a ?
20 a formel?
30 b
40 b
50 c
60 c

q ist gesucht und abhänging von v und x



q a b c
1 10 20 30
2 20 30 40
3 30 40 50
4 40 50 60
5 50 60 70
6 60 70 80


rauskommen soll

v a q
10 a 1
20 a 2
30 b 2
40 b 3
50 c 3
60 c 4

also erst schauen welcher x parameter, dann v in der entschprechenden spalte suchen und q ausgeben.

Bild

Betrifft: AW: Suche mit 2 Parametern (keine Kreuztabelle)
von: k
Geschrieben am: 18.06.2015 17:11:58
hier noch die datei
https://www.herber.de/bbs/user/98295.xlsx
danke

Bild

Betrifft: mit WENNFEHLER(), INDEX() und AGGREGAT() ...
von: der neopa C
Geschrieben am: 18.06.2015 17:18:08
Hallo,
...in C2: =WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE(A$14:A$22)/(B$14:D$22=A2)/(B$13:D$13=B2);1));"") und nach unten kopieren.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: mit WENNFEHLER(), INDEX() und AGGREGAT() ...
von: k
Geschrieben am: 18.06.2015 17:29:29
Wahnsinn!
Perfekte Lösung und das so schnell.
Vielen Dank!

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Suche mit 2 Parametern (keine Kreuztabelle)"