Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Durchsuchen einer Liste und Ausgabe

Durchsuchen einer Liste und Ausgabe
20.10.2012 14:49:01
Emanuel
Hi Leute,
ich war schon ziemlich lange nicht mehr hier und meine Excel-Kenntnisse sind leider zwecks Vernachlässigung ein wenig eingerostet.
Folgendes Problem:
Ich habe eine Liste mit einer einzigen Spalte und vielen tausend Werten untereinander. In jeder Zeile stehen jeweils zwei Werte durch Komma getrennt, z.B.
A1 Hund, Katze
A2 Maus, Elefant
...
Ich möchte nun als Ergebnis einer Formel (mit der Suchfunktion habe ich es nicht hinbekommen auch nicht mit Sortieren), wenn es einen Eintrag mehr als einmal gibt einen Hinweis haben oder vielleicht sogar die jeweilige Zeile (nice to have). Sowohl als erstes Wort als auch als zweites Wort.
Wenn z.B. in A100 Hund, Spatz steht, dann soll irgendwas mich auf den doppelten Eintrag hinweisen aber auch bei Spatz, Hund etc.
Gruss,
Emanuel

11
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Durchsuchen einer Liste und Ausgabe
20.10.2012 15:39:14
Matze,Matthias
Hallo emanuell,
meinst du so? Ich verstehe nicht warum nur markieren ?
In spalte B ist die Anzahl wie oft .
 AB
1Hund,Katze2
2Katze,Hund2
3Pferd,Biber2
4Affe,Bär1
5Hund,Katze2
6Katze,Hund2
7Pferd,Biber2
8Affe,Löwe1
9Hund,Kater1

Formeln der Tabelle
ZelleFormel
B1=ZÄHLENWENN($A$1:$A$11;A1)
B2=ZÄHLENWENN($A$1:$A$11;A2)
B3=ZÄHLENWENN($A$1:$A$11;A3)
B4=ZÄHLENWENN($A$1:$A$11;A4)
B5=ZÄHLENWENN($A$1:$A$11;A5)
B6=ZÄHLENWENN($A$1:$A$11;A6)
B7=ZÄHLENWENN($A$1:$A$11;A7)
B8=ZÄHLENWENN($A$1:$A$11;A8)
B9=ZÄHLENWENN($A$1:$A$11;A9)

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A11. / Formel ist =ZÄHLENWENN($A$1:$A$11;A1)>1Abc
A21. / Formel ist =ZÄHLENWENN($A$1:$A$11;A1)>1Abc
A31. / Formel ist =ZÄHLENWENN($A$1:$A$11;A1)>1Abc
A41. / Formel ist =ZÄHLENWENN($A$1:$A$11;A1)>1Abc
A51. / Formel ist =ZÄHLENWENN($A$1:$A$11;A1)>1Abc
A61. / Formel ist =ZÄHLENWENN($A$1:$A$11;A1)>1Abc
A71. / Formel ist =ZÄHLENWENN($A$1:$A$11;A1)>1Abc
A81. / Formel ist =ZÄHLENWENN($A$1:$A$11;A1)>1Abc
A91. / Formel ist =ZÄHLENWENN($A$1:$A$11;A1)>1Abc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matze

Anzeige
AW: Durchsuchen einer Liste und Ausgabe
20.10.2012 15:52:13
Matthias
Hallo
Tabelle1

 ABCD
1Hund, Katze Elefant3  mal vorhansen
2Maus, Elefantim Text vorhanden  
3Katze, Maus   
4Elefant, Mausim Text vorhanden  
5Maus, Katze   
6Hund, Elefantim Text vorhanden  

Formeln der Tabelle
ZelleFormel
B1=WENN($C$1<>"";WENN(ISTZAHL(SUCHEN($C$1;A1)); "im Text vorhanden";""); "")
D1=ZÄHLENWENN(B1:B6;"im Text vorhanden")
B2=WENN($C$1<>"";WENN(ISTZAHL(SUCHEN($C$1;A2)); "im Text vorhanden";""); "")
B3=WENN($C$1<>"";WENN(ISTZAHL(SUCHEN($C$1;A3)); "im Text vorhanden";""); "")
B4=WENN($C$1<>"";WENN(ISTZAHL(SUCHEN($C$1;A4)); "im Text vorhanden";""); "")
B5=WENN($C$1<>"";WENN(ISTZAHL(SUCHEN($C$1;A5)); "im Text vorhanden";""); "")
B6=WENN($C$1<>"";WENN(ISTZAHL(SUCHEN($C$1;A6)); "im Text vorhanden";""); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Anzeige
AW: Durchsuchen einer Liste und Ausgabe
20.10.2012 16:46:51
Emanuel
Hi,
das erste war gut, hat aber noch nicht ganz gepasst da mir ein Ergebnis nicht angezeigt wurde, wo z.B. Hund, Spatz und Katze, Spatz in einer Zeile steht.
Es scheint so zu sein, als ob er mit der Reihenfolge wo in der Zeile die zu prüfenden Werte stehen noch nicht ganz klar kommt.
Merci,
Emanuel

Schau doch Matthias L. lösung an,...
20.10.2012 17:56:01
Matze,Matthias
...dort ist halt nur nicht Spalte A formatiert.
habe dies nochmal etwas abgeändert.
Zb.: Wenn "Hund" in C1 gesucht wird werden alle Zellen orange.
 ABCD
1BegriffeMeldungSucheAnzahl
2Hund,Katze,MausmehrfachHund5
3Hund,Mausmehrfach  
4Hundmehrfach  
5Hund,Katze,Bärmehrfach  
6Hund,Bär,Mausmehrfach  
7Tiger,Ente   
8Ente,Schwan   

Formeln der Tabelle
ZelleFormel
B2=WENN($C$2<>"";WENN(ISTZAHL(SUCHEN($C$2;A2)); "mehrfach";""); "")
D2=ZÄHLENWENN(B2:B7;"mehrfach")
B3=WENN($C$2<>"";WENN(ISTZAHL(SUCHEN($C$2;A3)); "mehrfach";""); "")
B4=WENN($C$2<>"";WENN(ISTZAHL(SUCHEN($C$2;A4)); "mehrfach";""); "")
B5=WENN($C$2<>"";WENN(ISTZAHL(SUCHEN($C$2;A5)); "mehrfach";""); "")
B6=WENN($C$2<>"";WENN(ISTZAHL(SUCHEN($C$2;A6)); "mehrfach";""); "")
B7=WENN($C$2<>"";WENN(ISTZAHL(SUCHEN($C$2;A7)); "mehrfach";""); "")
B8=WENN($C$2<>"";WENN(ISTZAHL(SUCHEN($C$2;A8)); "mehrfach";""); "")

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A21. / Formel ist =B2="mehrfach"Abc
A31. / Formel ist =B3="mehrfach"Abc
A41. / Formel ist =B3="mehrfach"Abc
A51. / Formel ist =B3="mehrfach"Abc
A61. / Formel ist =B3="mehrfach"Abc
A71. / Formel ist =B3="mehrfach"Abc
A81. / Formel ist =B3="mehrfach"Abc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matze

Anzeige
AW: Schau doch Matthias L. lösung an,...
21.10.2012 16:54:33
Emanuel
Hi,
das Problem ist, ich habe keinen exakten Suchbegriff. Bei mehr als 1000 verschiedenen Zeileneinträgen könnte in jeder Zeile ein Wert stehen, der weiter unten irgendwo wieder auftaucht. Somit entfällt bei mir die Möglichkeit der Suche nach einem bestimmt Begriff wie in Spalte C vorgegeben.
Im Grunde genommen, ist jeder Wert innerhalb der Liste auch gleichzeitig ein Suchbegriff. Als Ergebnis brauche ich nur die Info, ob die Liste mehrfache Einträge enthält und als nice to have wo diese zu finden sind (aber nicht nötig). Formatiert oder nicht spielt ebenfalls keine Rolle.
So ungefähr sollte es aussehen:
A1 B1
X1234,Y1234 Treffer! Oder ein "x" etc.
.
.
.
A234 B234
Y1234,U4567 Treffer! Oder ein "x" etc.
Gruss,
Emanuel

Anzeige
Rückfrage: ....
21.10.2012 18:16:18
Matze,Matthias
Hallo,
wie verstehe ich das denn? Du weist nicht wonach du suchst?
Mach bitte eine Musterdatei
Istzustand und Ergebnis
Matze
Rauf mir grad die Haare...?

AW: Durchsuchen einer Liste und Ausgabe
22.10.2012 14:49:14
Emanuel
Hi,
hier der Dateilink:
https://www.herber.de/bbs/user/82253.txt
In der Datei befindet sich nun ein doppelter Wert (B008FZMNFM). Die Originaldatei hat ca. 1000 Zeilen und könnte mehrere doppelte Werte enthalten, wobei jedes Paar den gleichen Aufbau hat.
Bitte die Datei vertraulich behandeln.

AW: Durchsuchen einer Liste und Ausgabe
22.10.2012 16:39:35
Emanuel
Noch offen

AW: Durchsuchen einer Liste und Ausgabe
22.10.2012 18:12:02
Matze,Matthias
Hallo Emanuel,
dein Link: nimm bitte beim versenden den unteren im Rahmen dargestellten Link.
Es steht auch dort so beschrieben,....!
https://www.herber.de/bbs/user/82259.xlsx
hoffentlich reicht dir das, ansonsten weis ich echt nicht was du willst.
Matze

Anzeige
AW: abgeänderte Überschriften,..
23.10.2012 09:54:42
Emanuel
Wow!!
Danke Dir! So klappts.
Emanuel

305 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige