ZÄHLENWENN mit >0 in mehreren Bereichen

Bild

Betrifft: ZÄHLENWENN mit >0 in mehreren Bereichen
von: AW
Geschrieben am: 19.04.2005 15:22:09
Hallo!
Bin absoluter Neuling in Sachen Excel.
Wie bekomme ich die Summe der Zellen in denen Zahlen größer Null stehen, wenn ich mehrere, nicht zusammenhängende Bereiche auswerten will?
Danke,
AW

Bild

Betrifft: AW: ZÄHLENWENN mit >0 in mehreren Bereichen
von: Andi
Geschrieben am: 19.04.2005 15:29:00
Hi,
meinst Du nun die Anzahl (ZÄHLENWENN) oder die Summe der Zell-Inhalte (SUMMEWENN)?
Wenn's nicht zu viele Bereiche sind, würde ich einfach mehrere SUMMEWENN-Funktionen addieren:
=SUMMEWENN(A1:A4;">0")+SUMMEWENN(C1:C4;">0")+...
Geht mit ZÄHLENWENN natürlich analog.
Schönen Gruß,
Andi
Bild

Betrifft: AW: ZÄHLENWENN mit >0 in mehreren Bereichen
von: Nils Götzel
Geschrieben am: 19.04.2005 15:33:09
Für Summen brauchst die SUMMEWENN Formel und dann
einfach ein paar dieser Formeln zusammenhängen mit den entsprechenden Bereichen
BSP:
=SUMMEWENN(Bereich1;">0")+SUMMEWENN(Bereich2;">0")+SUMMEWENN(Bereich3;">0")
Nicht schön aber es klappt...
Gruss
Bild

Betrifft: AW: ZÄHLENWENN mit >0 in mehreren Bereichen
von: AW
Geschrieben am: 19.04.2005 15:51:23
Mensch, seid Ihr schnell :-)
Also ich möchte nicht die Summe der Werte in den Zellen, sondern die Anzahl der Zellen in den Bereichen, in denen Werte über 0 stehen.
Der Vorschlag von Nils hört sich gut an, kann ich das denn auch für ZÄHLENWENN anwenden?
Erstmal vielen Dank für die schnellen Antworten!!!!!
Bild

Betrifft: AW: ZÄHLENWENN mit >0 in mehreren Bereichen
von: Andi
Geschrieben am: 19.04.2005 15:55:18
Der Vorschlag von Nils hört sich zunächst mal genauso an wie meiner, und da stand ja schon drin, dass das für ZÄHLENWENN genauso geht.
Am elegantesten ist aber (wie immer :-)) die Lösung von Boris...
Schönen Gruß,
Andi
P.S.: Is nicht bös gemeint, sondern nur als Tip:
wenn Du, wie hier, nicht weisst, ob etwas bestimmtes funktioniert, dann probier's doch einfach mal aus; das geht im allgemeinen schneller, als hier zu posten und auf ne Antwort zu warten.
Bild

Betrifft: AW: ZÄHLENWENN mit >0 in mehreren Bereichen
von: Boris
Geschrieben am: 19.04.2005 15:46:17
Hi,
die Summe mit:
=SUMME(SUMMEWENN(INDIREKT({"A1:A5"."B10"."E20:I100"});">0"))
Für die Anzahl einfach SUMMEWENN durch ZÄHLENWENN ersetzen.
Grüße Boris
Bild

Betrifft: AW: ZÄHLENWENN mit >0 in mehreren Bereichen
von: AW
Geschrieben am: 19.04.2005 16:03:57
Hey Boris, habs getestet: SUPER, Danke!!
Vielen Dank auch an alle anderen, so schnelle Antworten habe ich noch in keinem Forum bekommen.
Vielleicht weiß ja auch jemand, wie man einzelne Zellen oder Bereiche schützen kann, damit mir hier keiner die Formeln überschreibt?
AW
Bild

Betrifft: AW: ZÄHLENWENN mit >0 in mehreren Bereichen
von: Mathias
Geschrieben am: 19.04.2005 16:07:42
Hallo AW,
so wärs auch gegangen
=SUMMENPRODUKT(SUMMEWENN(A1:A7;">0";A1:A7))+(SUMMEWENN(B1:B7;">0";B1:B7))+(SUMMEWENN(C1:C7;">0";C1:C7))
Gruss
Mathias
Bild

Betrifft: AW: ZÄHLENWENN mit >0 in mehreren Bereichen
von: Mathias
Geschrieben am: 19.04.2005 16:11:57
Sorry ich das war gesamtergebnis, hier für die Zellen
=SUMMENPRODUKT(ZÄHLENWENN(A1:A7;">0"))+(ZÄHLENWENN(B1:B7;">0"))+(ZÄHLENWENN(C1:C7;">0"))
Gruss Mathias
Bild

Betrifft: schutz
von: th.heinrich
Geschrieben am: 19.04.2005 17:44:11
hallo AW, vornamen erwuenscht,
Extras-Schutz-Blatt schützen vorher mit Format-Zellen-Schutz die zellen entsperren in denen eingaben gemacht werden sollen.
gruss thomas
 Bild

Beiträge aus den Excel-Beispielen zum Thema "ZÄHLENWENN mit >0 in mehreren Bereichen"