Microsoft Excel

Herbers Excel/VBA-Archiv

zählenwenn über mehrere Spalten | Herbers Excel-Forum


Betrifft: zählenwenn über mehrere Spalten von: Olaf Oertelt
Geschrieben am: 17.12.2009 01:29:40

Hallo,

ich möchte gern mit zählenwenn nach der Zahl 12 in mehreren Spalten suchen.
Die Spaltenbereiche wären: F3:F33;N3:N33;V3:V33;AD3:AD32;AL3:AL33;AT3:AT32;BB3:BB33;BJ3:BJ33;BR3:BR32;BZ3:BZ33;CH3:CH32;CP3:CP33
mit der Standartformel komme ich hier nicht weiter.
Wie muss die Formel lauten damit ich die Bereiche abfragen kann?

Danke

  

Betrifft: AW: zählenwenn über mehrere Spalten von: fcs
Geschrieben am: 17.12.2009 07:02:48

Hallo Olaf,

ZÄHLENWENN kann nur zusamenhängende Zellbereiche auswerten. Du muss also ggf. jeden Bereich separat auswerten und addieren.

=ZÄHLENWENN(F3:F33;12)+ZÄHLENWENN(N3:N33);12)+..... 
Da du die Inhalte aus Spalten in regelmäßigen Abstanden von 8 Spalten zählen willst funktioniert auch die folgende Formel:
=SUMMENPRODUKT((REST(SPALTE($F$3:$CP$33)+8 -SPALTE($F$3);8)=0)*($F$3:$CP$33=12))
Gruß
Franz


  

Betrifft: AW: zählenwenn über mehrere Spalten von: Olaf Oertelt
Geschrieben am: 19.12.2009 16:21:33

Danke, beide Formeln funktionieren wie gewünscht.

mfG
Olaf


Beiträge aus den Excel-Beispielen zum Thema "zählenwenn über mehrere Spalten"