Microsoft Excel

Herbers Excel/VBA-Archiv

Summe nach Monaten bilden | Herbers Excel-Forum


Betrifft: Summe nach Monaten bilden von: edie
Geschrieben am: 16.12.2009 21:57:27

Hallo zusammen,

in Spalte C soll die Summe der Werte aus der Spalte B nach Monaten gebildet werden.
D.h. die Werte sollen aufsummiert werden und in Spalte C geschieben werden.

Die Datumsspalte A kann dabei auch mitten im Monat beginnen und kann unterschiedliche
Anzahl an Monaten beinhalten.

Hat jemand eine Matrix-Formel und kann helfen?

Vielen Dank im Voraus.

Grüße

  

Betrifft: AW: Summe nach Monaten bilden von: Christian
Geschrieben am: 16.12.2009 22:36:12

Hallo Edie,

als Ansatz
={SUMME(WENN(TEXT(A1:A100;"M")*1=12;B1:B100))}

Matrixformel

MfG Christian


  

Betrifft: AW: Summe nach Monaten bilden von: edie
Geschrieben am: 16.12.2009 23:09:08

Hallo Christian,

in der Spalte A sind nicht einzelne Monate z. B. Januar, Februar u.s.w., sonderen
die Monate mit Datum, d.h. z.B. 01.01.09, 02.01.09, 03.01.09 u.s.w. Dabei soll die
Summe der Werte in Spalte B aufsummiert werden, d. h. die Summe für Januar, Februar... .

Wichtig ist, dass die Monate nicht immer voll sind und könnem mitten im Monat beginnen.


Die Ergebnisse sollen in Spalte C stehen.

Vielen Dank im Voraus.

Grüße


  

Betrifft: AW: Summe nach Monaten bilden von: edie
Geschrieben am: 16.12.2009 23:14:17

Hallo zusammen,

als ergänzung, es kann auch, wenn es geht, eine VBA-Lösung sein.

Noch einmal vielen Dank im Voraus für die Hilfe.

Grüße


  

Betrifft: AW: Summe nach Monaten bilden von: Beate Schmitz
Geschrieben am: 16.12.2009 23:20:23

Hallo Eddie,

 ABCD
1DatumBetragMonatssummeMonat
229.07.200942,68268,92Jan
317.07.200950,00359,09Feb
405.11.200934,00489,08Mrz
517.02.200918,04299,21Apr
627.11.200914,56507,74Mai
719.01.200960,30613,63Jun
831.03.20098,55509,82Jul
914.02.200917,19578,87Aug
1004.01.200959,89326,75Sep
1128.10.200959,35301,50Okt
1230.06.200938,99626,14Nov
1325.04.200981,0570,35Dez
1425.01.20091,00  
1502.10.200957,10  
1609.05.20093,13  

Formeln der Tabelle
ZelleFormel
C2=SUMMENPRODUKT((MONAT(A$2:A$100)=ZEILE(A1))*B$2:B$100)


Die Formel aus C2 kannst du runterkopieren.

Gruß,
Beate


  

Betrifft: AW: Summe nach Monaten bilden von: Christian
Geschrieben am: 16.12.2009 23:23:32

Hallo,

probier mal={SUMME(WENN(MONAT($A$1:$A$1000)=ZEILE();$B$1:$B$1000))}

von C1 bis C12; ab C1 also für Januar usw.

Matrixformel ohne {} eingeben, Abschluss mit Strg+Shift+Enter

MfG Christian


  

Betrifft: AW: Summe nach Monaten bilden von: edie
Geschrieben am: 16.12.2009 23:37:38

Hallo Christian,
Hallo Beate Schmitz,

prima, es funktioniert, herzlichen Dank und einen schönen Abend noch.

Grüße


Beiträge aus den Excel-Beispielen zum Thema "Summe nach Monaten bilden "