Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Anzahl und Summenberechnung pro Monat

Anzahl und Summenberechnung pro Monat
07.02.2019 17:41:18
Marco
Hallo Forum Mitglieder,
ich habe schon sehr viel hier im Forum gelesen, um eine Lösung für meine Tabelle zu erreichen. Ich habe es mit SUMMENPRODUKT und SUMMEWENN schon ausprobiert, aber ich komme nicht zum Ziel.
Beschreibung:
Ich brauche in der unten aufgeführten Tabelle jeweils die Stückzahlen bzw. die Summe unter der Berücksichtigung von Produkt (Spalte J) und Betrag (Spalte K) für jeweils der Monate.
Die Tabelle wächst im Laufe des Jahres natürlich. (ca 10000 Datensätze)
https://www.herber.de/bbs/user/127488.xlsx
Für jeden Vorschlag bzw. Lösung bin ich sehr dankbar.
Gruß Marco

11
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: formelmäßig möglich, jedoch ...
07.02.2019 18:18:57
neopa
Hallo Marco,
... viel zu aufwendig im Vergleich zu einer Pivotauswertung. Deine Datenstruktur ist bestens geeignet für eine solche. Und es bedarf dazu nur weniger Mausklicks um diese aufzustellen.
Gruß Werner
.. , - ...
AW: formelmäßig möglich, jedoch ...
07.02.2019 19:08:52
Marco
Hallo Werner,
Pivot Tabelle einfügen hab ich gefunden, aber definiere ich das ganze damit ich jeweils die Anzahl bzw. die Summen bekomme.
Gruß Marco
AW: Ergebnis einer Pivotauswertung ...
08.02.2019 17:19:48
neopa
Hallo Marco,
... würde für Deine eingestellte Beispieldaten z.B. so aussehen:
Arbeitsblatt mit dem Namen 'Tabelle1'
 MNOPQ
1Art(Alle)   
2     
3 Auswertung   
4 2019   
5 Jan Feb 
6ProduktStückBetragStückBetrag
7E int13,60 €  
8E int, RSch121,65 €  
9E nat831,05 €26,40 €
10E nat, RSch211,45 €  
11EE nat  39,45 €
12Eint  13,40 €
13Enat  13,20 €
14     
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Entstanden durch wenige Mausklicks und ein paar nachträglichen textl. Anpassungen.
In dieser Tabelle findest Du Filtermöglichkeiten, mit der Du dann durch wieder nur ein bzw. wenige Mausklicks sofort auch das Jahresergebnis sehen kannst und(oder dies auch für für die verschiedenen "Art" einzeln und/oder auch nur bestimmte Produkte; bestimmte Monate ... etc.
Gruß Werner
.. , - ...
Anzeige
AW: Ergebnis einer Pivotauswertung ...
08.02.2019 17:54:24
Marco
Hallo Werner,
vielen Dank. Ich wird es mal versuchen.
Gruß Marco
AW: hierzu ...
09.02.2019 15:09:47
neopa
Hallo Marco,
... gib mal in google z.B.: "thehos pivot" ein und schau Dir mal die Filme von ‎Andreas Thehos zur Pivotauswertung an.
Gruß Werner
.. , - ...
AW: Anzahl und Summenberechnung pro Monat
07.02.2019 18:28:00
onur
Wenn du meinst, da wäre ein Fehler - es liegt daran, dass du unten "Eint" stehen hast statt "E int", einfach ändern.
AW: Anzahl und Summenberechnung pro Monat
07.02.2019 18:56:29
Marco
Hallo onur,
danke für die Formel. Läuft für jeden Monat. Eines ist mir noch unklar. Was bewirkten die Formelteile
;">="$B$25; und;" Formel in Zelle B27 =ZÄHLENWENNS($B$2:$B$20;">="&B$25;$B$2:$B$20;" Formel in Zelle C27 =SUMMEWENNS($K$2:$K$20;$B$2:$B$20;">="&B$25;$B$2:$B$20;" Gruß Marco
Anzeige
AW: Anzahl und Summenberechnung pro Monat
07.02.2019 19:00:10
onur
>=Monat oben im Monatsfeld und
AW: Anzahl und Summenberechnung pro Monat
07.02.2019 19:05:50
Marco
ich hab mal irgendwo ne Formel (da gings auch um Monatszahlen) gesehen, da wurde der Monat in der Formel mit ((Monat)=1 oder so ähnlich definiert.
1 für Januar usw.
AW: Anzahl und Summenberechnung pro Monat
07.02.2019 19:12:19
onur
Hätte man auch so machen können, wenn bei dir als Monat eine Zahl von 1 bis 12 gestanden hätte.
Dann hätte man statt ">=Monat und

332 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige