Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
536to540
536to540
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

automatisch Monat und Jahr generieren bei Zahl

automatisch Monat und Jahr generieren bei Zahl
29.12.2004 09:58:05
Joh@nn
Hallo zusammen.
Ich will dass meine Tabelle automatisch den Monat und das Jahr weis.Nicht das Tagesdatum.
Sodass ich nur die Zahl 1 für den 1. Januar 2005 eingebe.
2 für den 2. Januar 2005 usw.
Die Zellen sind auf Datum formatiert.. Excel gibt aber automatisch das Jahr 1900 aus
Danke und guten Rutsch
Joh@nn

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: automatisch Monat und Jahr generieren bei Zahl
29.12.2004 10:02:52
Hajo_Zi
Hallo Joh@nn,
das ist doch klar. Das Datum ist in Excel auch nur ein numerischer Wert. Der erste Tag in Excel ist der 1.1.1900.
Dein Problem kann nur mit VBA gelöst werden oder Du benutzt eine Hilfspalte.
Tabelle2
 AB
1101.01.2004
2303.01.2004
312302.05.2004
Formeln der Tabelle
B1 : =WENN(A1="";"";A1+"31.12.03")
B2 : =WENN(A2="";"";A2+"31.12.03")
B3 : =WENN(A3="";"";A3+"31.12.03")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.


Anzeige
automatisch Monat und Jahr generieren bei Zahl
Beate
Hallo Jah@nn,
mit dieser Lösung wird immer das aktuelle Jahr und der aktuelle Monat angenommen:
 
 AB
1505.12.2004
2808.12.2004
31212.12.2004
42929.12.2004
53131.12.2004
Formeln der Tabelle
B1 : =(A1&"."&MONAT(JETZT())&"."&JAHR(JETZT()))*1
B2 : =(A2&"."&MONAT(JETZT())&"."&JAHR(JETZT()))*1
B3 : =(A3&"."&MONAT(JETZT())&"."&JAHR(JETZT()))*1
B4 : =(A4&"."&MONAT(JETZT())&"."&JAHR(JETZT()))*1
B5 : =(A5&"."&MONAT(JETZT())&"."&JAHR(JETZT()))*1
 

Gruß,
Beate
Anzeige
Das ist mit der Funktion DATUM aber kürzer ;-)
Boris
Hi Beate,
=DATUM(JAHR(HEUTE());MONAT(HEUTE());A1)
Und nochmals einiges kürzer:
=HEUTE()-TAG(HEUTE())+A1
Grüße Boris
AW: Das ist mit der Funktion DATUM aber kürzer ;-)
29.12.2004 11:51:56
Hajo_Zi
Hallo
mir scheint diese Lösung hat aber den Nachteil das sich im nächsten Monat alee Datumswerte ändern.
Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.


richtig.Hajo-Lösung ist gut für mich. Danke Euch
29.12.2004 12:10:40
Joh@nn
.
@ Boris @ Hajo
Beate
Hallo zusammen,
danke Boris für die Ergänzung. Aber Hajo hat ja Recht, im nächsten Monat springen unsere Daten um...
An deiner Lösung, Hajo, fand ich nachteilig, dass praktisch keiner auswendig weiß, dass z.B. der 2.5. der 123 Tag im Jahr ist.
Ich denke, hier kann es nur eine Makrolösung geben oder man baut sich einen Pop-Up-Kalender ein.
Gruß,
Beate
Anzeige
AW: Datumseingabe,
29.12.2004 12:19:45
Hajo_Zi
Hallo Beate,
um dieses Problem habe ich mir keinen kopf gemach. Der Vorschlag kam ja von Joh@nn das er nur eine lfd. Nr. eingeben wollte. Wie er nun zu 123 für den 2.5. kommt ist jetzt sein Problem.
Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.


48 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige