Microsoft Excel

Herbers Excel/VBA-Archiv

Zeile einfügen ohne den Bezug zu verändern

Betrifft: Zeile einfügen ohne den Bezug zu verändern von: Manu
Geschrieben am: 21.08.2014 13:03:05

Hallo zusammen,

habe folgendes Problemchen mit Excel.
- 2 Arbeitsmappen
- Mappe1, Tabelle1 ist der Master (Mastero-Tabelle.xlsx)
- Mappe2, Tabelle1 soll der slave sein (Tabelle Content.xlsx)

Tabelle2 ist eine Kopie von Tabelle1, sieht also exakt so aus wie Tabelle1!
Ich habe also alles miteinander verknüpft.

Wenn ich nun in Mappe1, Tabelle1 eine Zeile einfüge dann rutschen in Mappe2, Tabelle1 die Werte nach unten aber die Formatierung bleibt erhalten.

So sieht die Formel in Mappe2, Tabelle1 momentan aus:
='[Mastero-Tabelle.xlsx]Tabelle1'!$B$11

So habe ich es versucht aber es funzt nicht:
=WENN(INDIREKT('[Mastero-Tabelle.xlsx]Tabelle1'!A"&ZEILE())="";"";)INDIREKT("Tabelle1!A"&ZEILE()))

Ich komm einfach nicht weiter und hoffe auf euch Jungs und Mädels..

Danke im Voraus!

Emanuele

  

Betrifft: ...Und was willst du erreichen? Gruß owT von: Luc:-?
Geschrieben am: 21.08.2014 13:25:10

:-?


  

Betrifft: AW: ...Und was willst du erreichen? Gruß owT von: Manu
Geschrieben am: 21.08.2014 14:30:44

Natürlich!
Wenn ich in Mappe1, Tabelle1 eine Zeile einfüge dann soll es in Mappe2, Tabelle1 genauso aussehen. Also immer wie im Master


  

Betrifft: AW: ...Und was willst du erreichen? Gruß owT von: Manu
Geschrieben am: 21.08.2014 14:59:30

Natürlich!
Wenn ich in Mappe1, Tabelle1 eine Zeile einfüge dann soll es in Mappe2, Tabelle1 genauso aussehen. Also immer wie im Master


  

Betrifft: AW: Zeile einfügen ohne den Bezug zu verändern von: Hajo_Zi
Geschrieben am: 21.08.2014 14:55:47

Hallo Emanuele,

Indirekt geht nur bei offener Datei.
Ich hätte vermutet
=WENN(INDIREKT("'[Mastero-Tabelle.xlsx]Tabelle1'!A"&ZEILE())="";""; INDIREKT("'[Mastero-Tabelle.xlsx]Tabelle1'!A"&ZEILE()))

GrußformelHomepage


  

Betrifft: AW: Zeile einfügen ohne den Bezug zu verändern von: Manu
Geschrieben am: 21.08.2014 15:12:21

Hallo Hajo,

ja es scheint zu funtionieren!!
Wie kann ich das mit der offenen Datei umgehen?

Danke


  

Betrifft: AW: Zeile einfügen ohne den Bezug zu verändern von: Daniel
Geschrieben am: 21.08.2014 15:28:11

Hi

mit INDEX:

=WENN(INDEX('[Mastero-Tabelle.xlsx]Tabelle1'!A:A";ZEILE())="";""; INDEX('[Mastero-Tabelle.xlsx]Tabelle1'!A:A;ZEILE()))  

INDIREKT sollte man nur verwenden, wenn man den Blattnamen des Zellbezugs selbst aus Formeln oder Zellwerten zusammensetzen muss.
Solange nur die ZeilenNr oder SpaltenNr berechnet wird, ist Index besser und funktioniert auch mit geschlossenen Dateien.
Gruß Daniel


  

Betrifft: AW: Zeile einfügen ohne den Bezug zu verändern von: Manu
Geschrieben am: 21.08.2014 16:01:44

Hallo Daniel,

es erscheint nur - Die eingegebene Formel enthält einen fehler.
Wenn ich Anführungszeichen vor Mastero und hinter das letzte A setze erscheint nur "#WERT


  

Betrifft: AW: Zeile einfügen ohne den Bezug zu verändern von: Daniel
Geschrieben am: 21.08.2014 16:17:11

du solltest das Anführungszeichen nach A:A beim ersten Index entfernen.

oder schau dir die Index-Funktion an, versuche sie zu verstehen und schreibe sie selber.
dann vermeidest du meine Tipfehler ;-)

gruß Daniel


  

Betrifft: AW: Zeile einfügen ohne den Bezug zu verändern von: Manu
Geschrieben am: 21.08.2014 16:53:13


Hallo Leute,

leider ist mein Problem, ob mit INDIREKT oderr INDEX noch immer nicht gelöst.
Zur besseren Veranschaulichung habe ich ein screenshot beigefügt.



Zur Erklärung: Wenn ich in Mappe1, Tabelle1 zwischen Zeile 7 und 8 eine neue Zeile einfüge passiert folgendes (siehe screenhot) in Mappe2, Tabelle1.

Danke im Voraus Leute. Aber Ihr seit meine Rettung!

LG Manu


  

Betrifft: AW: Zeile einfügen ohne den Bezug zu verändern von: Daniel
Geschrieben am: 21.08.2014 17:02:45

Hi

das Problem würde ich so lösen:
lasse die Überschriften mit einem bestimmten Zeichen (z.B. "_") beginnen oder enden, wodurch man sie von den normalen Texten unterscheiden kann ("Songs der 80_")
die unterschiedliche Formatierung machst du dann mit der Bedingten Formatierung (Formel der Regel: Rechts(A1;1)="_")

Gruß Daniel


  

Betrifft: AW: Zeile einfügen ohne den Bezug zu verändern von: rene
Geschrieben am: 22.08.2014 01:22:33

danke


  

Betrifft: AW: Zeile einfügen ohne den Bezug zu verändern von: Manu
Geschrieben am: 22.08.2014 11:06:08

Danke Daniel


 

Beiträge aus den Excel-Beispielen zum Thema "Zeile einfügen ohne den Bezug zu verändern"