Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
608to612
608to612
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Zellenformat mit bedingter Formel kopieren

Zellenformat mit bedingter Formel kopieren
09.05.2005 15:55:24
mykey2002
Moinsens zusammen,
wie kann ich die Textfarbe einer Zelle in einer Formel kopieren ?
=WENN(A9=1;A4;B4)
A4 --&gt roter Text "Achtung"
B4 --&gt grüner Text "OK"
Danke im Vorraus

9
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zellenformat mit bedingter Formel kopieren
09.05.2005 15:58:32
Hajo_Zi
Hallo myky2002
mit Formeln können keine Formate übergeben werden.
Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem Windows 2000 SP4 und Excel Version 2000 SP3.



"Wer Rechtschreibfehler findet, darf sie behalten!"
Dies gilt auch für Bert.
Anzeige
AW: Zellenformat mit bedingter Formel kopieren
09.05.2005 16:00:27
mykey2002
Hmm okay ...
muss ich das dann über ein Makro oder Modul formatieren ?
Danke im Vorraus
AW: Zellenformat mit bedingter Formel kopieren
09.05.2005 16:03:06
Hajo_Zi
Hallo mykey2002
Über ein Makro.
Gruß Hajo
Das Forum lebt auch von den Rückmeldungen.

"Wer Rechtschreibfehler findet, darf sie behalten!"
Dies gilt auch für Bert.
Anzeige
AW: Zellenformat mit bedingter Formel kopieren
09.05.2005 16:18:27
mykey2002
Kannst Du mir evtl. sagen wie das Makro erstelle ? Wo finde ich eine Anleitung für dieses Makro ?
Vielen Dank !
AW: Zellenformat mit bedingter Formel kopieren
09.05.2005 16:25:13
Hajo_Zi
Hallo mykey2002,

Sub Werte_Format()
Range("C10").Copy
Range("A1").PasteSpecial Paste:=xlFormats      ' Formate
Application.CutCopyMode = False
End Sub

Gruß Hajo
Das Forum lebt auch von den Rückmeldungen.

"Wer Rechtschreibfehler findet, darf sie behalten!"
Dies gilt auch für Bert.
Anzeige
AW: Zellenformat mit bedingter Formel kopieren
09.05.2005 16:27:11
Luc:-?
Hallo mykey,
das, was du in diesem einfachen Bsp erreichen willst, kannst du mit bedingter Formatierung realisieren. Wenn hierzu Fragen, F1 drücken oder ? anklicken. Wenn's nicht reicht: im Forumsarchiv existiert kilometerweise Material zum Thema Bedingte Formatierung einschl. VBA-Codes und Verweisen auf Fremdtools. Wenn es ein Format sein soll, dass die bedingte Formatierung nicht unterstützt, musst du wirklich in die VBA-Kiste greifen. Da gibt's dann auch 'nen Trick, mit dem eine benutzerdefinierte Funktion (in einer Formel) eine Formatübertragung anstoßen nicht vornehmen kann.
Gruß Luc :-?
Anzeige
AW: Zellenformat mit bedingter Formel kopieren
09.05.2005 16:37:15
mykey2002
Klappt das denn wenn ich diese Formatierung benutze ?

Private Sub Worksheet_Change(ByVal Target As Range)
With Range("B9")
If .Value = "OK" Then
.Interior.ColorIndex = 4
.Font.ColorIndex = 4
ElseIf .Value = "Achtung !!" Then
.Interior.ColorIndex = 3
.Font.ColorIndex = 3
End If
End With
End Sub

In Zelle B9 sitzt die Formel =WENN(A9=1;A4;B4) . . . . .
MfG
max
AW: Zellenformat mit bedingter Formel kopieren
09.05.2005 19:49:45
Hajo_Zi
Hallo max,
einfach Testen.
Gruß Hajo
Das Forum lebt auch von den Rückmeldungen.

"Wer Rechtschreibfehler findet, darf sie behalten!"
Dies gilt auch für Bert.
Anzeige
AW: Zellenformat mit bedingter Formel kopieren
12.05.2005 14:50:35
mykey2002
danke shcön hat soweit geklappt !
:)

420 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige