Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
712to716
712to716
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Zellen mit Formel ausfülen

Zellen mit Formel ausfülen
06.01.2006 13:32:30
Erich
Hallo....
Habe wieder mal ein Problem.
Ich muß in der Spalte J immer das aktuelle Alter haben.
Da sich die Anzahl der Zeilen sich immer wieder ändert, wollte ich
mit folgenden Code die Formel eintragen.
Public

Sub Alter()
Dim i, x As Integer
Dim dblRange As Double
Range("c1:c" & Cells(Rows.Count, 3).End(xlUp).Row).Select
dblRange = Selection.Rows.Count
x = dblRange
For i = 2 To x
Cells(i, 10).Formula = "=WENN(NICHT(ISTFEHLER(WENN(DATUM(JAHR(HEUTE());MONAT(I2);TAG(I2))>HEUTE();JAHR(HEUTE())-JAHR(I2)-1;JAHR(HEUTE())-JAHR(I2))));WENN(DATUM(JAHR(HEUTE());MONAT(I2);TAG(I2))>HEUTE();JAHR(HEUTE())-JAHR(I2)-1;JAHR(HEUTE())-JAHR(I2));"")=WENN(NICHT(ISTFEHLER(WENN(DATUM(JAHR(HEUTE());MONAT(I2);TAG(I2))>HEUTE();JAHR(HEUTE())-JAHR(I2)-1;JAHR(HEUTE())-JAHR(I2))));WENN(DATUM(JAHR(HEUTE());MONAT(I2);TAG(I2))>HEUTE();JAHR(HEUTE())-JAHR(I2)-1;JAHR(HEUTE())-JAHR(I2));"")=WENN(NICHT(ISTFEHLER(WENN(DATUM(JAHR(HEUTE());MONAT(I2);TAG(I2))>HEUTE();JAHR(HEUTE())-JAHR(I2)-1;JAHR(HEUTE())-JAHR(I2))));WENN(DATUM(JAHR(HEUTE());MONAT(I2);TAG(I2))>HEUTE();JAHR(HEUTE())-JAHR(I2)-1;JAHR(HEUTE())-JAHR(I2));"")"
Next i
Tabelle1.Range("A1").Select
End Sub

Nur bekomme ich die Fehlermeldung "Objekt oder Anwendungsfehler"
was mache ich verkehrt.
Für einen Tipp wäre ich Dankbar.
Gruss Erich

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zellen mit Formel ausfülen
06.01.2006 13:46:40
Helga
Hi,
bei deutscher Formel musst du FormulaLocal verwenden.
mfg Helga
AW: Zellen mit Formel ausfülen
06.01.2006 14:57:26
Erich
Hallo Helga
Vielen Dank für die Antwort,
aber die Fehler-Meldung bleibt
"Laufzeitfehler 1004
Anwendungs oder objektdefinierter Fehler"
Vieleicht hast Du noch eine andere Idee.
Gruss Erich
AW: Zellen mit Formel ausfülen
06.01.2006 16:54:03
Helga
Hi,
die "" in der Formel müssen auch in "" stehen, also """"
mfg Helga
Anzeige

318 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige