Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema MsgBox
BildScreenshot zu MsgBox MsgBox-Seite mit Beispielarbeitsmappe aufrufen

Einfügen von Bildern in Kommentar geht nicht mehr | Herbers Excel-Forum


Betrifft: Einfügen von Bildern in Kommentar geht nicht mehr von: Stefan K.
Geschrieben am: 30.11.2009 15:16:28

Hallo zusammen,
ich habe ein Problem mit folgenden Codezeilen:

For spalte = 4 To 13
'*********
If Cells(zeile, spalte).Hyperlinks.Count <> 1 Then 'Abfrage, ob Hyperlink vorhanden
GoTo weiter2
Else
Dim mycom As Object
On Error Resume Next
Pfad = ActiveWorkbook.Path
HyName = Pfad & "\" & Cells(zeile, spalte).Hyperlinks(1).Address
MsgBox HyName
With Cells(zeile, spalte)
.AddComment
'.Comment.Text Text:=HyName 'Pfad & Dateiname in Kommentar laden
Set mycom = .Comment.Shape
With mycom
.Fill.UserPicture Cells(zeile, spalte).Hyperlinks(1).Address 'Bild in Kommentar einfügen
.Width = 300
.Height = 200
End With
End With
End If

Hier werden anhand des Hyperlinks Vorschaubilder in den Kommentar geladen. Keine Angst, vor dem Speichern werden diese wieder rausgelöscht und beim Starten wird rein. So bleibt die Datei klein. Es funktioniert auch alles. Aber "plötzlich und unerwartet" bleiben die Kommentar-Kästchen leer. Hat einer von Euch Experten eine Idee, was ich verkehrt gemacht haben könnte ?
Im Voraus herzlichen Dank.
Gruß
Stefan K.

  

Betrifft: AW: Einfügen von Bildern in Kommentar geht nicht mehr von: Ramses
Geschrieben am: 30.11.2009 15:34:28

Hallo

Das ist nicht unerwartet und plötzlich sondern ganz normal,... so wie ich das lese.
Das Makro läuft auf einen Fehler wenn schon ein Kommentar der Zelle zugewiesen ist, und macht einfach weiter, dann wird aber das einfügen der Bilder nicht mehr vorgenommen.

Lösche mal die Zeile "On Error Resume next" und lass das Makro nochmals laufen und schau was dann passiert.

Ansonsten mal die Datei hochladen oder das gesamte Makro incl. Löschmakro hier mal zeigen.

Gruss Rainer


Beiträge aus den Excel-Beispielen zum Thema "Einfügen von Bildern in Kommentar geht nicht mehr"