Microsoft Excel

Herbers Excel/VBA-Archiv

Zeilen zufällig auswählen | Herbers Excel-Forum


Betrifft: Zeilen zufällig auswählen von: Nanuk
Geschrieben am: 12.11.2009 18:11:07

Hallo da draussen!
Mein erster Beitrag in diesem Forum an die Experten ;-)

Ich brauche einen Rat von Euch für meine Doktorarbeit. Ich habe eine Excel Tabelle erstellt, in der in jeder Zeile die Daten für einen "Fall" stehen. Es sind ca. 200 Zeilen.
Nun möchte ich aus diesen 200 Zeilen 20 zufällig auswählen. Damit das Ganze auch später noch nachvollziehbar bleibt, stelle ich mir das so vor, dass Excel mir in der ersten (bisher noch leeren Spalte) pro Zeile entweder "0" oder "1" generiert, wobei es nur 20 mal "1" sein darf. Ist so was prinzipiell möglich?
Wenn ja, wie mach ich das? Wenn nicht, wie komme ich anders ans Ziel?

Ich bin wirklich kein Excel-Held, deswegen bitte ich Euch, dass Ihr alles laaangsam und ohne internen Abkürzungen erklärt. Sonst verstehe ich nur die Hälfte...

Ich hoffe, dass mir jemand helfen kann. Vorab schon mal Danke für jede Antwort!

Viele Grüße, Nanuk

  

Betrifft: Zeilen zufällig auswählen von: Erich G.
Geschrieben am: 12.11.2009 18:32:39

Hallo Eisbär, :-))

kommst du damit klar?

 ABC
10,1740426 20
20,4836921  
30,55142934  

Formeln der Tabelle
ZelleFormel
A1=ZUFALLSZAHL()
B1=WENN(A1>=KGRÖSSTE(A$1:A$200;20); "x";"")
C1=ZÄHLENWENN(B:B;"x")
A2=ZUFALLSZAHL()
B2=WENN(A2>=KGRÖSSTE(A$1:A$200;20); "x";"")
A3=ZUFALLSZAHL()
B3=WENN(A3>=KGRÖSSTE(A$1:A$200;20); "x";"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Die Formel in C1 habe ich nur hingeschrieben, um zu zeigen, dass 20 xe geschrieben wurden.

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Zeilen zufällig auswählen von: Jens
Geschrieben am: 12.11.2009 23:07:43

Hallo Nanuk

Hier ein Beispiel:

https://www.herber.de/bbs/user/65837.xls

Gruß aus dem Sauerland

Jens


Beiträge aus den Excel-Beispielen zum Thema "Zeilen zufällig auswählen"