Dringend: Formel per VBA in Zelle schreiben

Bild

Betrifft: Dringend: Formel per VBA in Zelle schreiben von: Florian Scheidler
Geschrieben am: 14.02.2005 10:36:11

Hallo zusammen,

in meinem Code versuche ich je nach Situation eine andere Formel in eine Zelle zu schreiben. Irgendwie funktioniert das nicht so wirklich. Mein Code:

01 If Monatsauswertung = 0 Then
02
03 Sheets("Import").Select
04 Range("AO1").Value = "=ANZAHL2(B2:B5000)"
05 Range("AP1").Value = "=ZÄHLENWENN(B2:B5000;10)"
06
07 Else
08
09 Sheets("Import").Select
10 Range("AO1").Value = "=ANZAHL2(B2:B10000)"
11 Range("AP1").Value = "=ZÄHLENWENN(B2:B10000;10)"
12
13 End If

Es kommt z.B. bei der Zeile 05 der Laufzeitfehler 1004 "Anwendungs- oder objektdefinierter Fehler". Und die Zeile 04 bewirkt das in der Zelle nur #NAME? steht.

Mache ich irgendwas falsch? Wie schreibt man denn über VBA Formeln in Zellen??

Bitte helft mir recht schnell. Ist ein dringendes Problem!

Gruß Florian Scheidler

Bild


Betrifft: AW: Dringend: Formel per VBA in Zelle schreiben von: Jonny
Geschrieben am: 14.02.2005 10:38:50

Tipp: Benutz den Makrorekorder bei Formeln.... Mach ich auch...klappt wunderbar..

ausserdem sollte nach dem THEN ein "_" ...

Jonny


Bild


Betrifft: AW: Dringend: Formel per VBA in Zelle schreiben von: PeterW
Geschrieben am: 14.02.2005 10:43:28

Hallo Florian,

kann es sein, dass AP1 gesperrt ist? Um Formeln in Zellen zu schreiben benutze FormulaLocal
04 Range("AO1").FormulaLocal = "=ANZAHL2(B2:B5000)"

Gruß
Peter


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Dringend: Formel per VBA in Zelle schreiben"