Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Summewenns ungleich
01.07.2021 15:08:47
Finn
Hallo,
ich würde gerne eine Summewenns() erstellen, bei der das zweite Kriterium ungleich eines Textes ist.
Sprich: Summewenns(A1:A5;B1:B5;M3;C1:C5;ungleich"Unterzeichnet")
Wie kann ich das ungleich umsetzen?
Dankeschön! :)

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
ich nehme SUMMENPRODUKT
01.07.2021 15:19:48
WF
Hi,
=SUMMENPRODUKT((B1:B5=M3)*(C1:C5"Unterzeichner");A1:A5)
WF
Grafik mit mehreren Datengruppen
01.07.2021 15:44:34
Finn
Danke, das hilft schonmal.
Kann ich das mit einem "und" ergänzen? ALso:
=SUMMENPRODUKT((B1:B5=M3)*(C1:C5UND("Unterzeichnet";"Risk"));A1:A5)
?
AW: Grafik mit mehreren Datengruppen
01.07.2021 15:58:23
Daniel
Hi
Nein. UND kannst du da nicht einsetzten.
Hier wird gerechnet. Das Ergebnis der Vergleiche geht mit 1 (Wahr) und 0 (Falsch) in die Berechnung ein.
Eine UND- Verknüpfung entspricht dann einer Multiplikation, ein ODER einer Addition.
Außerdem musst du das schon korrekt formulieren und jeden Vergleich einzeln auffühern.
Umgangssprachlich sagen wir "C1 darf nicht gleich Unterzeichnet und Risk sein"
Korrekt wäre aber: "C1 darf nicht gleich Unterzeichnet sein und C1 darf nicht gleich Risk sein"
So musst du es dann in der Formel darstellen.
Gruß Daniel
Anzeige
Summenprodukt
01.07.2021 16:06:03
Finn
Danke für die Antwort.
Ich habe das ganze mal mit
=SUMMENPRODUKT((B1:B5=M3)*(UND(C1:C5"Unterzeichnet";;C1:C5"Risk"));A1:A5)
probiert, das klappt leider auch nicht. GIbt es Alternativen?
das ist nur eine Multiplikation mehr
01.07.2021 16:08:34
WF
Hi,
=SUMMENPRODUKT((B1:B5=M3)*(C1:C5"Unterzeichner")*(C1:C5"Risk");A1:A5)
WF
AW: geht schon mit SUMMEWENNS() ,,,
01.07.2021 16:16:20
neopa
Hallo Finn,
... so: =SUMMEWENNS(A:A;B:B;M3;C:C;"Unterzeichnet";C:C;"Risk")
Gruß Werner
.. , - ...
AW: Summenprodukt
01.07.2021 17:52:12
Daniel
Welchen Teil des Satzs "UND kannst du da nicht einsetzten." war zu kompliziert für dich, so dass du ihn nicht verstanden hast?
Gruß Daniel

310 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige